Problem with copying files to USB flash drive on Ubuntu 18.04.5 and Ubuntu 20.04 but this problem is not exist on Windows 10

Asked by Piotr on 2021-04-07

Dear Community,

I found problem probably with compability with one of the USB flash drive. I wanted to copy .jpg files from my HDD drive to USB flash drive and I noticed that copied files are broken so I thinked that is the problem with malfunction of my USB flash drive. I tried this same on other USB flash drive and copying files was successful. Okay so you probably will tell me that this is problem with device but I tried copy this same files on my other machine with Windows 10 and I can notice that on Windows machine I can copy files successful so this is not problem with USB flash drive device. So this is problem between Ubuntu and USB flash drive. On other OS this usb flash drive work perfectly.

I tried on Ubuntu 18.04 and livecd Ubuntu 20.04. Both OS can't properly copy files to this USB flash drive so this issue is still exist. How I can report this problem?

Of course I tried copy files on Ubuntu via terminal (cp -r command) and GUI method. Both methods fails on Ubuntu.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-08
Last reply:
2021-04-08
Piotr (peterq94) said : #1

It is very important me to fix this issue. I don't know if it is problem with kernel itself on other problem? What I should do to report this issue?

What file system are you using on the USB stick?

Piotr (peterq94) said : #3

This was "FAT". I formatted this USB flash drive by GNOME Disk so I think that this was FAT32. I formatted also on Windows 10 to FAT32 but this also not work. I mean that not work on Ubuntu because in Windows 10 I can copy any file on this USB Flash Drive and this work perfectly. I have problem only on Ubuntu. On other flash drive devices I have not problem. This is problem only with this one device.

Manfred Hampl (m-hampl) said : #4

If you verify the checksums of the copied files on your hard disk and on the USB stick (e.g. with the command "md5sum -b filename" or "sha512sum -b filename"), do you get identical values or do they differ?

Piotr (peterq94) said : #5

I will check this soon because this USB Flash drive is now out of my home. I will answer you soon.

Can you help with this problem?

Provide an answer of your own, or ask Piotr for more information if necessary.

To post a message you must log in.