Videos Won't Load on Any Site Besides YouTube

Asked by Max Erikson on 2021-04-06

Hello, I'm having trouble watching videos while using Ubuntu. The only website where videos play properly is YouTube. If I go to Vimeo, Dailymotion, Funimation, or even Reddit (unless the video's origin is YouTube), no video will play. I know the problem isn't with my browser, because I use the same browser (Firefox) on my other computer using Windows, and all of the settings are the same. So I think it must be a problem with Ubuntu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
IKONIK
Solved:
2021-04-14
Last query:
2021-04-14
Last reply:
2021-04-14
Drew Howden (drewhowden) said : #1

Try opening up a terminal, and running "sudo apt install ubuntu-restricted-extras".

Max Erikson (maxerikson) said : #2

How do I do that?

Drew Howden (drewhowden) said : #3

Just go to "Show Applications" > "Utilities" > "Terminal", and simply copy the command, paste it into the terminal window, and hit enter.

*The command will prompt you for your password. Type your password (the characters you type here will not show up, but you are indeed typing them), and hit enter. Next it will ask you to confirm installation of the package. Just hit enter here. And then it will install the package.

Best IKONIK (ikonik-arts) said : #4

Just happened to me yesterday, i installed ubuntu-restricted-extras, and vlc media player, and everything seems to be working fine. If you have recently upgraded ubuntu to 21.04, it might have broke some packages, and installing vlc might have reinstalled them or something.

To install these packages, open terminal, then type(or copy paste) the following:

sudo apt install ubuntu-restricted-extras [Press Enter and input your password]

sudo snap install vlc [Press Enter and input your password]

Note: when inputting your password the characters won't show up but you are indeed typing it.

Max Erikson (maxerikson) said : #5

I typed sudo apt install ubuntu-restricted-extras into the terminal. I pressed enter, then typed my password and hit enter again.
Instead of fixing anything, I got a line of text saying "Waiting for cache lock: could not get cache lock" followed by a bunch of other characters that got cut off by the screen I think, and this same line was repeated over and over again without stopping.

I thought I should type "sudo snap install vlc" at this point, but once I pressed the S key, the code just went bonkers. Eventually, I was shown this agreement thing I couldn't interact with, so I had to close the terminal.

Drew Howden (drewhowden) said : #6

Try rebooting your system, and running "sudo apt install ubuntu-restricted-extras" again.

Max Erikson (maxerikson) said : #7

I keep getting this end-user license agreement that I can't interact with.

Manfred Hampl (m-hampl) said : #8

To accept the license agreement use the tab and arrow keys until "ok" is highlighted and then press the space bar or the enter key.

Max Erikson (maxerikson) said : #9

I tried that already.

Max Erikson (maxerikson) said : #10

I tried it again, and this time it worked. I don't know why it didn't work last time. Anway, now the thing is installed and non-YouTube videos are playing in my web browser. Thanks!