noob needs help installing 4K videodownloader

Asked by thepeggasus@earthlink.net on 2021-03-16

I use 4K video downloader extensively. My wife bought me a Raspberry Pi 400 as I have talked about them and have been interested in Ubuntu and Linux. I am a noob.
1. I have tried all of the sudo apt-get upgrades and etc. to try to make sure I have all of the required dependencies.
2. I have tried to install it using WINE, but probably have done something wrong with that, as well. It will not let me get all of the dependencies (I think) even using the -f command.
3. I have tried the online guides without success. going to the directory to which I have the downloaded the application and right clicking to install has not worked either.

I get dependency problems and reports of things I need that I have not idea how to get in spite of using the first simple commands and others used in terminal that were supposed to solve all dependency problems.

4. Can someone type out a simple guide that a noob can follow to allow me to install the 4K video downloader? btw, I am using the Ubuntu on a 64 bit Raspberry Pi 400.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
thepeggasus@earthlink.net
Solved:
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the following commands (to be executed in a terminal window):

uname -a
lsb_release -crid
sudo apt update
sudo dpkg --audit

Manfred,
     Thank you for your answer. I really do appreciate it. I have decided that the Raspberry Pi 400 was a very poor choice by my wife for me to delve into Linux/Ubuntu/Raspbian. With its problem with the power off/on function, its tendency to fail to boot and having to guess when to pull the plug to turn it off and subsequently corrupting the drive on more than one occasion, I have decided to shelve looking into the OS for the time being. I Sudo apt-got the heck out of things, flashed the eeproms (which the off function actually worked a whole two times) and did everything I could learn to take care of the problem. The help desk informed me that it was a known problem, but I am tired of downloading images, trying to restore images and working with a piece of hardware that was, in my opinion, not ready to see the light of day. It has been a frustrating experience.
     Thanks again for your help.
Sincerely yours,
Gary Pegg (The Peggasus)

-----Original Message-----

>From: Manfred Hampl <email address hidden>
>Sent: Mar 17, 2021 2:30 AM
>To: <email address hidden>
>Subject: Re: [Question #696095]: noob needs help installing 4K videodownloader
>
>Your question #696095 on Ubuntu changed:
>https://answers.launchpad.net/ubuntu/+question/696095
>
> Status: Open => Answered
>
>Manfred Hampl proposed the following answer:
>For diagnostic purposes please provide the output of the following
>commands (to be executed in a terminal window):
>
>uname -a
>lsb_release -crid
>sudo apt update
>sudo dpkg --audit
>
>--
>If this answers your question, please go to the following page to let us
>know that it is solved:
>https://answers.launchpad.net/ubuntu/+question/696095/+confirm?answer_id=0
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/ubuntu/+question/696095
>
>You received this question notification because you asked the question.

Is it available for amrl (or arm64 if you used that)?

Manfred Hampl (m-hampl) said : #4

If you do not need any further help with this question, then please mark this question document as "solved", e.g. by visiting https://answers.launchpad.net/ubuntu/+question/696095 and pressing the related button.

I am giving up. I intend to see if the Raspberry Pi store will take their hardware back. I am through with dealing with it. I am putting this in the "solved" category. I thank you for your assistance.
thepeggasus

If the software creators don't make the software for the ARM CPU in your Pi then you will have issues. I can only see AMD64 debs for Ubuntu so you will need a 64bit AMD or Intel CPU to run it.
If you can find an alternative that is compiled for ARM CPU (Like youtube-dl maybe) then you can use this instead.