Video players don't work

Asked by Holtti on 2009-05-02

I updated Ubutu to 9.04 and after that every video player has stopped working. When I try to open a video-file the player shuts itself down except Totem which just doesn't play the video.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Patrick M
Solved:
2009-05-07
Last query:
2009-05-07
Last reply:
2009-05-07
Sérgio Bessa (sbsbessa) said : #1

What version did you upgrade from? Do you get some information on the log files?

Sérgio Bessa (sbsbessa) said : #2

What version did you upgrade from? Do you get some information on the log files?

Holtti (hode92) said : #3

I upgraded from version 8.10 and I didn't get any info from logs.

Biagio Marino (marino.biagio) said : #4

You might try reinstalling the codecs

Holtti (hode92) said : #5

I reinstalled codecs but it didn't help.

Alexander Jones (alex-weej) said : #6

Does Totem play the audio?

Does Totem show a "visualisation" instead of the video?

Does Totem prompt you to install missing codecs?

Tom (tom6) said : #7

Hmm, can you work through the Medibuntu worksheet again to try to get everything fixed properly for Jaunty. there might be some wonky repositories and things that need sorting out too and this is all in the guide here too
https://help.ubuntu.com/community/Medibuntu

Good luck and regards from
Tom :)

Patrick M (prmillius) said : #8

I am having the exact same problem. I thought it was codecs but is not, as I can do other things, such as edit video and COPY dvd/cd/blue ray, convert and burn from various formats. The issue seems to be with Jaunty, I say this because I had multiple players, none of which work. Also video can be played in play windows of editing soft ware. The codecs are there. Jaunty can't find them.

Open Question #69364, asked on 2009-04-29 by Patrick M

Patrick M (prmillius) said : #9

I can get it to go sort of. If I use xine or xfmedia to open one file, I get audio only. If I leave that running and then open a file with vlc the second one will play at the same time, but with video as well. then I close the fist file and have the video I want to play playing.

Tom (tom6) said : #10

Have you worked through the Medibuntu worksheet i gave a link to?

Holtti (hode92) said : #11

I have worked through the Medibuntu worksheet but it didn't help. Still all the video players keep shutting themselves down. Now even totem does so.

Holtti (hode92) said : #12

I ran vlc-player with terminal and I got following error-message:

[????????] x11 video output error: X11 request 132.19 failed with error code 11:
 BadAlloc (insufficient resources for operation)
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 132 (XVideo)
  Minor opcode of failed request: 19 ()
  Serial number of failed request: 81
  Current serial number in output stream: 82

If this help...

Tom (tom6) said : #13

Ahah. I found that going to a command-line and typing

gstreamer-properties

and then changing the Video output from "Auto" to "...(no Xv)" stopped movie players from shutting down. It migh also be helpful to try opening a movie player from the command-line, perhaps with the "verbose" tag, and then drop a movie onto the players window. Hopefully that would produce some output error messages in the terminal console which contained the command-line you used.

Please let us know the error messages you get.

Thanks and regards from
Tom :)

Tom (tom6) said : #14

Lol, thanks Holti lol :)
Err, i don't suppose you have tiny ram and no swap-partition? Is that the resource it's having trouble with? It'd be an easy one to fix so i hope that's the trouble although it seems unlikely!

Good luck and regards from
Tom :)

Tom (tom6) said : #15

Bad Alloc, sounds a lot like ram suffering some sort of corruption somehow? Could you test memory on some bootup? Sorry, it takes ages. Also bad alloc could easily be a hard-drive problem or something else :(

Holtti (hode92) said : #16

I just foun out that Totem is playing my videos but lags a bit. But I'm going to test memory.

Tom (tom6) said : #17

Laggy video sounds a lot like ram & swap issue, was right after all. Please let us know how much ram you have and what size your linux swap is. Try going up to the top taskbar and click on

Applications - Accessories - Terminal

and into the terminal/command window/console type

free

this should let us know how much ram & swap you have. Note that swap should really be between =Ram and =2xRam, more than 2xRam just wastes drive space (not really a problem) and less than Ram is only an issue sometimes. If you have a 2nd physical drive then it can sometimes increase performance a little if you can put a swap partition on the other drive from you main Ubuntu install.

Hope this helps!
Good luck and regards from
Tom :)

Best Patrick M (prmillius) said : #18

Tom& hollti:
I got my issue fixed, Toms advice about Gstreamer put me on the right track. Also opening vlc from the applications menu, going to tools:preferences: video and setting the Video output to x11 got evrything working including commercial DVDs

 hope this helps.

Tom (tom6) said : #19

Thanks Patrick, i've not heard of that way round working before buti'm glad to hear it does help sometimes. So it seems the "autodetect" can get it wrong either way around :(

Nicely fixed, congrats :)))
Regards from
Tom :)

Tom (tom6) said : #20

Swap size should be fairly easy to change but only fom a LiveCd as you'll need to umount both partitions and then open gparted

System - Administration - Partition Editor

(although i would use a faster distro like Wolvix to do this
http://distrowatch.com/table.php?distribution=wolvix
Either way when you've got gparted open you could umount (or 'unlock' or 'swapoff') the partition either before or after the swap, shrink it and then resize the swap to be a bit larger? Hope this helps holti!

Good luck and regards from
Tom :)

Holtti (hode92) said : #21

This worked also on my computer. I will check the memory for corruptions etc.

Thanks to everyone :)

Holtti

Tom (tom6) said : #22

Lol, if that fixed it then you're probably ok on your ram. Increasing swap might be worth doing, sometime, maybe, but don't worry about doing the memory check, it really is painfully long to check it. Glad to hear it's all working well now and i'm glad to hear i was wrong :)

Good luck and nicely done :)))
Regards from
Tom :)