Ubuntu 20.04.2 LTS not connecting to wireless (wifi)

Asked by Linda on 2021-02-21

I messed up something badly. My system did not have a settings menu, which happened because I had added the ppa:system76/pop repository, installed some things, then removed this repository. I tried to apt install gnome-control-center but it gave an error.

Then I did sudo ppa-purge ppa:system76/pop. Halfway through this as it was unpackaging, it popped up an alert suggesting I abort, because it was about to remove the currently active kernel. So I aborted and it ended with an error. Then up popped the software updater to install a different kernel version, so I allowed that to go through. Then it said it needed to restart, so I allowed it to restart. Bad mistake. It did reboot, but without a wifi connection.

There is no settings menu that shows wireless network options. I went through the official Ubuntu pages, but it didn't address this situation.

From the terminal command line:

lspci shows Network controller: Intel Corporation Wireless 7260 (rev 73)
iwconfig shows lo no wireless extensions
lshw -C network shows *-network UNCLAIMED for both network controller and ethernet controller
nmcli shows device lo, type loopback, state unmanaged, connection --

Any ideas? I would like to be able to reinstall Ubuntu 20.04.2 LTS, but I can't download it because I don't have an Internet connection.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-21
Last reply:
2021-02-21

Have you contacted the PPA maintainer. They may have an idea of what went on

Manfred Hampl (m-hampl) said : #2

What is the output of the command

lsb_release -crid

Jeremy (wa113y3s) said : #3

Might need to try this in terminal

sudo apt install --reinstall linux-modules-extra-$(uname -r)

Reboot

Linda (elindarie) said : #4

Thank you for your responses.

Actionparsnip, I will contact System76.

Manfred,

lsb_release -crid

gives

Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

Jeremy,

Trying

sudo apt install --reinstall linux-modules-extra-$(uname -r)

gave some error. I don't think it could work, maybe because the version number was messed up, but also because the wifi connection was broken.

However, I moved my /home directory to its own partition, saved some website stuff I was working on in /var, and re-installed Ubuntu from a live USB flash drive. My /home directory survived unscathed - so relieved after patiently following instructions and waiting for a download, altogether taking about 12 hours. I just did a normal install without downloading apps, because I was anxious to see if my /home directory survived.

Thank goodness I had a second computer here from my employer, so I could download the .iso installation boot file.

This all happened because I removed snap, but needed chromium, so I used the System76 pop repository, but that brought too much stuff along with it, causing long updates on a slow Internet connection. But somehow I didn't uninstall it properly. Anyways, the System76 person told me another non-snap chromium (saiarcot895) to install, so that was helpful.

If wiping everything out with a new install is considered a solution, then we can consider this solved, although it was sort of the nuclear option.

Jeremy (wa113y3s) said : #5

You might be able to get the grub menu up at boot, use either the shift or ESC key and use the Advanced Options, then choose an older kernel to boot into, see if you have internet then

Can you help with this problem?

Provide an answer of your own, or ask Linda for more information if necessary.

To post a message you must log in.