Wi-Fi doesn't connect easily and needs switching off the wifi adapter to connect

Asked by Sergio on 2021-02-19

I have a HP Pavilion dm 1 runing Ubuntu 20.10 with a Ralink WIFI adapter. The wifi connection runs for several minutes and fails to connect, if I switch off the adapter and connect again the connection works well again but only for 2 or 3 minutes.

sudo lshw -C network
[sudo] contraseña para sergio:
  *-network
       descripción: Ethernet interface
       id físico: 0
       información del bus: pci@0000:01:00.0
       nombre lógico: eno1
       versión: 06
       serie: 68:b5:99:e0:fa:24
       tamaño: 100Mbit/s
       capacidad: 1Gbit/s
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuración: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.8.0-43-generic duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.1.108 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:16 ioport:2000(size=256) memoria:f0004000-f0004fff memoria:f0000000-f0003fff
  *-network
       descripción: Interfaz inalámbrica
       id físico: 0
       información del bus: pci@0000:02:00.0
       nombre lógico: wlp2s0
       versión: 00
       serie: 90:00:4e:2b:62:d3
       anchura: 32 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuración: broadcast=yes driver=rt2800pci driverversion=5.8.0-43-generic firmware=0.40 ip=192.168.1.107 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       recursos: irq:17 memoria:f0100000-f010ffff

Thanks for your help, regards.

Sergio García

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jeremy
Solved:
19 hours ago
Last query:
19 hours ago
Last reply:
2021-02-21

Try:

echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci-fix.conf > /dev/null

Reboot to test. If there is no improvement then run:

sudo rm /etc/modprobe.d/rt2800pci-fix.conf

Then reboot again to revert

Sergio (sgarciagh) said : #2

No, it doesent works. Connects after reboot but after few minutes
connection to wifi fails.

:-(

Any other sugestion?

SG

El 19-02-21 a las 18:05, actionparsnip escribió:
> Your question #695651 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/695651
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Try:
>
> echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d
> /rt2800pci-fix.conf > /dev/null
>
> Reboot to test. If there is no improvement then run:
>
> sudo rm /etc/modprobe.d/rt2800pci-fix.conf
>
> Then reboot again to revert
>

Have you tried rebooting your router?

Sergio (sgarciagh) said : #4

I reboot my router and try to connect with several Access Points and
problem continues. Other computers and smartphones connected works fine.

Also the folder  /etc/modprobe.d/ already has the rt2800pci.conf file
with the line nohwcrypt=1. I remove it and the problem continues.

Regards

SG

El 20-02-21 a las 13:45, actionparsnip escribió:
> Your question #695651 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/695651
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Have you tried rebooting your router?
>

Best Jeremy (wa113y3s) said : #5

In terminal,

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot, see if it works better when Network Manager can't enable wifi power management

Sergio (sgarciagh) said : #6

The command doesent works. I edit the file and change the parameter form 3 to 2 and the problem continues.

Sergio (sgarciagh) said : #7

Hi, with wifi-posersave = 2 wifi works ok.

THANKS to all.

Sergio (sgarciagh) said : #8

Thanks Jeremy, that solved my question.