Nvidia driver not loaded on Ubuntu 20.04

Asked by CHEN on 2021-02-16

Hi, Nvidia card seems not being used on an Ubuntu 20.04

Here are the asked infos:

 lspci -nnk | egrep -i '3d|aphics|display|nouveau|nvidia|radeon|trident|vesa|vga'; uname -a; Xorg -version; sudo apt-get update; sudo apt-get install mesa-utils hardinfo fbset nux-tools inxi; inxi -F; sudo fbset -i; apt-cache show xserver-xorg | grep Version; xrandr; fglrxinfo; nvidia-settings -g |head -n 30 ; sudo lshw -short; sudo lshw -C display; dpkg -l | egrep -i 'fgl|intel|mesa|mesa-utils|nvidia|nouveau|radeon|trident|video-ati'; cat /etc/lsb-release; dmesg | egrep -i 'abort|ailed|bug|error|fail|fgl|GLX|GPU|intel|missing|nouveau|NVIDIA|radeon|segment|trident|VESA|VGA|wfb|\(EE\)|\(WW\)'; cat /proc/cpuinfo | grep -I model; cat /var/log/Xorg.0.log | egrep -i 'abort|ailed|bug|display|error|fail|fgl|GLX|GPU|intel|issing|nouveau|nvidia|radeon|segment|trident|VESA|VGA|wfb|\(EE\)|\(WW\)'; sudo dmidecode|egrep 'anufact|roduct|erial|elease'; cat /etc/X11/xorg.conf; /usr/lib/nux/unity_support_test -p; ubuntu-support-status || ubuntu-security-status ; sudo lsmod

# lspci -nnk | egrep -i '3d|aphics|display|nouveau|nvidia|radeon|trident|vesa|vga'; uname -a; Xorg -version; sudo apt-get update; sudo apt-get install mesa-utils hardinfo fbset nux-tools inxi; inxi -F; sudo fbset -i; apt-cache show xserver-xorg | grep Version; xrandr; fglrxinfo; nvidia-settings -g |head -n 30 ; sudo lshw -short; sudo lshw -C display; dpkg -l | egrep -i 'fgl|intel|mesa|mesa-utils|nvidia|nouveau|radeon|trident|video-ati'; cat /etc/lsb-release; dmesg | egrep -i 'abort|ailed|bug|error|fail|fgl|GLX|GPU|intel|missing|nouveau|NVIDIA|radeon|segment|trident|VESA|VGA|wfb|\(EE\)|\(WW\)'; cat /proc/cpuinfo | grep -I model; cat /var/log/Xorg.0.log | egrep -i 'abort|ailed|bug|display|error|fail|fgl|GLX|GPU|intel|issing|nouveau|nvidia|radeon|segment|trident|VESA|VGA|wfb|\(EE\)|\(WW\)'; sudo dmidecode|egrep 'anufact|roduct|erial|elease'; cat /etc/X11/xorg.conf; /usr/lib/nux/unity_support_test -p; ubuntu-support-status || ubuntu-security-status ; sudo lsmod
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics [8086:9b41] (rev 02)
        Subsystem: Tongfang Hongkong Limited UHD Graphics [1d05:107a]
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX250] [10de:1d13] (rev a1)
        Kernel modules: nvidiafb, nouveau
Linux kmcs 5.4.0-65-lowlatency #73-Ubuntu SMP PREEMPT Mon Jan 18 18:17:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-130-generic x86_64 Ubuntu
Current Operating System: Linux kmcs 5.4.0-65-lowlatency #73-Ubuntu SMP PREEMPT Mon Jan 18 18:17:38 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-65-lowlatency root=UUID=4e4c40ae-0244-4990-9e82-2e0d2da076dd ro quiet splash usbcore.autosuspend=-1 vt.handoff=7
Build Date: 17 January 2021 09:13:31AM
xorg-server 2:1.20.9-2ubuntu1.2~20.04.1 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.38.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Atteint :1 http://ppa.launchpad.net/ondrej/php/ubuntu focal InRelease
Atteint :2 https://linux.teamviewer.com/deb stable InRelease
Atteint :3 http://ppa.launchpad.net/saiarcot895/chromium-beta/ubuntu focal InRelease
Atteint :4 http://id.archive.ubuntu.com/ubuntu focal InRelease
Atteint :5 http://id.archive.ubuntu.com/ubuntu focal-updates InRelease
Réception de :6 http://id.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Atteint :7 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease
Atteint :8 http://security.ubuntu.com/ubuntu focal-security InRelease
101 ko réceptionnés en 1s (135 ko/s)
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
fbset est déjà la version la plus récente (2.1-31).
hardinfo est déjà la version la plus récente (0.5.1+git20180227-2).
inxi est déjà la version la plus récente (3.0.38-1-0ubuntu1).
mesa-utils est déjà la version la plus récente (8.4.0-1build1).
nux-tools est déjà la version la plus récente (4.0.8+18.10.20180623-0ubuntu1).
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  php7.4-phpdbg
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 226 non mis à jour.
System: Host: kmcs Kernel: 5.4.0-65-lowlatency x86_64 bits: 64 Console: tty 1
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine: Type: Laptop System: SLIMBOOK product: PROX14-10 v: Standard serial: Standard
           Mobo: SLIMBOOK model: PROX14-10 v: Standard serial: Standard UEFI: American Megatrends
           v: N.1.05 date: 02/21/2020
Battery: ID-1: BAT0 charge: 41.8 Wh condition: 42.2/46.7 Wh (90%)
CPU: Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP
           L2 cache: 8192 KiB
           Speed: 4830 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 4760 2: 4558 3: 4382
           4: 4453 5: 4575 6: 4617 7: 4799 8: 4364
Graphics: Device-1: Intel UHD Graphics driver: i915 v: kernel
           Device-2: NVIDIA GP108M [GeForce MX250] driver: N/A
           Display: server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.0.8
Audio: Device-1: Intel driver: snd_hda_intel
           Device-2: Focusrite-Novation Scarlett 2i4 USB type: USB driver: snd-usb-audio
           Sound Server: ALSA v: k5.4.0-65-lowlatency
Network: Device-1: Intel Wireless-AC 9462 driver: iwlwifi
           IF: wlo1 state: down mac: c8:09:a8:57:47:98
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: b0:25:aa:35:14:85
Drives: Local Storage: total: 957.62 GiB used: 400.09 GiB (41.8%)
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
           ID-2: /dev/sda type: USB model: USB Flash Disk size: 3.75 GiB
Partition: ID-1: / size: 61.79 GiB used: 45.53 GiB (73.7%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: swap-1 size: 62.70 GiB used: 22.1 MiB (0.0%) fs: swap dev: /dev/nvme0n1p3
Sensors: System Temperatures: cpu: 51.0 C mobo: 51.0 C
           Fan Speeds (RPM): N/A
Info: Processes: 389 Uptime: 4d 12h 01m Memory: 31.22 GiB used: 7.88 GiB (25.2%) Shell: bash
           inxi: 3.0.38

mode "1920x1080"
    geometry 1920 1080 1920 1080 32
    timings 0 0 0 0 0 0 0
    accel true
    rgba 8/16,8/8,8/0,0/0
endmode

Frame buffer device information:
    Name : i915drmfb
    Address : 0
    Size : 8294400
    Type : PACKED PIXELS
    Visual : TRUECOLOR
    XPanStep : 1
    YPanStep : 1
    YWrapStep : 0
    LineLength : 7680
    Accelerator : No
Version: 1:7.7+19ubuntu14
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080 60.01*+ 60.01 59.97 59.96 59.93
   1680x1050 59.95 59.88
   1600x1024 60.17
   1400x1050 59.98
   1600x900 59.99 59.94 59.95 59.82
   1280x1024 60.02
   1440x900 59.89
   1400x900 59.96 59.88
   1280x960 60.00
   1440x810 60.00 59.97
   1368x768 59.88 59.85
   1360x768 59.80 59.96
   1280x800 59.99 59.97 59.81 59.91
   1152x864 60.00
   1280x720 60.00 59.99 59.86 59.74
   1024x768 60.04 60.00
   960x720 60.00
   928x696 60.05
   896x672 60.01
   1024x576 59.95 59.96 59.90 59.82
   960x600 59.93 60.00
   960x540 59.96 59.99 59.63 59.82
   800x600 60.00 60.32 56.25
   840x525 60.01 59.88
   864x486 59.92 59.57
   800x512 60.17
   700x525 59.98
   800x450 59.95 59.82
   640x512 60.02
   720x450 59.89
   700x450 59.96 59.88
   640x480 60.00 59.94
   720x405 59.51 58.99
   684x384 59.88 59.85
   680x384 59.80 59.96
   640x400 59.88 59.98
   576x432 60.06
   640x360 59.86 59.83 59.84 59.32
   512x384 60.00
   512x288 60.00 59.92
   480x270 59.63 59.82
   400x300 60.32 56.34
   432x243 59.92 59.57
   320x240 60.05
   360x202 59.51 59.13
   320x180 59.84 59.32
HDMI-1 connected (normal left inverted right x axis y axis)
   4096x2160 30.00 25.00 24.00 29.97 23.98
   3840x2160 30.00 25.00 24.00 29.97 23.98
   1920x1080 60.00 50.00 59.94 30.00 25.00 24.00 29.97 23.98
   1920x1080i 60.00 50.00 59.94
   1600x1200 60.00
   1680x1050 59.88
   1400x1050 59.95
   1280x1024 75.02 60.02
   1440x900 59.90
   1280x960 60.00
   1280x800 59.91
   1152x864 75.00
   1280x720 60.00 50.00 59.94
   1024x768 75.03 70.07 60.00
   832x624 74.55
   800x600 72.19 75.00 60.32 56.25
   720x576 50.00
   720x576i 50.00
   720x480 60.00 59.94
   720x480i 60.00 59.94
   640x480 75.00 72.81 60.00 59.94
   720x400 70.08
fglrxinfo : commande introuvable

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

Chemin matériel Périphérique Classe Description
===================================================================
                                         system PROX14-10 (0001)
/0 bus PROX14-10
/0/0 memory 64KiB BIOS
/0/3b memory 32GiB Mémoire Système
/0/3b/0 memory Project-Id-Version: @(#) $Id$Report-Msgid-Bugs
/0/3b/1 memory 32GiB SODIMM DDR4 Synchrone 2667 MHz (0,4 ns)
/0/45 memory 256KiB L1 cache
/0/46 memory 1MiB L2 cache
/0/47 memory 8MiB L3 cache
/0/48 processor Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
/0/100 bridge Intel Corporation
/0/100/2 display UHD Graphics
/0/100/8 generic Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th
/0/100/12 generic Comet Lake Thermal Subsytem
/0/100/14 bus Intel Corporation
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/3 scsi1 storage Flash Disk
/0/100/14/0/3/0.0.0 /dev/sda disk 4027MB Flash Disk
/0/100/14/0/3/0.0.0/0 /dev/sda disk 4027MB
/0/100/14/0/3/0.0.0/0/2 /dev/sda2 volume 15EiB Windows FAT volume
/0/100/14/0/4 multimedia Scarlett 2i4 USB
/0/100/14/0/5 input USB Laser Mouse
/0/100/14/0/7 multimedia HD Webcam
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/14.2 memory RAM memory
/0/100/14.3 wlo1 network Wireless-AC 9462
/0/100/15 bus Serial IO I2C Host Controller
/0/100/16 communication Comet Lake Management Engine Interface
/0/100/17 storage Comet Lake SATA AHCI Controller
/0/100/1c bridge Intel Corporation
/0/100/1c/0 display GP108M [GeForce MX250]
/0/100/1d bridge Intel Corporation
/0/100/1d.3 bridge Intel Corporation
/0/100/1d.3/0 enp3s0 network RTL8111/8168/8411 PCI Express Gigabit Ethernet
/0/100/1d.4 bridge Intel Corporation
/0/100/1d.4/0 storage SSD 660P Series
/0/100/1e communication Intel Corporation
/0/100/1f bridge Intel Corporation
/0/100/1f.3 multimedia Intel Corporation
/0/100/1f.4 bus Intel Corporation
/0/100/1f.5 bus Comet Lake SPI (flash) Controller
/0/1 input PnP device PNP0303
/0/2 system PnP device PNP0c02
/0/3 generic PnP device INT3f0d
/0/4 system PnP device PNP0c02
/0/5 system PnP device PNP0c02
/0/6 system PnP device PNP0c02
/0/7 system PnP device PNP0c02
/1 power To Be Filled By O.E.M.
  *-display
       description: VGA compatible controller
       produit: UHD Graphics
       fabricant: Intel Corporation
       identifiant matériel: 2
       information bus: pci@0000:00:02.0
       version: 02
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration : driver=i915 latency=0
       ressources : irq:131 mémoire:64000000-64ffffff mémoire:40000000-4fffffff portE/S:7000(taille=64) mémoire:c0000-dffff
  *-display NON-RÉCLAMÉ
       description: 3D controller
       produit: GP108M [GeForce MX250]
       fabricant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list
       configuration : latency=0
       ressources : mémoire:65000000-65ffffff mémoire:50000000-5fffffff mémoire:60000000-61ffffff portE/S:6000(taille=128) mémoire:66000000-6607ffff
ii gir1.2-ibus-1.0:amd64 1.5.22-2ubuntu2.1 amd64 Intelligent Input Bus - introspection data
ii i965-va-driver:amd64 2.4.0-0ubuntu1 amd64 VAAPI driver for Intel G45 & HD Graphics family
ii ibus 1.5.22-2ubuntu2.1 amd64 Intelligent Input Bus - core
ii ibus-data 1.5.22-2ubuntu2.1 all Intelligent Input Bus - data files
ii ibus-gtk:amd64 1.5.22-2ubuntu2.1 amd64 Intelligent Input Bus - GTK2 support
ii ibus-gtk3:amd64 1.5.22-2ubuntu2.1 amd64 Intelligent Input Bus - GTK3 support
ii intel-media-va-driver:amd64 20.1.1+dfsg1-1 amd64 VAAPI driver for the Intel GEN8+ Graphics family
ii intel-microcode 3.20201110.0ubuntu0.20.04.2 amd64 Processor microcode firmware for Intel CPUs
ii iucode-tool 2.3.1-1 amd64 Intel processor microcode tool
ii libdrm-intel1:amd64 2.4.101-2 amd64 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-intel1:i386 2.4.101-2 i386 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-nouveau2:amd64 2.4.101-2 amd64 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-nouveau2:i386 2.4.101-2 i386 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-radeon1:amd64 2.4.101-2 amd64 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libdrm-radeon1:i386 2.4.101-2 i386 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libegl-mesa0:amd64 20.0.8-0ubuntu1~20.04.1 amd64 free implementation of the EGL API -- Mesa vendor library
ii libegl1-mesa:amd64 20.0.8-0ubuntu1~20.04.1 amd64 transitional dummy package
ii libgl1-mesa-dri:amd64 20.0.8-0ubuntu1~20.04.1 amd64 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-dri:i386 20.0.8-0ubuntu1~20.04.1 i386 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-glx:amd64 20.0.8-0ubuntu1~20.04.1 amd64 transitional dummy package
ii libglapi-mesa:amd64 20.0.8-0ubuntu1~20.04.1 amd64 free implementation of the GL API -- shared library
ii libglapi-mesa:i386 20.0.8-0ubuntu1~20.04.1 i386 free implementation of the GL API -- shared library
ii libglu1-mesa:amd64 9.0.1-1build1 amd64 Mesa OpenGL utility library (GLU)
ii libglx-mesa0:amd64 20.0.8-0ubuntu1~20.04.1 amd64 free implementation of the OpenGL API -- GLX vendor library
ii libglx-mesa0:i386 20.0.8-0ubuntu1~20.04.1 i386 free implementation of the OpenGL API -- GLX vendor library
ii libibus-1.0-5:amd64 1.5.22-2ubuntu2.1 amd64 Intelligent Input Bus - shared library
ii libigdgmm11:amd64 20.1.1+ds1-1 amd64 Intel Graphics Memory Management Library -- shared library
ii libmpx2:amd64 8.4.0-3ubuntu2 amd64 Intel memory protection extensions (runtime)
ii libnvidia-cfg1-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA binary OpenGL/GLX configuration library
ii libnvidia-common-450 450.102.04-0ubuntu0.20.04.1 all Shared files used by the NVIDIA libraries
rc libnvidia-compute-440:amd64 450.80.02-0ubuntu0.20.04.2 amd64 Transitional package for libnvidia-compute-450
ii libnvidia-compute-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA libcompute package
ii libnvidia-compute-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVIDIA libcompute package
ii libnvidia-decode-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA Video Decoding runtime libraries
ii libnvidia-decode-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVIDIA Video Decoding runtime libraries
ii libnvidia-encode-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVENC Video Encoding runtime library
ii libnvidia-encode-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVENC Video Encoding runtime library
ii libnvidia-extra-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 Extra libraries for the NVIDIA driver
ii libnvidia-fbc1-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA OpenGL-based Framebuffer Capture runtime library
ii libnvidia-fbc1-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVIDIA OpenGL-based Framebuffer Capture runtime library
ii libnvidia-gl-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii libnvidia-gl-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii libnvidia-ifr1-450:amd64 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA OpenGL-based Inband Frame Readback runtime library
ii libnvidia-ifr1-450:i386 450.102.04-0ubuntu0.20.04.1 i386 NVIDIA OpenGL-based Inband Frame Readback runtime library
ii libnvtt2:amd64 2.0.8-1+dfsg-8.2build2 amd64 NVIDIA Texture Tools
rc libpsm-infinipath1 3.3+20.604758e7-6 amd64 PSM Messaging library for Intel Truescale adapters
ii libwayland-egl1-mesa:amd64 20.0.8-0ubuntu1~20.04.1 amd64 transitional dummy package
ii mesa-utils 8.4.0-1build1 amd64 Miscellaneous Mesa GL utilities
ii mesa-va-drivers:amd64 20.0.8-0ubuntu1~20.04.1 amd64 Mesa VA-API video acceleration drivers
ii mesa-vdpau-drivers:amd64 20.0.8-0ubuntu1~20.04.1 amd64 Mesa VDPAU video acceleration drivers
ii mesa-vulkan-drivers:amd64 20.0.8-0ubuntu1~20.04.1 amd64 Mesa Vulkan graphics drivers
ii mesa-vulkan-drivers:i386 20.0.8-0ubuntu1~20.04.1 i386 Mesa Vulkan graphics drivers
ii nvidia-compute-utils-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA compute utilities
ii nvidia-dkms-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA DKMS package
ii nvidia-driver-440 450.102.04-0ubuntu0.20.04.1 amd64 Transitional package for nvidia-driver-450
ii nvidia-driver-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA driver metapackage
ii nvidia-kernel-common-450 450.102.04-0ubuntu0.20.04.1 amd64 Shared files used with the kernel module
ii nvidia-kernel-source-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA kernel source package
ii nvidia-prime 0.8.14 all Tools to enable NVIDIA's Prime
ii nvidia-settings 440.82-0ubuntu0.20.04.1 amd64 Tool for configuring the NVIDIA graphics driver
ii nvidia-utils-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA driver support binaries
ii python3-ibus-1.0 1.5.22-2ubuntu2.1 all Intelligent Input Bus - introspection overrides for Python (Python 3)
ii screen-resolution-extra 0.18build1 all Extension for the nvidia-settings control panel
ii whois 5.5.6 amd64 intelligent WHOIS client
ii xserver-xorg-video-ati 1:19.1.0-1 amd64 X.Org X server -- AMD/ATI display driver wrapper
ii xserver-xorg-video-intel 2:2.99.917+git20200226-1 amd64 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-nouveau 1:1.0.16-1 amd64 X.Org X server -- Nouveau display driver
ii xserver-xorg-video-nvidia-450 450.102.04-0ubuntu0.20.04.1 amd64 NVIDIA binary Xorg driver
ii xserver-xorg-video-radeon 1:19.1.0-1 amd64 X.Org X server -- AMD/ATI Radeon display driver
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.1 LTS"
[247803.591321] printk: Suspending console(s) (use no_console_suspend to debug)
[247805.133723] mei_me 0000:00:16.0: hbm: dma setup response: failure = 3 REJECTED
[247805.766287] usb 1-4: device descriptor read/64, error -71
[247805.986085] usb 1-4: device descriptor read/64, error -71
[247806.854769] thermal thermal_zone3: failed to read out thermal zone (-61)
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
model : 142
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 35.040] (==) Automatically adding GPU devices
[ 35.040] (==) Automatically binding GPU devices
[ 35.044] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 35.044] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 35.044] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 35.044] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 35.044] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 35.066] (II) LoadModule: "glx"
[ 35.067] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 35.079] (II) Module glx: vendor="X.Org Foundation"
[ 35.079] (==) Matched vesa as autoconfigured driver 2
[ 35.085] (II) LoadModule: "vesa"
[ 35.085] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 35.087] (II) Module vesa: vendor="X.Org Foundation"
[ 35.087] (II) VESA: driver for VESA chipsets: vesa
[ 35.114] (WW) Falling back to old probe method for fbdev
[ 35.115] (II) modeset(0): Creating default Display subsection in Screen section
[ 35.315] (II) modeset(0): glamor X acceleration enabled on Mesa Intel(R) UHD Graphics (CML GT2)
[ 35.345] (II) modeset(0): Digital Display Input
[ 35.345] (II) modeset(0): Digital interface is DisplayPort
[ 35.345] (II) modeset(0): First detailed timing is preferred mode
[ 35.345] (II) modeset(0): Supported detailed timing:
[ 35.374] (II) modeset(0): Digital Display Input
[ 35.374] (II) modeset(0): First detailed timing is preferred mode
[ 35.374] (II) modeset(0): Supported detailed timing:
[ 35.374] (II) modeset(0): Supported detailed timing:
[ 35.376] (II) UnloadModule: "vesa"
[ 35.376] (II) Unloading vesa
[ 35.584] (II) Initializing extension GLX
[ 35.591] (II) AIGLX: Loaded and initialized iris
[ 35.591] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 35.862] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event10)
[ 35.862] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event11)
[ 35.862] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event12)
[ 35.862] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=7 (/dev/input/event13)
[ 35.862] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=8 (/dev/input/event14)
[ 35.863] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=9 (/dev/input/event15)
[ 35.863] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=10 (/dev/input/event16)
[ 36.158] (EE) Failed to open authorization file "/var/run/sddm/{216f41b8-9923-4cf5-aea9-e3d54822996b}": No such file or directory
[ 36.171] (WW) Option "xkb_variant" requires a string value
[ 36.171] (WW) Option "xkb_options" requires a string value
[ 36.189] (WW) Option "xkb_variant" requires a string value
[ 36.189] (WW) Option "xkb_options" requires a string value
        Release Date: 02/21/2020
                Serial services are supported (int 14h)
        Manufacturer: SLIMBOOK
        Product Name: PROX14-10
        Serial Number: Standard
        Manufacturer: SLIMBOOK
        Product Name: PROX14-10
        Serial Number: Standard
        Manufacturer: SLIMBOOK
        Serial Number: Standard
        Port Type: Serial Port 16550A Compatible
        Manufacturer: To Be Filled By O.E.M.
        Serial Number: To Be Filled By O.E.M.
        Manufacturer: Not Specified
        Serial Number: Not Specified
        Module Manufacturer ID: Unknown
        Module Product ID: Unknown
        Memory Subsystem Controller Manufacturer ID: Unknown
        Memory Subsystem Controller Product ID: Unknown
        Manufacturer: 029E
        Serial Number: 00000000
        Module Manufacturer ID: Bank 3, Hex 0x9E
        Module Product ID: Unknown
        Memory Subsystem Controller Manufacturer ID: Unknown
        Memory Subsystem Controller Product ID: Unknown
        Manufacturer: Intel(R) Corporation
        Serial Number: To Be Filled By O.E.M.
                Debug Use USB(Disabled:Serial)
cat: /etc/X11/xorg.conf: Aucun fichier ou dossier de ce type
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics (CML GT2)
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.8

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes
ubuntu-support-status : commande introuvable
3340 packages installed, of which:
1659 receive package updates with LTS until 4/2025
1483 could receive security updates with ESM Apps until 4/2030
  62 packages are from third parties
 136 packages are no longer available for download

Packages from third parties are not provided by the official Ubuntu
archive, for example packages from Personal Package Archives in
Launchpad.
For more information on the packages, run 'ubuntu-security-status
--thirdparty'.

Packages that are not available for download may be left over from a
previous release of Ubuntu, may have been installed directly from a
.deb file, or are from a source which has been disabled.
For more information on the packages, run 'ubuntu-security-status
--unavailable'.

Enable Extended Security Maintenance (ESM Apps) to get 1 security
update (so far) and enable coverage of 1483 packages.

This machine is not attached to an Ubuntu Advantage subscription.
See https://ubuntu.com/advantage
Module Size Used by
uas 28672 0
usb_storage 77824 1 uas
xt_multiport 20480 1
snd_seq_dummy 16384 0
snd_hrtimer 16384 0
uvcvideo 98304 0
videobuf2_vmalloc 20480 1 uvcvideo
videobuf2_memops 20480 1 videobuf2_vmalloc
videobuf2_v4l2 24576 1 uvcvideo
videobuf2_common 53248 2 videobuf2_v4l2,uvcvideo
videodev 225280 3 videobuf2_v4l2,uvcvideo,videobuf2_common
snd_usb_audio 270336 2
snd_usbmidi_lib 36864 1 snd_usb_audio
mc 53248 5 videodev,snd_usb_audio,videobuf2_v4l2,uvcvideo,videobuf2_common
ipt_REJECT 16384 919
nf_reject_ipv4 16384 1 ipt_REJECT
nf_log_ipv4 16384 2
nf_log_common 16384 1 nf_log_ipv4
xt_LOG 20480 2
xt_limit 16384 2
xt_tcpudp 20480 35
xt_state 16384 0
xt_conntrack 16384 2
nf_conntrack 139264 2 xt_conntrack,xt_state
nf_defrag_ipv6 24576 1 nf_conntrack
nf_defrag_ipv4 16384 1 nf_conntrack
iptable_filter 16384 1
bpfilter 32768 0
snd_sof_pci 20480 0
snd_hda_codec_hdmi 61440 1
snd_sof_intel_hda_common 69632 1 snd_sof_pci
snd_soc_hdac_hda 24576 1 snd_sof_intel_hda_common
snd_sof_intel_hda 20480 1 snd_sof_intel_hda_common
snd_sof_intel_byt 20480 1 snd_sof_pci
snd_sof_intel_ipc 20480 1 snd_sof_intel_byt
snd_hda_codec_realtek 126976 1
snd_sof 106496 4 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc
snd_sof_xtensa_dsp 16384 1 snd_sof_pci
snd_hda_codec_generic 81920 1 snd_hda_codec_realtek
snd_hda_ext_core 28672 3 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_soc_acpi_intel_match 32768 2 snd_sof_pci,snd_sof_intel_hda_common
snd_soc_acpi 16384 2 snd_sof_pci,snd_soc_acpi_intel_match
ledtrig_audio 16384 3 snd_hda_codec_generic,snd_hda_codec_realtek,snd_sof
snd_soc_core 245760 3 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda
snd_compress 24576 1 snd_soc_core
ac97_bus 16384 1 snd_soc_core
snd_pcm_dmaengine 16384 1 snd_soc_core
snd_hda_intel 53248 3
snd_intel_dspcfg 24576 3 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common
snd_hda_codec 139264 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core 90112 9 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
nls_iso8859_1 16384 1
snd_hwdep 20480 2 snd_usb_audio,snd_hda_codec
snd_pcm 106496 9 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd_seq_midi 20480 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 36864 2 snd_seq_midi,snd_usbmidi_lib
intel_rapl_msr 20480 0
mei_hdcp 24576 0
snd_seq 69632 3 snd_seq_midi,snd_seq_midi_event,snd_seq_dummy
iwlmvm 385024 0
snd_seq_device 16384 3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer 36864 3 snd_seq,snd_hrtimer,snd_pcm
intel_rapl_common 24576 1 intel_rapl_msr
mac80211 856064 1 iwlmvm
x86_pkg_temp_thermal 20480 0
intel_powerclamp 20480 0
libarc4 16384 1 mac80211
joydev 24576 0
coretemp 20480 0
snd 86016 25 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi
kvm_intel 282624 0
iwlwifi 335872 1 iwlmvm
kvm 667648 1 kvm_intel
rapl 20480 0
intel_cstate 20480 0
asus_wmi 32768 0
input_leds 16384 0
cfg80211 716800 3 iwlmvm,iwlwifi,mac80211
sparse_keymap 16384 1 asus_wmi
serio_raw 20480 0
wmi_bmof 16384 0
mxm_wmi 16384 0
8250_dw 16384 0
hid_multitouch 28672 0
soundcore 16384 1 snd
mei_me 40960 1
mei 106496 3 mei_hdcp,mei_me
mac_hid 16384 0
acpi_tad 16384 0
acpi_pad 184320 0
sch_fq_codel 20480 2
cuse 16384 3
parport_pc 40960 0
ppdev 24576 0
lp 20480 0
parport 53248 3 parport_pc,lp,ppdev
ip_tables 28672 1 iptable_filter
x_tables 40960 9 xt_conntrack,iptable_filter,xt_LOG,xt_multiport,xt_state,xt_tcpudp,ipt_REJECT,ip_tables,xt_limit
autofs4 45056 2
btrfs 1249280 0
xor 24576 1 btrfs
zstd_compress 167936 1 btrfs
raid6_pq 114688 1 btrfs
libcrc32c 16384 2 nf_conntrack,btrfs
dm_mirror 24576 0
dm_region_hash 20480 1 dm_mirror
dm_log 20480 2 dm_region_hash,dm_mirror
usbhid 57344 0
hid_generic 16384 0
crct10dif_pclmul 16384 1
crc32_pclmul 16384 0
ghash_clmulni_intel 16384 0
i915 1990656 75
aesni_intel 372736 0
i2c_algo_bit 16384 1 i915
drm_kms_helper 184320 1 i915
crypto_simd 16384 1 aesni_intel
cryptd 24576 2 crypto_simd,ghash_clmulni_intel
syscopyarea 16384 1 drm_kms_helper
glue_helper 16384 1 aesni_intel
sysfillrect 16384 1 drm_kms_helper
nvme 49152 6
intel_lpss_pci 20480 0
sysimgblt 16384 1 drm_kms_helper
intel_lpss 16384 1 intel_lpss_pci
i2c_hid 28672 0
fb_sys_fops 16384 1 drm_kms_helper
idma64 20480 0
drm 487424 29 drm_kms_helper,i915
r8169 90112 0
ahci 40960 0
nvme_core 102400 8 nvme
i2c_i801 32768 0
realtek 24576 1
libahci 32768 1 ahci
virt_dma 20480 1 idma64
hid 131072 4 i2c_hid,usbhid,hid_multitouch,hid_generic
pinctrl_cannonlake 36864 1
wmi 32768 3 asus_wmi,wmi_bmof,mxm_wmi
video 49152 2 asus_wmi,i915
pinctrl_intel 28672 1 pinctrl_cannonlake

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-17
Last reply:
2021-02-17
Manfred Hampl (m-hampl) said : #1

Graphics:
           Device-1: Intel UHD Graphics driver: i915 v: kernel
           Device-2: NVIDIA GP108M [GeForce MX250] driver: N/A

You have a system with two graphics adapter. This probably requires installing bumblebee https://wiki.ubuntu.com/Bumblebee
Furthermore you might consider switching to the nvidia-driver-460 package.

CHEN (kmchen) said : #2

Yes , 2 graphics, but how to use the nvidia one ? I'd like to use the full resources of the computer.

What difference between bumblebee and the nvidia-driver-460 package ?

bumblebee seems to use the nvidia card only if we explicitly load it with optirun command ?

Tried to install 460:

~$ sudo apt install nvidia-driver-460
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-driver-460 : Dépend: libnvidia-gl-460 (= 460.32.03-0ubuntu0.20.04.1) mais ne sera pas installé
                     Dépend: nvidia-compute-utils-460 (= 460.32.03-0ubuntu0.20.04.1) mais ne sera pas installé
                     Dépend: xserver-xorg-video-nvidia-460 (= 460.32.03-0ubuntu0.20.04.1) mais ne sera pas installé
                     Dépend: libnvidia-ifr1-460 (= 460.32.03-0ubuntu0.20.04.1) mais ne sera pas installé
                     Recommande: libnvidia-compute-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommande: libnvidia-decode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommande: libnvidia-encode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommande: libnvidia-ifr1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommande: libnvidia-fbc1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommande: libnvidia-gl-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Manfred Hampl (m-hampl) said : #3

The nvidia card usually consumes far more power that the intel one, so it should be enabled only for applications that need it.

bumblebee/optirun switches the nvidia card on and off,
the nvidia driver package provides the driver.

What output do you receive for the command

LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460 xserver-xorg-video-nvidia-460 libnvidia-ifr1-460

CHEN (kmchen) said : #4

So it seems that there is no need to have an Nvidia card in case of usual use without 3D games ?

~$ LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460 xserver-xorg-video-nvidia-460 libnvidia-ifr1-460
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libnvidia-ifr1-460 : Depends: libnvidia-gl-460 but it is not going to be installed
 nvidia-driver-460 : Depends: libnvidia-gl-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-decode-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-encode-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Recommends: libnvidia-compute-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-decode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-encode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-ifr1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-fbc1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-gl-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #5

So it seems that there is no need to have an Nvidia card in case of usual use without 3D games ?

It is your choice to select the applications that use the NVidia adapter.

For the installation error, what is the output of the command

LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460 xserver-xorg-video-nvidia-460 libnvidia-ifr1-460 libnvidia-gl-460 libnvidia-decode-460 libnvidia-encode-460

CHEN (kmchen) said : #6

~$ LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-460 : Depends: libnvidia-gl-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-ifr1-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Recommends: libnvidia-compute-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-decode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-encode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-ifr1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-fbc1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-gl-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #7

The last command was incomplete, you have to give

LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460 xserver-xorg-video-nvidia-460 libnvidia-ifr1-460 libnvidia-gl-460 libnvidia-decode-460 libnvidia-encode-460

as one single command

CHEN (kmchen) said : #8

Here it is:

~$ LANG=C apt --simulate install nvidia-driver-460 nvidia-compute-utils-460 xserver-xorg-video-nvidia-460 libnvidia-ifr1-460 libnvidia-gl-460 libnvidia-decode-460 libnvidia-encode-460
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libnvidia-common-450 php7.4-phpdbg
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libnvidia-cfg1-460 libnvidia-common-460 libnvidia-compute-460 libnvidia-extra-460 libnvidia-fbc1-460 libnvidia-gl-460:i386 libnvidia-ifr1-460:i386 nvidia-dkms-460
  nvidia-kernel-common-460 nvidia-kernel-source-460 nvidia-utils-460
Recommended packages:
  libnvidia-compute-460:i386 libnvidia-decode-460:i386 libnvidia-encode-460:i386 libnvidia-fbc1-460:i386
The following packages will be REMOVED:
  libnvidia-cfg1-450 libnvidia-compute-450 libnvidia-compute-450:i386 libnvidia-decode-450 libnvidia-decode-450:i386 libnvidia-encode-450 libnvidia-encode-450:i386 libnvidia-extra-450
  libnvidia-fbc1-450 libnvidia-fbc1-450:i386 libnvidia-gl-450 libnvidia-gl-450:i386 libnvidia-ifr1-450 libnvidia-ifr1-450:i386 nvidia-compute-utils-450 nvidia-dkms-450 nvidia-driver-440
  nvidia-driver-450 nvidia-kernel-common-450 nvidia-kernel-source-450 nvidia-utils-450 xserver-xorg-video-nvidia-450
The following NEW packages will be installed:
  libnvidia-cfg1-460 libnvidia-common-460 libnvidia-compute-460 libnvidia-decode-460 libnvidia-encode-460 libnvidia-extra-460 libnvidia-fbc1-460 libnvidia-gl-460 libnvidia-gl-460:i386
  libnvidia-ifr1-460 libnvidia-ifr1-460:i386 nvidia-compute-utils-460 nvidia-dkms-460 nvidia-driver-460 nvidia-kernel-common-460 nvidia-kernel-source-460 nvidia-utils-460
  xserver-xorg-video-nvidia-460
0 upgraded, 18 newly installed, 22 to remove and 229 not upgraded.
Remv nvidia-driver-440 [450.102.04-0ubuntu0.20.04.1]
Remv nvidia-driver-450 [450.102.04-0ubuntu0.20.04.1]
Remv xserver-xorg-video-nvidia-450 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-cfg1-450 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-encode-450:i386 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-decode-450:i386 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-compute-450:i386 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-encode-450 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-decode-450 [450.102.04-0ubuntu0.20.04.1]
Remv nvidia-utils-450 [450.102.04-0ubuntu0.20.04.1]
Remv libnvidia-compute-450 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-extra-450 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-fbc1-450 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-fbc1-450:i386 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-ifr1-450 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-gl-450 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-ifr1-450:i386 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv libnvidia-gl-450:i386 [450.102.04-0ubuntu0.20.04.1] [nvidia-compute-utils-450:amd64 ]
Remv nvidia-compute-utils-450 [450.102.04-0ubuntu0.20.04.1]
Remv nvidia-dkms-450 [450.102.04-0ubuntu0.20.04.1]
Remv nvidia-kernel-common-450 [450.102.04-0ubuntu0.20.04.1]
Remv nvidia-kernel-source-450 [450.102.04-0ubuntu0.20.04.1]
Inst libnvidia-cfg1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-common-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [all])
Inst libnvidia-compute-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-decode-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-encode-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-extra-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-fbc1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-gl-460:i386 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-gl-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-ifr1-460:i386 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-ifr1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-compute-utils-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-kernel-source-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-kernel-common-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-dkms-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-utils-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst xserver-xorg-video-nvidia-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-driver-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-cfg1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-common-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [all])
Conf libnvidia-compute-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-decode-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-encode-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-extra-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-fbc1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-gl-460:i386 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-gl-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-ifr1-460:i386 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-ifr1-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-compute-utils-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-kernel-source-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-kernel-common-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-dkms-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-utils-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf xserver-xorg-video-nvidia-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-driver-460 (460.32.03-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Looks good. Can I launch it without the --simulate flag ?

Manfred Hampl (m-hampl) said : #9

The output shows two things:

1. When installing the nvidia-460 driver, the nvidia-440 and nvidia-450 drivers need to be uninstalled.
It is your choice, whether you want to try the 460 version.
The real installation is done by removing "--simulate" and adding "sudo" in front.
In case that the 460 version turns out not to work as desired, then you can revert to the 450 version with a similar command, replacing 460 by 450.

2. "0 upgraded, 18 newly installed, 22 to remove and 229 not upgraded."
There are updates available for 229 packages.
Is there a specific reason that you did not install them?

CHEN (kmchen) said : #10

Well, if nvidia 450 driver is installed already I don't need to install another.

Upgraded OK.

Installed bumblebee https://wiki.ubuntu.com/Bumblebee

Testing it:

$ optirun 0ad
[ 1926.676792] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 1926.676809] [ERROR]Aborting because fallback start is disabled.

CHEN (kmchen) said : #12

Tried this:

# depmod -av|grep nvidia
/lib/modules/5.4.0-65-lowlatency/kernel/drivers/video/fbdev/nvidia/nvidiafb.ko needs "fb_ddc_read": /lib/modules/5.4.0-65-lowlatency/kernel/drivers/video/fbdev/core/fb_ddc.ko
/lib/modules/5.4.0-65-lowlatency/kernel/drivers/video/fbdev/nvidia/nvidiafb.ko needs "i2c_bit_add_bus": /lib/modules/5.4.0-65-lowlatency/kernel/drivers/i2c/algos/i2c-algo-bit.ko
/lib/modules/5.4.0-65-lowlatency/kernel/drivers/video/fbdev/nvidia/nvidiafb.ko needs "save_vga": /lib/modules/5.4.0-65-lowlatency/kernel/drivers/video/vgastate.ko
/lib/modules/5.4.0-65-lowlatency/kernel/drivers/usb/typec/altmodes/typec_nvidia.ko needs "__typec_altmode_register_driver": /lib/modules/5.4.0-65-lowlatency/kernel/drivers/usb/typec/typec.ko
/lib/modules/5.4.0-65-lowlatency/kernel/drivers/usb/typec/altmodes/typec_nvidia.ko needs "dp_altmode_remove": /lib/modules/5.4.0-65-lowlatency/kernel/drivers/usb/typec/altmodes/typec_displayport.ko

Then modified bembmebee.conf:

# grep nvidia /etc/bumblebee/bumblebee.conf
# auto-detection is performed. The available drivers are nvidia and nouveau
# Should the program run under optirun even if Bumblebee server or nvidia card
# PMMethod: method to use for saving power by disabling the nvidia card, valid
## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
#KernelDriver=nvidia
KernelDriver=nvidiafb
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current:/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu
# comma-separated path of the directory containing nvidia_drv.so and the
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

Nothing changed

Manfred Hampl (m-hampl) said : #13

I do not understand why you now have "KernelDriver=nvidiafb" in your bumblebee.conf.
According to https://askubuntu.com/a/179379 and https://wiki.ubuntu.com/Bumblebee this is not correct.

CHEN (kmchen) said : #14

I did put it as a result of the command "depmod -av|grep nvidia" that gave nvidiafb as module name.

CHEN (kmchen) said : #15

There was "KernelDriver=nvidia" already as suggested in https://askubuntu.com/a/179379

Manfred Hampl (m-hampl) said : #16

I think you have to find out where the correct nvidia*.ko module is.
What do you receive for

find / -name "nvidia*.ko" -ls

Can you help with this problem?

Provide an answer of your own, or ask CHEN for more information if necessary.

To post a message you must log in.