error while loading shared libraries: libpulsecommon-11.1.so: cannot open shared object file: No such file or directory installing qemu-virgil on ubuntu 18.04 for arm64

Asked by Marietto on 2021-02-14

How to fix this ? (on ubuntu 18.04 for arm64 on jetson nano and I can't upgrade ubuntu from 18.04 to 20.04 because nvidia does not support 20.04 at the moment)

root@ziomario-desktop:# uname -a

Linux ziomario-desktop 4.9.140 #1 SMP PREEMPT Mon Feb 8 00:07:34 CET 2021 aarch64 aarch64 aarch64 GNU/Linux

root@ziomario-desktop:# sudo snap install qemu-virgil

error: snap "qemu-virgil" is not available on stable but is available to

install on the following channels:

edge snap install --edge qemu-virgil

Please be mindful pre-release channels may include features not

completely tested or implemented. Get more information with 'snap info

qemu-virgil'.

root@ziomario-desktop:# snap install --edge qemu-virgil

2021-02-14T13:09:37+01:00 INFO Waiting for automatic snapd restart...

qemu-virgil (edge) 4.2.0 from Oliver Grawert (ogra) installed

root@ziomario-desktop:# sudo snap connect qemu-virgil:kvm

root@ziomario-desktop:# qemu-virgil

/snap/qemu-virgil/62/usr/bin/qemu-system-x86_64: error while loading shared libraries: libpulsecommon-11.1.so: cannot open shared object file: No such file or directory

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-14
Last reply:
2021-02-14
Manfred Hampl (m-hampl) said : #1

libpulsecommon-11.1.so is contained in the package libpulse0 ("sudo apt install libpulse0"), but if that problem is shown for a snap application, then you have to ask at the snapcraft.io forum, I guess you should select the https://forum.snapcraft.io/c/snap/14 category.

Marietto (marietto2008) said : #2

I have installed these packages already : libpulse0 ; libpulse0:armhf ; libpulse-dev ; libpulse-dev:armhf ; pulseaudio ; pulseaudio:armhf. but the error still there.

Manfred Hampl (m-hampl) said : #3

That is what I meant. For *.deb packages you can add shared libraries, but snap packages need to have everything in the snap package itself. If you receive sich message for a snap package, then the snap file is broken and adding shared libraries via deb packages does not help. Report this to snapcraft.io.

Manfred Hampl (m-hampl) said : #5

Don't know whether it will help, but on https://github.com/wimpysworld/quickemu#installation there are more snap connects to be done, not only kvm

Marietto (marietto2008) said : #6

root@ziomario-desktop:# snap connect qemu-virgil:audio-record

root@ziomario-desktop:# snap connect qemu-virgil:raw-usb

root@ziomario-desktop:# snap connect qemu-virgil:removable-media
error: snap "qemu-virgil" has no plug named "removable-media"

root@ziomario-desktop:# qemu-virgil.arm64

/snap/qemu-virgil/62/usr/bin/qemu-system-aarch64: error while loading shared libraries: libpulsecommon-11.1.so: cannot open shared object file: No such file or directory

Can you help with this problem?

Provide an answer of your own, or ask Marietto for more information if necessary.

To post a message you must log in.