Internal hard drives are not detected even after changing controller to AHCI

Asked by Raghavendra S Bhat on 2021-02-14

Strange problem I have encountered when I was installing 20.04.2 LTS version of ubuntu.In the live USB each and every functions were working properly but when I opened files app it did not show any hard drives .I found out that storage controller was set to IDE so I changed it to AHCI but still no hopes,still the installer and the live USB not detecting any harddrives.
I cannot proceed installation. Installation type is empty.It shows only dev/sda which is my USB drive itself.
Things I have already tried
    1.Updated the BIOS
    2.Disabled secure boot and fast boot

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-14
Last reply:
45 minutes ago
Bernard Stafford (bernard010) said : #1

The Ubuntu live is just that live on the USB. You can install click the install icon. This Ubuntu install will find the hard drive during the actual installation with various options of how to format the hard drive.
https://ubuntu.com/tutorials/install-ubuntu-desktop#1-overview
If you decide to format your own hard drive on the installation type click do something else and the Gparted opens to manually partition your hard drive.

Can you help with this problem?

Provide an answer of your own, or ask Raghavendra S Bhat for more information if necessary.

To post a message you must log in.