recently i installed 20.04 but installer didn't install kernel

Asked by Stepan on 2021-02-08

 I was able to chroot into new system and install kernel with apt to complete installation this way. Official installer from Ubuntu.com was used(20.04.2). I would like to report a bug on this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2021-02-09
Last query:
2021-02-09
Last reply:
2021-02-08
Best Manfred Hampl (m-hampl) said : #1

Did you end up with a system without any kernel packages, or did you run into the problem that the kernel files (initrd, vmlinuz) were not correctly copied into the /boot directory (i.e. a boot loader problem)?

If you are sure that this is a bug and not caused by anything else, then please follow
https://help.ubuntu.com/community/ReportingBugs to report it.

The package name for the installer is "ubiquity",
see https://wiki.ubuntu.com/Bugs/FindRightPackage#When_installing_Ubuntu_.28or_Derivatives.29

The developers would like see the contents of the installer logs (e.g. /var/log/installer/syslog). If you have them still available, then you should add them to the bug report.
see https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Are you sure it didn't install GRUB but installed the kernel OK. This is more likely

Stepan (stepan111) said : #3

Thanks Manfred Hampl, that solved my question.

Stepan (stepan111) said : #4

Thanks guys,

I was able to create a bug and attached installer logs there - https://bugs.launchpad.net/ubuntu/+bug/1915114.

Also I am pretty sure that kernel wasn't installed.

To identify root cause I installed debian(which was operating normally ) to validata that it is not a secureboot isuue or something lke this. And then tried to manually boot ubuntu from debian's grub cli (ubuntu's grub didn't show up and reboot system ).