mouse acceleration not working with logitech G402 mouse

Asked by blue-on on 2021-02-06

it is really weird.
im only using G402 mouse (no dual mouse or something)
even though acceleration profile is set to 'adaptive' or 'default', cursor doesnt accelerates.

i tried to fix it by changing xinput props("libinput Accel Speed". "Coordinate Transformation Matrix") but it just only changes cursor speed. i also tried changing "libinput Accel Profile Enabled" and ran `xset m <acceleration> <threshold>` but it did nothing.

weird thing is, by changing accel profile to 'flat', it does something. speed adjusting slider's range grows too big, making slow to too slow, fast to too fast. it also changes default sensivity.

so both of profile is broken. i checked whether this is only ubuntu's problem or not by testing with USB live boot with only default packages.
turns out, all supported ubuntu and debian versions are affected. even with alternative DE variants.
latest fedora is affected too.
the mouse works fine on windows. what should i do?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Bernard Stafford (bernard010) said : #1

Only for diagnostic purpose: Open Terminal [ctl+alt+t] Paste Output: lsb_release -a; uname -a; python --version

blue-on (blue-on) said : #2

====command====
lsb_release -a; uname -a; python3 --version
====

====output====
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.10
Release: 20.10
Codename: groovy
Linux ubuntu 5.8.0-25-generic #26-Ubuntu SMP Thu Oct 15 10:30:38 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Python 3.8.6
====

taken from live USB, still has issue. changed 'python' to 'python3' because 'python' is removed from ubuntu repository.

Bernard Stafford (bernard010) said : #3

Top right corner of your screen open -> select settings -> scroll down to mouse and touchscreen -> adjust mouse speed & check that natural scrolling is in the off position.

blue-on (blue-on) said : #4

it is already turned off-which is default. i never edited any settings on testing enviroment.

Can you help with this problem?

Provide an answer of your own, or ask blue-on for more information if necessary.

To post a message you must log in.