Problem running Ubuntu 20.04 kernels

Asked by Matteo Ferrara on 2021-02-03

Ubuntu 20.04 don’t run with the new kernel.

When I choose the new kernel from GRUB menu I have the following errors during the loading ram disk:

can’t allocate initrd

And after pressing another button such as chiesto:

eri: EFI_MAMMAP is not enabled

The default Kernel installed work.

Could be the motherboard ?
I haven’t this problem on virtual machine with another PC.

Thanks

Matteo

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Matteo Ferrara
Solved:
2021-02-04
Last query:
2021-02-04
Last reply:
2021-02-04

I suggest you report a bug. You can boot old kernels by holding SHIFT at boot then choosing the older kernel

Manfred Hampl (m-hampl) said : #3

A possible reason for such message could be a failure during the update.
What are the version numbers of the failing and the working kernels?

What is the output of
ls -l /boot

Matteo Ferrara (mat21) said : #4

The installed kernels are:
                                                           - 5.4.0-42-generic (default install)
                                                           - 5.4.10-rt5
                                                           - 5.8.0-41-generic (default install)

For each version are present the corispective files vmlinuz, System.map, initrd.img and config-5...

I have to use the 5.4.10-rt5 version, i tried this version on virtual machine and work.

I tried other version such as 5.1.13, 5.5.0 (also not RT kernel) and these also present this error.

I'm doing other tries now.

thanks

Matteo Ferrara (mat21) said : #5

Now i tried the version 5.9.0-rt5 and in this case i have another error:

error: can't allocate initrd
x86/cpu VMX (outside txt) disabled by BIOS

the errors change

Manfred Hampl (m-hampl) said : #6

Please provide the _full_ output of the commands

uname -a
lsb_release -crid
ls -l /boot

Manfred Hampl (m-hampl) said : #8

Why didn't you just copy/paste the text into this question document? This would have been much easier for us.

Where did you get the *rt* kernels? As far as I know they are not provided by standard Ubuntu.

Wich one of the four versions does work and which one doesn't?
5.4.0.42-generic
5.4-10-rt5
5.8.0-41-generic
5.9.1-rt20

Matteo Ferrara (mat21) said : #9

Because I'm using another PC, sorry.

I took the *rt* kernels of the site : https://www.kernel.org/pub/linux/kernel/projects/rt/ indicated of the linux kernel archives site.

Yesterday I tried not rt version and i got the same error.

The versions that work are: 5.4.0.42-generic and 5.8.0-41-generic (default install).

The versions that not work are: 5.4-10-rt5 and 5.9.1-rt20.

All version work on virtual machine of another PC.

Manfred Hampl (m-hampl) said : #10

This is support for Ubuntu, and the Ubuntu kernels work well, only those from a foreign source don't.
So this is not an Ubuntu problem and hence not really the right place.

"x86/cpu VMX (outside txt) disabled by BIOS"
Have you checked the BIOS of the system, if there is a switch to enable this?

Do you have the newest version of the BIOS available for your system?

Matteo Ferrara (mat21) said : #11

I tried with VMX enable but is don't work.

The BIOS isn't updated.

Matteo Ferrara (mat21) said : #12

Thanks everyone for the help.

I solved the problem.

The image wasn't being loaded because the size was too big.
After reducing the size the new kernel is work.

Best regards