touchpad intermittently not working

Asked by Francis Merlino on 2021-02-02

## info ##

Thinkpad P14s(AMD)
Kubuntu 20.10
(also tried with kubuntu 20.04)

I am trying to either, find a fix or, discover which bug to file a report against.

## issue ##

Sometimes when I turn the machine on the touchpad just doesn't work. I'll have to reboot numerous times to fix the issue. If I leave the machine off overnight it seems on the first boot the touchpad will start working again (could be coincidence?).

## attempted remedies/diagnosis ##

I have tried both synaptic and libinput, same issue.
I cannot see anything that stands out in the logs, admittedly i am not confident in what I am looking at. The kernel seems to recognize the touchpad properly. I cannot see anything different between the logs when the touchpad does and doesn't work.

I have tried modprobe and that has no effect. the trackpoint(joystick mouse thing in the keyboard) will stop working and then start working again when I re-enable the module.

## additional info ##

A friend has the same machine as me and he has no issues. he is running Ubuntu 20.04. so could be a plasma issue. What is the difference between plasma and gnome in relation to touchpad?

Just purchased the machine. It is a replacement for same model that was DOA and the DOA one had the same issue with the intermittent failure of the touchpad.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-06
Last reply:
2021-02-07
Francis Merlino (fwmm) said : #1

forgot to mention: I tried evtest. And physical depress of the Touchpad is detected but no scrolling or tapping.

Do you have the latest BIOS?

Francis Merlino (fwmm) said : #3

Yep, BIOS and firmware are up to date.

Do you get touch pad issues in the live USB desktop as well?

Francis Merlino (fwmm) said : #5

So I have been trying the live USB, approx 15 times. not once has the touchpad NOT worked when booting the live usb.

Are there any options about the touch pad in BIOS?
Could also try the boot option

i8024.reset

May help

Francis Merlino (fwmm) said : #7

The option in BIOS is on/off. I have added i8024.reset to grub boot parameters. I will keep trying and report back.
what is i8024?
if adding this solves the issue, what does that mean?
Is it something to file a bug for, or not really?

thank you for taking the time to help out.

Does the boot option work? There are other similar options available on i8024. Honestly not 100% sure what it is but it seems to be something to do with touch pads. It's a kernel option that makes the kernel act different.

You can also try:

i8024.nopnp
i8024.nomux

Another option I've seen (works for Sonys sometimes but worth a try) ir

Irqpoll

Francis Merlino (fwmm) said : #9

The touchpad has just stopped working. The only change I made to the boot options i8024.reset.

Francis Merlino (fwmm) said : #10

another funny thing, which has happened too often to be a coincidence, if I restart the touchpad does not start working. However, if I shutdown, the touchpad will start working on next boot.

Can you help with this problem?

Provide an answer of your own, or ask Francis Merlino for more information if necessary.

To post a message you must log in.