rpi 400 img - vmware player

Asked by treloar on 2021-02-01

I saw this: https://ubuntu.com/download/raspberry-pi/thank-you?version=20.10&architecture=desktop-arm64+raspi

I wanted to try it out in Vmware Player to see how it is before going off and buying a rpi 400, alas I cannot install it... so far I tried

unxz ubuntu-20.10-preinstalled-desktop-arm64+raspi.img.xz

to get to just a img file and that doesn't work, so next I tried

qemu-img convert -O vmdk ubuntu-20.10-preinstalled-desktop-arm64+raspi.img.img ubuntu-20.10-preinstalled-desktop-arm64+raspi.vmdk

And installed it to VMWare as a HDD and tried to boot it and that doesn't work either.

How can I trial your software before going out and buying hardware for it to run on to know it works?
I'd hardly want to buy hardware for software that doesn't work.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-03
Last reply:
2021-04-18
Manfred Hampl (m-hampl) said : #1

Which processor architecture does your host system have?
As far as I know you cannot run software for arm processors in virtualization on hardware with intel/amd processors.
This might be possible with an emulator, e.g. qemu

treloar (treloar) said : #2

x86_64

treloar (treloar) said : #3

Well I tried qemu and qemu-system-arm and it doesn't work either stating the img is corrupt, I've downloaded it on multiple PC's and OS now and copied it across to the system I specifically set qemu up on and its always corrupt

treloar (treloar) said : #4

I've given up

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.