update downloads won't install

Asked by Neil E Mac on 2021-01-31

updates of pkgs etc won't install after being downloaded. I get a msg saying they're downloaded but won't install when I click 'install.' How do I ask using a terminal? Am a relative newby and shy about 'coding.' Please help me get things flowing again.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-02-04
Last reply:
2021-02-05

This question was reopened

Wim (launchpad-xs4all) said : #1

Neil,

You ask how to fix this in a Terminal Window. Here is the description:

Open a Terminal Window, you will see a screen with a line like
neil@YouPcName:~$

If you internet connection is working on this machine, enter this command

   sudo apt-get update

followed by the <Enter>-key on your keyboard; you will have to enter your password, this is a normal security issue in linux.
Now the most actual information of programs will be downloaded, so the most actual info is known by your PC.

If you want to install all new versions of the programs you use, enter the command

   sudo apt-get upgrade

The apt-get program is now downloading (some more) programs and install them on your machine.

Once apt-get is completely ready, you can close this Terminal Window by giving the command

   exit

Hopes this is the info you wanted.
Wim

Terminal gives better text unlike GUI apps

Neil E Mac (neilemac) said : #3

yes, thank you; used the terminal and chose to upgrade system which it did. However, Ubuntu doesn't list installed apps. What should I do to obtain that list?

Neil E Mac (neilemac) said : #4

Not sure how this site uses replies; after upgrade, Ubuntu still doesn't list apps associated with the OS. What do I do now?

Manfred Hampl (m-hampl) said : #5

Press the "super" key (bottom left of the keyboard, probably a windows logo or apple logo on it), and you should get a pop-up window where you can search for installed apps.
Is this what you want?
If not, then please re-formulate your question that we understand what you are looking for.

Neil E Mac (neilemac) said : #6

The 'super' button worked, a box appeared but after a few seconds searching 'installed apps,' I rec'd msg. saying 'No Results.'
Really strange considering I've a host of apps installed. Thanks for attempt to solve my issue.

Manfred Hampl (m-hampl) said : #7

Sorry, I was not clear enough.
The "super" key helps if you know whet you are looking for (e.g. "update").
If you want some kind of overview about available apllications you better do a mouse click on the nine dots in the bottom left corner of the screen.

Can you help with this problem?

Provide an answer of your own, or ask Neil E Mac for more information if necessary.

To post a message you must log in.