Updated 20.10 via software updater now my entire system hangs on boot mounting sequence, system completely bricked

Asked by Ryan on 2021-01-18

The most recent update has made it literally impossible to repair anything in order to log in. This is infuriating

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-20
Last reply:
2021-01-20
Ryan (1n00buntu1) said : #1

No recovery mode options help , deleting frontend locks did not help, attempting to run yannubuntu is impossible because I am inable to type into the terminal from my install media(even though i am able to type into other fields terminal is dysfunctional).

Ryan (1n00buntu1) said : #2

I managed to run yannubuntu now I am loading into grub saying that normal.mod is not found. As far as I can tell I have to set this using my known filesystem, how do I ensure I am using the correct filesystem.

When you say "yannubuntu" do you mean boot repair?

Ryan (1n00buntu1) said : #4

yes I have managed to run boot repair and it put me in grub recovery mode, now I am trying to find vimlinuz on my filepartition since normal.mod isnt there

Manfred Hampl (m-hampl) said : #5

Do you have a separate partition for /boot ?

I suggest following https://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd but if you have a separate /boot partition, you have to add some commands.

Ryan (1n00buntu1) said : #6

that appears to be the case, also i boot repaired on a flash containing 20.04 instead of 20.10, im going to try to use 20.10 to boot-repair and see if it will help.

Ryan (1n00buntu1) said : #7

Still nothing is working, I am stuck trying to install grub and its telling me it cannot find an EFI directory even though I have tried every possible directory.

Manfred Hampl (m-hampl) said : #8

My suggestion:
Follow https://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd
with a small addition:

after
sudo mount -t ext4 /dev/sdXY /mnt
add the command
sudo mount -t ext4 /dev/sdXZ /mnt/boot

where /dev/sdXY and /dev/sdXZ are the partitions with your root file system and the boot partition respectively.

at the very end
before
sudo umount /mnt
issue the command
sudo umount /mnt/boot

In case that you are not sure whether you have a separate /boot partition, I suggest that you run boot-repair in the "info" mode and provide (a link to) the output of that script.

Ryan (1n00buntu1) said : #9

grub-install still returns "cannot find EFI directory"

Ryan (1n00buntu1) said : #10

Here is the boot info summary from boot-repair: https://paste.ubuntu.com/p/kHgKqs86Pw/

Manfred Hampl (m-hampl) said : #11

You will probably need an additional mount:

sudo mount -t ext4 /dev/sdb7 /mnt
sudo mount -t ext4 /dev/sda1 /mnt/boot
sudo mount -t vfat /dev/nvme0n1p1 /mnt/boot/efi

(and the reverse
sudo umount /mnt/boot/efi
sudo umount /mnt/boot
sudo umount /mnt
afterwards)

Ryan (1n00buntu1) said : #12

ok thanks, ill try this

Ryan (1n00buntu1) said : #13

ok I went through all those steps and im still met with grub rescue> error file /grub/i386-pc/normal.mod not found

Ryan (1n00buntu1) said : #14

I am quite frustrated, Is there a way I can back up my files using the live usb then just reinstall the OS. As far as I can tell my grub folder has no i386-pc folder with normal.mod and i cant figure out how I would use a comand to copy it from the usr/lib where people say it is. Because I cannot access these filesystems I can only operate through live USB or grub-rescue.

Sure. You can mount the internal partitions from live CD/USB desktop and then make a copy as you need

Ryan (1n00buntu1) said : #16

Ok, thank you. I really appreciate you trying to help, I have pretty much exhausted anything I could find online and I tried the guide you sent like 3 times. This is very important though because this all came from a mainline update through software updater GUI. This type of result is very strange for a mainline update as far as I can tell, or it should be. Do you know what causes this?

Manfred Hampl (m-hampl) said : #17

Before you wipe the system, I suggest trying it again, a very last time. There probably was a typo error in my lastest list of commands which should have lead to an error message.

What output do you receive for the following command sequence when done from a live system:

sudo mount -t ext4 /dev/sdb7 /mnt
sudo mount -t ext4 /dev/sdb1 /mnt/boot
sudo mount -t vfat /dev/nvme0n1p1 /mnt/boot/efi

sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

grub-install /dev/sdb
grub-install --recheck /dev/sdb
update-grub

exit

sudo umount /mnt/sys
sudo umount /mnt/proc
sudo umount /mnt/dev/pts
sudo umount /mnt/dev

sudo umount /mnt/boot/efi
sudo umount /mnt/boot
sudo umount /mnt

Now please copy/paste the output and then reboot

Ryan (1n00buntu1) said : #18

I did notice the sdb instead of sda typo on my first run. The grub install said it worked with no errors. However when booting it just went into grub rescue again. I will try it again, however im not sure if anything will be different.

Manfred Hampl (m-hampl) said : #19

Just an addition:

after the "grub-install" and "update-grub" commands, check whether at that moment the file /boot/grub/i386-pc/normal.mod exists.

Ryan (1n00buntu1) said : #20

I have already reinstalled a new version of 20.10 after it didnt work. I recovered all my data so its fine on my end. Thank you for your time and support.

Manfred Hampl (m-hampl) said : #21

If the problem has been resolved and you do not need further help with that issue, then please mark this question document as "solved".

Can you help with this problem?

Provide an answer of your own, or ask Ryan for more information if necessary.

To post a message you must log in.