Ubuntu 20.04 "No Display Driver," "E: Unable to locate package mesa"

Asked by Tiberias on 2021-01-17

I installed possibly the wrong AMDGPU on my fresh install of 20.04 LTS. There were errors in the install and no matter what I did, it would not uninstall. So I blacklisted the driver. I rebooted and it's gone, but now Ubuntu says I have no driver and my resolution is set really low with only that option. I am trying to install mesa but even though I have the kisak ppa, I am getting an "E: Unable to locate package mesa". In the glxinfo command below, all of the "mesa" references are red which may mean that they are not permitted to be executable? In the Software and Updates "Additional Drivers" app preinstalled with Ubuntu, it has not once ever offered me another driver or even recognized that I was once using an amdgpu driver. I need help with this issue, thanks!

//Terminal outputs:

glxinfo | grep Mesa
client glx vendor string: Mesa Project and SGI
    Vendor: Mesa/X.org (0xffffffff)
OpenGL vendor string: Mesa/X.org
OpenGL core profile version string: 4.5 (Core Profile) Mesa 20.3.3 - kisak-mesa PPA
OpenGL version string: 3.1 Mesa 20.3.3 - kisak-mesa PPA
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.3.3 - kisak-mesa PPA

sudo lshw -c video
[sudo] password for joana:
  *-display UNCLAIMED
//removed
configuration: latency=0
//and more, removed.

sudo apt update
Hit:1 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Hit:2 http://ppa.launchpad.net/kisak/kisak-mesa/ubuntu focal InRelease
//And more, removed.

sudo apt install mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mesa

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Tiberias
Solved:
2021-01-19
Last query:
2021-01-19
Last reply:
2021-01-17

I suggest you remove the PPA and start again from there. What are you trying to achieve please?

Manfred Hampl (m-hampl) said : #2

A short explanation for "E: Unable to locate package mesa":

"mesa" is the name for the source package, but with "apt install" you install the binary packages which are named differently, e.g. libegl-mesa0, libegl1-mesa, libgl1-mesa-dri, mesa-opencl-icd, ...

And the general recommendation for your problem:
If this is a new installation that you have botched, the easiest way is wiping it and starting from scratch with a new installation.

If you use a PPA and if you have a problem with the software from it, then you have to solve the problem yourself or contact the provider of the PPA. answers.launchpad.net/ubuntu is not the right address for problems with software from a PPA.

Tiberias (tiberiusfury) said : #3

I have taken your advice and just reinstalled my OS. First I tried Drauger, but it had no support for encrypted volumes!! So I salvaged that by installing Pop!_OS and I am pretty pleased with it!
I have not tried installing AMD drivers, but I don't suspect I will need them with my current performance. The default installed drivers (probably mesa) are working great.

Thanks for your answers.