Executing Grub-install /dev/sda error during installation

Asked by Cikitta Tjok on 2021-01-12

I was using Windows 10 OS, and wanted to install Ubuntu alongside my current OS. I used Rufus to create the bootable USB, with default settings. However, that option is missing so I clicked "something else"* option and install Ubuntu manually. Then, an error pop-up shows saying "Executing Grub-install /dev/sda failed, this is a fatal error". I tried to do reboot and it says "Ubuntu boot failed". Then I tried to mess with BIOS setting and now my BIOS setting won't even recognize my Windows as an operating system. Ubuntu actually once recognized my Windows and "broken" Ubuntu. I boot again from my bootable USB and this time it didn't recognize my Windows anymore. I tried to replace my "broken" Ubuntu with the new one from my bootable USB but same problem occurred again. What should I do to either install Ubuntu properly or bringing Windows back without any problem?

*Here are my something else settings:
- Root with 30 GB of space;
- Home with 100 GB of space;
- Swap with 9 GB of space;
- EFI with 1 GB of space.

Other information:
- Ubuntu version: 20.04.1 LTS
- I have 500 GB hard drive disk and I don't have unallocated space anymore, the Installer took all the spaces :(
- My Windows boot type/mode is Legacy
- I can't find secure boot setting on BIOS
- I don't want two OS's anymore.. I don't mind If I need to fully wipe my disk, I prefer using Linux actually
- I am now running my bootable USB since I can't boot into any installed operating system
- I am not a tech-savvy.. I'm a new Linux user

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-12
Last reply:
2021-01-13
Bernard Stafford (bernard010) said : #1

https://ubuntu.com/tutorials/install-ubuntu-desktop#1-overview
Feel free to re open question if you need more information

Can you help with this problem?

Provide an answer of your own, or ask Cikitta Tjok for more information if necessary.

To post a message you must log in.