Support needed for bricked login - “Oh no! Something went wrong” screen

Asked by Pablo Palomo López on 2020-11-18

Recently, I've had to flush my disks due to a Windows update bug and I had lost my Ubuntu 20.04 disk, which worked perfectly. However, after installing Windows and Linux again, and trying to set up Ubuntu 20.04, I've received multiple times the brick screen "Oh no! Something went wrong" when trying to login, after changing some settings of gnome, such as dock or desktop icons (yeah, it's unbeliavable that the brick is being caused by gnome settings, but it's true since I tested it reinstalling 20.04 and only changing gnome settings; after rebooting, the brick screen appeared.

I have tried solutions found in post like [this][1] or [this][2], but none of them worked. Since I'm not an experienced Linux user, I'm feeling lost when trying to debug what is going on, such as greping `/var/log/` files, but I don't not where neither what to search. I'm still providing the content of `syslog` file with `grep error`, just in case any helpful information relies [there][3].

If anybody could help me solving this problem I would be so grateful, I've been struggling with this for weeks and after asking in many forums and not getting response, I'm a little bit desperate, since I can't work in my job without my Ubuntu desktop :(

So please, if I can provide any information that could be useful, ask me and I'll do it as quickly as I can.

[UPDATE]: Here you can see the content of crash file (_usr_sbin_gdm3.0.crash): [link][4].

  [1]: https://askubuntu.com/questions/1239025/after-upgrade-to-ubuntu-20-04-oh-no-something-went-wrong
  [2]: https://superuser.com/questions/917377/how-do-i-fix-oh-no-something-has-gone-wrong-gdm3-fails-to-start
  [3]: https://hastebin.com/raw/ojafazuyez
  [4]: https://controlc.com/914ae515

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-18
Last reply:
2020-11-19

This question was reopened

Is the system fully updated? If you press CTRL + ALT + F1 you can log in there and get fully updated in CLI using:

sudo apt-get update
sudo apt=get -y upgrade
sudo apt-get -y dist-upgrade
sudo reboot

This will ensure your packages are up to date and may help. Ubuntu 20.04 has been out for 7 months so you'll have some updates to grab

Pablo Palomo López (lr55drk) said : #2

Yes, it is fully updated. I've been so careful with that before updating. However, since I've found the crash file being related to gdm3 instead of gnome, the problem might be easier to find (see UPDATED line in original post if you missed it).

Pablo Palomo López (lr55drk) said : #3

I've tried to change from gdm3 to lightdm and check if I could login, but the brick screen appeared again. However, a lightdm crash file didn't appear in /var/crash.

Pablo Palomo López (lr55drk) said : #4

Providing more information, doing "sudo cat /var/log/syslog | grep -i gdm3 | grep -i error", the following line appears:

Nov 18 16:25:29 pakitoUX kernel: [ 33.483023] gdm3[1152]: segfault at 1 ip 00007f19d5c5e77a sp 00007ffdb1b2f740 error 4 in libgobject-2.0.so.0.6400.3[7f19d5c30000+36000]

Manfred Hampl (m-hampl) said : #5

For diagnostic purposes please provide the output that you receive for the commands

uname -a
lsb_release -crid
apt-cache policy libglib2.0-0 gdm3

Can you help with this problem?

Provide an answer of your own, or ask Pablo Palomo López for more information if necessary.

To post a message you must log in.