Windows 10 repair loop after installing ububtu

Asked by Tom Byars on 2020-11-18

After installing ubuntu on my ms surface pro 4 windows 10 laptop the dual boot system worked fine. For a few hours I was able to log into both ubuntu 20.04 and windows 10. I don't recall doing anything on windows during that testing period. Since then I've been able to log into ubuntu fine but on windows I get the automatic repair / diagnosing loop. I've tried pretty much everything I've found via google (I might even have exacerbated the problem) but I'm still stuck in the loop. I downloaded boot-repair in ubuntu and ran it but it didn't fix anything. The boot-repair log is here https://paste.ubuntu.com/p/FQhgGsqxkk/

Anyone help?

PS I'm a total newbie so be gentle with your answers.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-27
Last reply:
2020-11-26

This question was reopened

If Windows is loop booting then I suggest you boot to your Windows install media and run a full CHKDSK on the C: to make sure the files are complete and consistent.

Tom Byars (buntur) said : #2

I already tried that but got 'no problems found'. I noticed in the boot-repair log

nvme0n1p4: _____________________________________________________________________

    File system: ntfs
    Boot sector type: Windows 8/2012: NTFS
    Boot sector info: According to the info in the boot sector, nvme0n1p4
                       starts at sector 130283520. But according to the info
                       from fdisk, nvme0n1p4 starts at sector 996282368.
    Operating System:
    Boot files:

I don't know if that's the root of my problem but if I try
bootrec /fixboot
in windows command prompt I get 'access is denied'.

Tom Byars (buntur) said : #3

I have to say my initial ubuntu experience has not been a happy one. I tried a windows repair that, at best, would've let me back in minus my apps and still the repair loop persisted. As I can access many of my files within ubuntu and my OneDrive files via another laptop this wouldn't be a disaster if ubuntu itself was working well for me but the wi-fi drops out randomly. From googling I see this is a long standing problem with ms surface machines. I've tried many of the s suggestions but the problem, while not as bad, persists. In addition, probably related to this, I often experience a lengthy wait for a restart. Sometimes after a restart the trackpad doesn't work properly.

Tom Byars (buntur) said : #5

Thanks Bernard. That might have helped me before I installed but I don't see much that can help me now. As I said earlier, after installation I could start up both Windows 10 & Ubuntu 20.04 from the boot menu and did so numerous times. A few hours later though I only had access to Ubuntu as when I accessed Windows it would always go into repairing / diagnosing and finish with unable to repair. Ubuntu is still working fine and I have at least been able to fix the wi-fi by turning powersave to off. The trackpad still doesn't work after a hibernate (not after a restart as I stated earlier).

Manfred Hampl (m-hampl) said : #6

If your windows system runs into a repair loop, then this is a windows problem that Ubuntu cannot solve.
You should try finding help in a windows support forum.

Tom Byars (buntur) said : #7

That ship's already sailed but please note that I also posted ubuntu related problems.

Can you help with this problem?

Provide an answer of your own, or ask Tom Byars for more information if necessary.

To post a message you must log in.