Livepatch does not work (is not supportted) in 20.10

Asked by Luhein Lategan on 2020-10-24

2020/10/24 16:16:51 error executing enable: Livepatchd error: The platform Ubuntu 20.10 is not supported. exiting.

Nothing much more I can say actually.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-10-27
Last query:
2020-10-27
Last reply:
2020-10-24

I suggest you report a bug

Best Manfred Hampl (m-hampl) said : #2

Read the documentation!

https://ubuntu.com/security/livepatch
"The Canonical Livepatch Service delivers live kernel patching to Ubuntu LTS systems without the need to reboot. "

Ubuntu 20.10 is no LTS release, so Livepatch is not available.

Luhein Lategan (luhein) said : #3

Thank you for the responses, Andrew and Manfred.

Just a clarification. I use Ubuntu from a "village idiot" perspective. So everything must just work. I have no desire to go and read up or search why something does not work. I believe that is the profile of 99% of PC users. Ubuntu is a magnificent platform and it has made enormous strides to get to a point "where everything just works". So extremely proud and also excited to use Ubuntu - albeit as a "curious to see" system...thus duel booting my PC.

Ubuntu is now at a stage where the average village idiot can install it and I have confidence that everything will work.

My view is that now Ubuntu can look at integrating the outstanding 20+ items to make this the best desktop experience on earth. Examples are - Integrate extensions, Enable partner repositories, the restricted packages, enable minimize on click etc. I cannot believe that it cannot and should not be done.

To come back to the Livepatch. The village idiot in me says: Why only on LTS?And if there are technical reasons for it - then it must not form part of the software update box - as it confuses village idiots like me.

Lastly - I got Conky and Conky manager to work on 20.04. On 20.10 Conky manager needs upgrading I believe - but lots of the skins and also extensions that worked in 20.04 does not work or only certain portions work on 20.10. Why? I dont know. For me it was a nice challenge to get Conky and Conky manager to work on 20.04 - but the average village idiot will not go through that exercise. But to spend hours trying to figure out why something works in 20.04 and not in 20.10 ...Nope. Do not have the desire - so just leave it.

Ubuntu is magnificent and village idiots like me are the last link. It must just work - and it does...

Thanks and have a great day

Luhein Lategan (luhein) said : #4

Thanks Manfred Hampl, that solved my question.