Updating the thinkfan package

Asked by Jan-Hendrik Müller on 2020-10-13

At the moment, when one types `sudo apt-get install thinkfan` it will install thinkfan 0.9.1, however this is quit ancient.
There is the most recent version here: https://github.com/vmatare/thinkfan/releases/tag/1.2.1

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-10-13
Last reply:
2020-10-13

What is the output of:

lsb_release -a; uname -a

The fact it is "ancient" is fairly irrelevant in Ubuntu. If the version is supported and has no significant bugs or security issues then the package will be left in favour of more problematic ones. Ubuntu mainly champions stability over keeping up with the latest package versions. It is not a rolling release distribution.

If you log a bug and report the bug and security issues then it may be updated sooner rather than later, or you can build from source

Manfred Hampl (m-hampl) said : #2

Manfred Hampl suggests this article as an answer to your question:
FAQ #3037: “no rolling release”.

Can you help with this problem?

Provide an answer of your own, or ask Jan-Hendrik Müller for more information if necessary.

To post a message you must log in.