gnome-terminal drops display scaling on new tab creation

Asked by Pavel Vasilyev on 2020-10-09

In my setup I have Ubuntu 20.04 running in VirtualBox on Windows. I connect to the Windows machine through Microsoft Remote Desktop from Macbook Pro with Retina Display. Since it is retina display, Windows does rescaling. In Ubuntu I have to go to Settings -> Display and set Scale to 200%. I had opened gnome-terminal before, so I just press Ctrl-Shift-T to create a new tab. Together with opening a new tab, scaling drops to a default value which is 100%. Same can be reproduced if I run tmux session.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Do you do all the work on the Ubuntu system in the terminal / move files around in nautilus?

Pavel Vasilyev (rokrpv) said : #2

I do all the work in the gnome-terminal.

OK, what system are you running gnome-terminal on? Do you RDP to Windows to open the console to Ubuntu to then launch a terminal? Is that what you are doing?

Pavel Vasilyev (rokrpv) said : #4

> OK, what system are you running gnome-terminal on?
Ubuntu 20.04

> Do you RDP to Windows to open the console to Ubuntu to then launch a terminal?
I run Ubuntu inside VirtualBox. VirtualBox is running on Windows. I open the console inside Ubuntu:

Mac OS Catalina -- (RDP) --> Windows 10 -- (VirtualBox) --> Ubuntu 20.04 -> gnome-terminal

Then why not install openssh-server on Ubuntu and SSH from the Mac directly to the Ubuntu system? Why mess around with RDP?

The SSH client (On the Mac) will then scale as expected as its running on the Mac......why all the extra steps??

I assume you set the Ubuntu system to have a bridged network so it's visible on the LAN and will get an IP from your router.

Don't you think this would be a muh sleeker solution?

Mac -SSH > Ubuntu

rather than

Mac OS Catalina -- (RDP) --> Windows 10 -- (VirtualBox) --> Ubuntu 20.04 -> gnome-terminal

If you do ALL work in the terminal....... No?

Pavel Vasilyev (rokrpv) said : #6

No, because all ports except RDP one are closed.

Is this your own LAN? opening port 22/TCP to the Ubuntu guest's IP would make your life a LOT easier. You can even lock it down so that only your Mac can only communicate with the Ubuntu IP over SSH to secure the setup

If you aren't willing to do this then all I can suggest is to report a bug to get the issue resolved. You could even SSH from the Windows desktop to the Ubuntu system to the Ubuntu system. Even that would be better than what you are doing presently and would not leave the Windows system, meaning no firewall changes need to occur

Pavel Vasilyev (rokrpv) said : #8

No, it is not my LAN, it is VPN connection, I do not control that network. So yes, I have to use this setup. Windows 10 is also a host system, I can't install Ubuntu as a host system. I know, but I still need to run some GUI applications, and I could even run Xming, but the scaling with this thing works even worse.

No but you can install PuTTY on Windows and use it to connect to the Ubuntu host. Does this work? I'm not suggesting a change to the host OS.

Pavel Vasilyev (rokrpv) said : #10

Yes, I can, but how it solves the following issues:
- running GUI applications
- having multiple tabs in the terminal.

True about GUI apps. You can use X forwarding in SSH and they'll run on the server but display in the Windows OS (like in Citrix if you are familiar). It's messy but works.

Multiple tabs you can work around using screen. You can switch between screens using shortcut keys (recommended if you use a lot of CLI).

The X forwarding is a bit silly though and I'd probably use the console session as you do if I was running GUI apps too.

Let's see how the bug report goes. The OS shouldn't snap back to previous settings as you are seeing

Pavel Vasilyev (rokrpv) said : #12

As I wrote earlier, I could use Xming, but the apps are blurry, when I'm using Xming. This is also fixable, but creates other issues.

I use tmux instead of screen. And as I wrote, tmux also restores scaling when run it in the gnome-terminal. Running it in PuTTY is an option, but I lose some flexibilities when I run everything outside the virtual machine. E.g. saving states of running apps and terminals when shutting down the virtual machine.

Can you help with this problem?

Provide an answer of your own, or ask Pavel Vasilyev for more information if necessary.

To post a message you must log in.