App icons don't show, double clicking don't make it run

Asked by William Pabon on 2020-10-07

Hi!:
Just upgraded Ubuntu from 18.04 to 20.04.1 and everything seemed to be working ok: applications executed from the dock and also choosing them from All Applications. Then I go to /usr/share/applications and find that the desktop files there do not have the corresponding icon for each application, and if I double click them, they don't run, it opens the desktop file. Will appreciate any help on this issue. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-10-08
Last query:
2020-10-08
Last reply:
2020-10-08

Have you set your own personal icon set? If you change the icon theme is it OK?

William Pabon (williepabon) said : #2

Hi Andrew:

After upgrading to 20.04, for me is the first time that I go to the applications folder and see the files without their normal icons. See the link below:

https://drive.google.com/file/d/1r7NfHI23jaQjLqMgHrwRzhEQ0J8_fOUO/view?usp=sharing

And as I said above, if I double click any app there, instead of launching, it opens the desktop file. Maybe, this is a characteristic of the OS now. I'm trying all the apps now from the All Applications screen and apparently, they seem to work. Haven't tried them all, yet. Maybe, with this upgrade, I need to learn to do things differently as far as working with the apps folder. Please, advice.

Seems that desktop files re associated with the text editor.

I don't have access to a desktop Linux OS, maybe others can see what these are ran with and you can make the association again

William Pabon (williepabon) said : #4

Andrew:

OK. Will wait then until I receive new ideas on how to solve this. Thanks.

Best Manfred Hampl (m-hampl) said : #5

I tried this (browsing to the /usr/share/applications folder and doing a doubleclick on a *.desktop file) on my Ubuntu 20.04 system and it behaves the same way as yours. The icon is not shown, the application does not open, but the file is opened in the text editor.

But: I have never tried this before, and this seems not to be a recommended action at all.

The preferred way to start an application where you have a *.desktop file on your system (either in the /usr/share/... folder, or below your home directory in ~/.local/share/application) is a mouse click on the nine dots in the bottom left corner of the screen and selecting the application (with icon) from the list.

Remark: On Ubuntu 18.04 the system behaves the way that you were used to.

William Pabon (williepabon) said : #6

Manfred:

Thank you. So, Ubuntu 20.04 has a different behaviour than the previous versions on the applications folder. Now I will need to find out if I can create a *.desktop file app manually, save it in the applications folder and verify that it shows in the All Applications screen (clicking the dotted square you said above). Thanks again for the clarification.

William Pabon (williepabon) said : #7

Thanks Manfred Hampl, that solved my question.