Epson Workforce 600 won't print documents

Asked by Matthew Walker on 2020-10-07

I have just installed Ubuntu 20.04 onto my desktop and laptop computers. After installing the correct driver from Seiko-Epson Corporation, my Epson Workforce 600 will print a test page, but everything else feeds through blank. The page feeds at the proper speed, and the print head moves appropriately, but no ink is released onto the page. I have tried looking on multiple forums, and Google-ing my issue, but - as a novice user of Ubuntu - I am in over my head.

The printer is connected to my desktop computer via a usb cable, but my laptop communicates with the printer over my wireless network. I have made sure the printer has been installed appropriately on each machine: both computers are yielding the same results.

Can someone please walk me through a (relatively) simple series of steps to get my printer working properly?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew Walker
Solved:
2020-10-14
Last query:
2020-10-14
Last reply:
2020-10-09
Bernard Stafford (bernard010) said : #1

If you disconnect the USB from the Printer will the laptop print a document over its WiFi connection?

Bernard Stafford: I have tried both desktop and laptop computers; both with USB cable, and both over WiFi - the outcome is always the same. I'm wondering if I've set something up incorrectly with CUPS, or if there is a driver-specific issue because I have been able to achieve the results listed below.
print test page: (what I will call) coloured DVD images print, but no text below
print PDF documents: successful
print webpage: only HTML elements will print
***any LibreOffice documents (Writer, Spreadsheets, etc), or any "text" will not print.

For example, if I was to print this webpage, the resulting printout would show the headings "Language:", "Status:", etc., but none of our message text, nor the information below the headers would show up. It seems any "input" related field will not print. I hope that makes sense... I'm not sure of the proper terminology to explain it.

Most importantly: thank you for stepping in to assist. I am quite grateful for your assistance!

After some experimentation, I was able to solve my printing problem with both desktop and laptop computers.
First: I removed my existing printer through the settings.
Second: Using Synaptic Package Manager, I completely removed all Epson-related protocalls, and activated all guten-related protocols.
Third: I restarted my machines.
Finally: I added my printer, printed a test page, tried a few different types of files to print (.odt; .pdf, etc.), and everything worked!
Problem solved!