20.04 Focal upgrade fails, can't mark packages for upgrade

Asked by bgarnham on 2020-10-07

Upgrade from 18.04.5 to 20.04.1 fails.

/var/log/dist-upgrade/main.log shows:

2020-10-06 20:35:21,194 DEBUG Marking 'xubuntu-core' for upgrade
2020-10-06 20:35:21,349 WARNING Can't mark 'xubuntu-core' for upgrade (E:Unable to correct problems, you have held broken packages.)
2020-10-06 20:35:21,349 DEBUG Marking 'xubuntu-desktop' for upgrade
2020-10-06 20:35:21,525 WARNING Can't mark 'xubuntu-desktop' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2020-10-06 20:35:21,526 DEBUG Marking 'ubuntu-mate-core' for upgrade
2020-10-06 20:35:21,666 WARNING Can't mark 'ubuntu-mate-core' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2020-10-06 20:35:21,667 DEBUG Marking 'ubuntu-mate-desktop' for upgrade
2020-10-06 20:35:21,809 WARNING Can't mark 'ubuntu-mate-desktop' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2020-10-06 20:35:51,326 ERROR Dist-upgrade failed: 'Broken packages after upgrade: xubuntu-core, xubuntu-desktop'

Synaptic shows no broken packages.

$ sudo apt update --fix-missing
...All packages are up to date.

$ sudo apt install -f
...0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ dpkg --get-selections | grep hold
(returns nothing.)

Any help would be greatly appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-10-10
Last query:
2020-10-10
Last reply:
2020-10-09

What is the output of:

sudo apt-get update; sudo apt-get --purge autoremove; sudo apt-get upgrade

Thanks

bgarnham (bgarnham) said : #2

Thanks for looking into this, actionparsnip.

$ sudo apt-get update
Ign:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://dl.google.com/linux/earth/deb stable Release
Hit:4 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit:5 http://www.geogebra.net/linux stable InRelease
Get:6 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:8 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Fetched 252 kB in 2s (161 kB/s)
Reading package lists... Done

$ sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

bgarnham (bgarnham) said : #3

I, foolishly, hadn't checked this log yet since I haven't been able to detect any broken packages using syaptic or apt but the upgrade apt log seems to show so many broken packages that I'm surprised it's even running... It seems a fair assumption this is where the problem stems from. Do you have any idea as to how to proceed?

/var/log/dist-upgrade/apt.log

Log time: 2020-10-06 20:34:33.675900
Log time: 2020-10-06 20:34:36.236064
Log time: 2020-10-06 20:35:17.539722
  MarkInstall python-is-python2:amd64 < none -> 2.7.17-4 @un uN Ib > FU=1
  Installing python2 as Depends of python-is-python2
    MarkInstall python2:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
    Installing python2-minimal as PreDepends of python2
      MarkInstall python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
       Removing: python-minimal
        MarkDelete python-minimal:amd64 < 2.7.15~rc1-1 @ii mK > FU=0
    Installing libpython2-stdlib as Depends of python2
      MarkInstall libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
       Removing: libpython-stdlib
        MarkDelete libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii mK > FU=0
     Removing: python
      MarkDelete python:amd64 < 2.7.15~rc1-1 @ii mK Ib > FU=0
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) python-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib >
Broken python-all-dev:amd64 Depends on libpython-all-dev:amd64 < 2.7.15~rc1-1 | 2.7.17-2ubuntu4 @ii umH > (= 2.7.17-2ubuntu4)
  Considering libpython-all-dev:amd64 0 as a solution to python-all-dev:amd64 1
  MarkKeep python-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib > FU=0
  Re-Instated libpython2-dev:amd64
  Re-Instated libpython-all-dev:amd64
  Re-Instated python2-dev:amd64
  Re-Instated python-all-dev:amd64
Investigating (0) python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib >
Broken python2-dev:amd64 Breaks on python-dev:amd64 < 2.7.15~rc1-1 @ii mK Ib > (< 2.7.15-2)
  Considering python-dev:amd64 -2 as a solution to python2-dev:amd64 0
  Added python-dev:amd64 to the remove list
  Fixing python2-dev:amd64 via remove of python-dev:amd64
  MarkDelete python-dev:amd64 < 2.7.15~rc1-1 @ii mK Ib > FU=0
Investigating (0) libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib >
Broken libpython2-dev:amd64 Breaks on libpython-dev:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
  Considering libpython-dev:amd64 0 as a solution to libpython2-dev:amd64 0
  MarkKeep libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
  Holding Back libpython2-dev:amd64 rather than change libpython-dev:amd64
Investigating (1) python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib >
Broken python2-dev:amd64 Depends on libpython2-dev:amd64 < none | 2.7.17-2ubuntu4 @un uH > (= 2.7.17-2ubuntu4)
  Considering libpython2-dev:amd64 0 as a solution to python2-dev:amd64 0
  MarkKeep python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
  Holding Back python2-dev:amd64 rather than change libpython2-dev:amd64
Investigating (1) libpython-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib >
Broken libpython-all-dev:amd64 Depends on libpython2-dev:amd64 < none | 2.7.17-2ubuntu4 @un uH > (= 2.7.17-2ubuntu4)
  Considering libpython2-dev:amd64 0 as a solution to libpython-all-dev:amd64 0
  MarkKeep libpython-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib > FU=0
  Holding Back libpython-all-dev:amd64 rather than change libpython2-dev:amd64
Investigating (2) python-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib >
Broken python-all-dev:amd64 Depends on libpython-all-dev:amd64 < 2.7.15~rc1-1 | 2.7.17-2ubuntu4 @ii umH > (= 2.7.17-2ubuntu4)
  Considering libpython-all-dev:amd64 0 as a solution to python-all-dev:amd64 1
  MarkKeep python-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii umU Ib > FU=0
  Removing python-all-dev:amd64 rather than change libpython-all-dev:amd64
  MarkDelete python-all-dev:amd64 < 2.7.15~rc1-1 | 2.7.17-2ubuntu4 @ii umH Ib > FU=0
Done
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
    MarkKeep libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
    MarkKeep python-dev:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
    MarkKeep python-minimal:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
  MarkInstall fdisk:amd64 < 2.31.1-0.4ubuntu3.7 -> 2.34-0.1ubuntu9.1 @ii umU Ib > FU=0
  Installing libncursesw6 as Depends of fdisk
    MarkInstall libncursesw6:amd64 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncursesw6
      MarkInstall libtinfo6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall xfce4-pulseaudio-plugin:amd64 < 0.4.1-0ubuntu1 -> 0.4.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libxfconf-0-3 as Depends of xfce4-pulseaudio-plugin
    MarkInstall libxfconf-0-3:amd64 < none -> 4.14.1-1 @un uN > FU=0
  MarkInstall evince:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libgnome-desktop-3-19 as Depends of evince
    MarkInstall libgnome-desktop-3-19:amd64 < none -> 3.36.3.1-0ubuntu1 @un uN > FU=0
  MarkInstall mate-settings-daemon:amd64 < 1.20.1-3 -> 1.24.0-1 @ii umU Ib > FU=0
  Installing librda0 as Depends of mate-settings-daemon
    MarkInstall librda0:amd64 < none -> 0.0.5-1 @un uN Ib > FU=0
    Installing librda-common as Depends of librda0
      MarkInstall librda-common:amd64 < none -> 0.0.5-1 @un uN > FU=0
  MarkInstall libgcc-7-dev:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libgcc-7-dev
    MarkInstall libgcc-s1:amd64 < none -> 10-20200411-0ubuntu1 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
  MarkInstall perl-base:amd64 < 5.26.1-6ubuntu0.3 -> 5.30.0-9build1 @ii umU Ib > FU=0
  Installing libcrypt1 as PreDepends of perl-base
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libreoffice-math:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-cppu3 as Depends of libreoffice-math
    MarkInstall libuno-cppu3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libuno-sal3 as Depends of libuno-cppu3
      MarkInstall libuno-sal3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
       Removing: uno-libs3
        MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
    Installing libuno-salhelpergcc3-3 as Depends of libuno-cppu3
      MarkInstall libuno-salhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libuno-cppuhelpergcc3-3 as Depends of libreoffice-math
    MarkInstall libuno-cppuhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing uno-libs-private as Depends of libuno-cppuhelpergcc3-3
      MarkInstall uno-libs-private:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall bluez:amd64 < 5.48-0ubuntu3.4 -> 5.53-0ubuntu3 @ii umU Ib > FU=0
  Installing libreadline8 as Depends of bluez
    MarkInstall libreadline8:amd64 < none -> 8.0-4 @un uN > FU=0
  MarkInstall dvdauthor:amd64 < 0.7.0-2build1 -> 0.7.2-1build1 @ii umU Ib > FU=0
  Installing libdvdread7 as Depends of dvdauthor
    MarkInstall libdvdread7:amd64 < none -> 6.1.0+really6.0.2-1 @un uN > FU=0
  MarkInstall python3-dev:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU Ib > FU=0
  Installing python3.8-dev as Depends of python3-dev
    MarkInstall python3.8-dev:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN Ib > FU=0
    Installing python3.8 as Depends of python3.8-dev
      MarkInstall python3.8:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN Ib > FU=0
      Installing python3.8-minimal as Depends of python3.8
        MarkInstall python3.8-minimal:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN Ib > FU=0
        Installing libpython3.8-minimal as Depends of python3.8-minimal
          MarkInstall libpython3.8-minimal:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN IPb > FU=0
          Installing libpython3.8-stdlib as Recommends of libpython3.8-minimal
            MarkInstall libpython3.8-stdlib:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN Ib > FU=0
            Installing libffi7 as Depends of libpython3.8-stdlib
              MarkInstall libffi7:amd64 < none -> 3.3-4 @un uN > FU=0
    Installing libpython3.8-dev as Depends of python3.8-dev
      MarkInstall libpython3.8-dev:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN Ib > FU=0
      Installing libpython3.8 as Depends of libpython3.8-dev
        MarkInstall libpython3.8:amd64 < none -> 3.8.2-1ubuntu1.2 @un uN > FU=0
  MarkInstall vlc-plugin-video-output:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libavcodec58 as Depends of vlc-plugin-video-output
    MarkInstall libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libaom0 as Depends of libavcodec58
      MarkInstall libaom0:amd64 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
    Installing libavutil56 as Depends of libavcodec58
      MarkInstall libavutil56:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing ocl-icd-libopencl1 as Depends of libavutil56
        MarkInstall ocl-icd-libopencl1:amd64 < none -> 2.2.11-1ubuntu1 @un uN > FU=0
    Installing libcodec2-0.9 as Depends of libavcodec58
      MarkInstall libcodec2-0.9:amd64 < none -> 0.9.2-2 @un uN > FU=0
    Installing libswresample3 as Depends of libavcodec58
      MarkInstall libswresample3:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvpx6 as Depends of libavcodec58
      MarkInstall libvpx6:amd64 < none -> 1.8.2-1build1 @un uN > FU=0
    Installing libx264-155 as Depends of libavcodec58
      MarkInstall libx264-155:amd64 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
    Installing libx265-179 as Depends of libavcodec58
      MarkInstall libx265-179:amd64 < none -> 3.2.1-1build1 @un uN > FU=0
  Installing libplacebo7 as Depends of vlc-plugin-video-output
    MarkInstall libplacebo7:amd64 < none -> 1.7.0-2 @un uN > FU=0
  MarkInstall hplip-data:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Installing python3-distro as Depends of hplip-data
    MarkInstall python3-distro:amd64 < none -> 1.4.0-1 @un uN > FU=0
  MarkInstall xserver-xorg:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU IPb > FU=0
  new important dependency: mesa-vulkan-drivers:amd64
  Installing mesa-vulkan-drivers as Recommends of xserver-xorg
    MarkInstall mesa-vulkan-drivers:amd64 < none -> 20.0.8-0ubuntu1~20.04.1 @un uN > FU=0
  MarkInstall python-tdb:amd64 < 1.3.15-2 @ii mK Ib > FU=0
  MarkInstall qt5-style-plugins:amd64 < 5.0.0+git23.g335dbec-2build5 -> 5.0.0+git23.g335dbec-3ubuntu4 @ii umU Ib > FU=0
  Installing qt5-gtk2-platformtheme as Depends of qt5-style-plugins
    MarkInstall qt5-gtk2-platformtheme:amd64 < none -> 5.0.0+git23.g335dbec-3ubuntu4 @un uN > FU=0
  Installing qt5-style-plugin-cleanlooks as Depends of qt5-style-plugins
    MarkInstall qt5-style-plugin-cleanlooks:amd64 < none -> 5.0.0+git23.g335dbec-3ubuntu4 @un uN > FU=0
  Installing qt5-style-plugin-motif as Depends of qt5-style-plugins
    MarkInstall qt5-style-plugin-motif:amd64 < none -> 5.0.0+git23.g335dbec-3ubuntu4 @un uN > FU=0
  Installing qt5-style-plugin-plastique as Depends of qt5-style-plugins
    MarkInstall qt5-style-plugin-plastique:amd64 < none -> 5.0.0+git23.g335dbec-3ubuntu4 @un uN > FU=0
  MarkInstall libgupnp-igd-1.0-4:amd64 < 0.2.5-1 -> 0.2.5-5 @ii umU Ib > FU=0
  Installing libgssdp-1.2-0 as Depends of libgupnp-igd-1.0-4
    MarkInstall libgssdp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libgupnp-1.2-0 as Depends of libgupnp-igd-1.0-4
    MarkInstall libgupnp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall xubuntu-icon-theme:amd64 < 18.04.5 -> 20.04.2 @ii umU Ib > FU=0
  Installing elementary-xfce-icon-theme as Depends of xubuntu-icon-theme
    MarkInstall elementary-xfce-icon-theme:amd64 < none -> 0.15-1 @un uN > FU=0
  MarkInstall libkf5texteditor5:amd64 < 5.44.0-0ubuntu2 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5texteditor-bin as Depends of libkf5texteditor5
    MarkInstall libkf5texteditor-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5authcore5 as Depends of libkf5texteditor-bin
      MarkInstall libkf5authcore5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libgit2-28 as Depends of libkf5texteditor5
    MarkInstall libgit2-28:amd64 < none -> 0.28.4+dfsg.1-2 @un uN Ib > FU=0
    Installing libhttp-parser2.9 as Depends of libgit2-28
      MarkInstall libhttp-parser2.9:amd64 < none -> 2.9.2-2 @un uN > FU=0
    Installing libmbedcrypto3 as Depends of libgit2-28
      MarkInstall libmbedcrypto3:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
    Installing libmbedtls12 as Depends of libgit2-28
      MarkInstall libmbedtls12:amd64 < none -> 2.16.4-1ubuntu2 @un uN Ib > FU=0
      Installing libmbedx509-0 as Depends of libmbedtls12
        MarkInstall libmbedx509-0:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
  MarkInstall xfce4-sensors-plugin:amd64 < 1.2.6-1 -> 1.3.0-2build1 @ii umU Ib > FU=0
  Installing libsensors5 as Depends of xfce4-sensors-plugin
    MarkInstall libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
    Installing libsensors-config as Depends of libsensors5
      MarkInstall libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
       Removing: libsensors4
        MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
       Removing: libsensors4
        MarkDelete libsensors4:i386 < 1:3.4.0-4 @ii mK > FU=0
  MarkInstall libisofs6:amd64 < 1.4.8-1 -> 1.5.2-1 @ii umU Ib > FU=0
  Installing libjte2 as Depends of libisofs6
    MarkInstall libjte2:amd64 < none -> 1.22-3build1 @un uN > FU=0
  MarkInstall thunar-media-tags-plugin:amd64 < 0.2.1-1 -> 0.3.0-2 @ii umU Ib > FU=0
  Installing libthunarx-3-0 as Depends of thunar-media-tags-plugin
    MarkInstall libthunarx-3-0:amd64 < none -> 1.8.14-0ubuntu1 @un uN > FU=0
  MarkInstall poppler-utils:amd64 < 0.62.0-2ubuntu2.10 -> 0.86.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libpoppler97 as Depends of poppler-utils
    MarkInstall libpoppler97:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall libgusb2:amd64 < 0.2.11-1 -> 0.3.4-0.1 @ii umU IPb > FU=0
  new important dependency: usb.ids:amd64
  Installing usb.ids as Recommends of libgusb2
    MarkInstall usb.ids:amd64 < none -> 2020.03.19-1 @un uN > FU=0
  MarkInstall libaa1:amd64 < 1.4p5-44build2 -> 1.4p5-46 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libaa1
    MarkInstall libncurses6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall liblapack3:amd64 < 3.7.1-4ubuntu1 -> 3.9.0-1build1 @ii umU Ib > FU=0
  Installing libgfortran5 as Depends of liblapack3
    MarkInstall libgfortran5:amd64 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
  MarkInstall libgtkspell0:amd64 < 2.0.16-1.2 -> 2.0.16-1.3 @ii umU Ib > FU=0
  Installing libenchant-2-2 as Depends of libgtkspell0
    MarkInstall libenchant-2-2:amd64 < none -> 2.2.8-1 @un uN Ib > FU=0
    Installing libhunspell-1.7-0 as Depends of libenchant-2-2
      MarkInstall libhunspell-1.7-0:amd64 < none -> 1.7.0-2build2 @un uN > FU=0
    Installing enchant-2 as Recommends of libenchant-2-2
      MarkInstall enchant-2:amd64 < none -> 2.2.8-1 @un uN > FU=0
  MarkInstall libffmpegthumbnailer4v5:amd64 < 2.1.1-0.1build1 -> 2.1.1-0.2build2 @ii umU Ib > FU=0
  Installing libavfilter7 as Depends of libffmpegthumbnailer4v5
    MarkInstall libavfilter7:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libavformat58 as Depends of libavfilter7
      MarkInstall libavformat58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libmysofa1 as Depends of libavfilter7
      MarkInstall libmysofa1:amd64 < none -> 1.0~dfsg0-1 @un uN > FU=0
    Installing libpostproc55 as Depends of libavfilter7
      MarkInstall libpostproc55:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libswscale5 as Depends of libavfilter7
      MarkInstall libswscale5:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvidstab1.1 as Depends of libavfilter7
      MarkInstall libvidstab1.1:amd64 < none -> 1.1.0-2 @un uN > FU=0
  MarkInstall ubuntu-mate-desktop:amd64 < 1.225 -> 1.263 @ii umU NPb Ib > FU=0
  Installing fortune-mod as Depends of ubuntu-mate-desktop
    MarkInstall fortune-mod:amd64 < none -> 1:1.99.1-7build1 @un uN Ib > FU=0
    Installing librecode0 as Depends of fortune-mod
      MarkInstall librecode0:amd64 < none -> 3.6-24 @un uN > FU=0
    Installing fortunes-min as Recommends of fortune-mod
      MarkInstall fortunes-min:amd64 < none -> 1:1.99.1-7build1 @un uN > FU=0
  new important dependency: caja-mediainfo:amd64
  Installing caja-mediainfo as Recommends of ubuntu-mate-desktop
    MarkInstall caja-mediainfo:amd64 < none -> 1.0.1-3 @un uN Ib > FU=0
    Installing python3-caja as Depends of caja-mediainfo
      MarkInstall python3-caja:amd64 < none -> 1.24.0-2 @un uN Ib > FU=0
       Removing: python-caja
        MarkDelete python-caja:amd64 < 1.20.0-1 @ii mK Ib > FU=0
    Installing python3-mediainfodll as Depends of caja-mediainfo
      MarkInstall python3-mediainfodll:amd64 < none -> 19.09+dfsg-2build1 @un uN Ib > FU=0
      Installing libmediainfo0v5 as Depends of python3-mediainfodll
        MarkInstall libmediainfo0v5:amd64 < none -> 19.09+dfsg-2build1 @un uN Ib > FU=0
        Installing libtinyxml2-6a as Depends of libmediainfo0v5
          MarkInstall libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN > FU=0
        Installing libzen0v5 as Depends of libmediainfo0v5
          MarkInstall libzen0v5:amd64 < none -> 0.4.37-1build1 @un uN > FU=0
  new important dependency: celluloid:amd64
  Installing celluloid as Recommends of ubuntu-mate-desktop
    MarkInstall celluloid:amd64 < none -> 0.18-2build1 @un uN Ib > FU=0
    Installing libmpv1 as Depends of celluloid
      MarkInstall libmpv1:amd64 < none -> 0.32.0-1ubuntu1 @un uN Ib > FU=0
      Installing libavdevice58 as Depends of libmpv1
        MarkInstall libavdevice58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libsndio7.0 as Depends of libavdevice58
          MarkInstall libsndio7.0:amd64 < none -> 1.5.0-3 @un uN > FU=0
      Installing libcdio18 as Depends of libmpv1
        MarkInstall libcdio18:amd64 < none -> 2.0.0-2 @un uN > FU=0
  new important dependency: evolution:amd64
  Installing evolution as Recommends of ubuntu-mate-desktop
    MarkInstall evolution:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libcamel-1.2-62 as Depends of evolution
      MarkInstall libcamel-1.2-62:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libicu66 as Depends of libcamel-1.2-62
        MarkInstall libicu66:amd64 < none -> 66.1-2ubuntu2 @un uN > FU=0
    Installing libecal-2.0-1 as Depends of evolution
      MarkInstall libecal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libedataserver-1.2-24 as Depends of libecal-2.0-1
        MarkInstall libedataserver-1.2-24:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
        Installing evolution-data-server-common as Depends of libedataserver-1.2-24
          MarkInstall evolution-data-server-common:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing libevolution as Depends of evolution
      MarkInstall libevolution:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libchamplain-0.12-0 as Depends of libevolution
        MarkInstall libchamplain-0.12-0:amd64 < none -> 0.12.20-1 @un uN > FU=0
      Installing libchamplain-gtk-0.12-0 as Depends of libevolution
        MarkInstall libchamplain-gtk-0.12-0:amd64 < none -> 0.12.20-1 @un uN > FU=0
      Installing libebook-1.2-20 as Depends of libevolution
        MarkInstall libebook-1.2-20:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
        Installing libebook-contacts-1.2-3 as Depends of libebook-1.2-20
          MarkInstall libebook-contacts-1.2-3:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
          Installing libphonenumber7 as Depends of libebook-contacts-1.2-3
            MarkInstall libphonenumber7:amd64 < none -> 7.1.0-5ubuntu11 @un uN Ib > FU=0
            Installing libboost-thread1.71.0 as Depends of libphonenumber7
              MarkInstall libboost-thread1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
            Installing libprotobuf17 as Depends of libphonenumber7
              MarkInstall libprotobuf17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
        Installing libedata-book-1.2-26 as Depends of libebook-1.2-20
          MarkInstall libedata-book-1.2-26:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
          Installing libebackend-1.2-10 as Depends of libedata-book-1.2-26
            MarkInstall libebackend-1.2-10:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
      Installing libedataserverui-1.2-2 as Depends of libevolution
        MarkInstall libedataserverui-1.2-2:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
      Installing libgeocode-glib0 as Depends of libevolution
        MarkInstall libgeocode-glib0:amd64 < none -> 3.26.2-2 @un uN > FU=0
      Installing libgnome-autoar-0-0 as Depends of libevolution
        MarkInstall libgnome-autoar-0-0:amd64 < none -> 0.2.3-2 @un uN > FU=0
      Installing libgnome-autoar-gtk-0-0 as Depends of libevolution
        MarkInstall libgnome-autoar-gtk-0-0:amd64 < none -> 0.2.3-2 @un uN > FU=0
      Installing libgspell-1-2 as Depends of libevolution
        MarkInstall libgspell-1-2:amd64 < none -> 1.8.3-1 @un uN > FU=0
      Installing libgweather-3-16 as Depends of libevolution
        MarkInstall libgweather-3-16:amd64 < none -> 3.36.0-1 @un uN Ib > FU=0
        Installing libgweather-common as Depends of libgweather-3-16
          MarkInstall libgweather-common:amd64 < none -> 3.36.0-1 @un uN > FU=0
      Installing libytnef0 as Depends of libevolution
        MarkInstall libytnef0:amd64 < none -> 1.9.3-1 @un uN > FU=0
      Installing evolution-common as Depends of libevolution
        MarkInstall evolution-common:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing evolution-data-server as Depends of evolution
      MarkInstall evolution-data-server:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libedata-cal-2.0-1 as Depends of evolution-data-server
        MarkInstall libedata-cal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing evolution-plugins as Recommends of evolution
      MarkInstall evolution-plugins:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing evolution-plugin-bogofilter as Recommends of evolution
      MarkInstall evolution-plugin-bogofilter:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing bogofilter as Depends of evolution-plugin-bogofilter
        MarkInstall bogofilter:amd64 < none -> 1.2.4+dfsg1-13 @un uN Ib > FU=0
        Installing bogofilter-bdb as Depends of bogofilter
          MarkInstall bogofilter-bdb:amd64 < none -> 1.2.4+dfsg1-13 @un uN Ib > FU=0
          Installing bogofilter-common as Depends of bogofilter-bdb
            MarkInstall bogofilter-common:amd64 < none -> 1.2.4+dfsg1-13 @un uN > FU=0
          Installing libgsl23 as Depends of bogofilter-bdb
            MarkInstall libgsl23:amd64 < none -> 2.5+dfsg-6build1 @un uN Ib > FU=0
            Installing libgslcblas0 as Depends of libgsl23
              MarkInstall libgslcblas0:amd64 < none -> 2.5+dfsg-6build1 @un uN > FU=0
    Installing evolution-plugin-pstimport as Recommends of evolution
      MarkInstall evolution-plugin-pstimport:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libpst4 as Depends of evolution-plugin-pstimport
        MarkInstall libpst4:amd64 < none -> 0.6.74-1build1 @un uN > FU=0
  new important dependency: evolution-ews:amd64
  Installing evolution-ews as Recommends of ubuntu-mate-desktop
    MarkInstall evolution-ews:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libmspack0 as Depends of evolution-ews
      MarkInstall libmspack0:amd64 < none -> 0.10.1-2 @un uN > FU=0
  new important dependency: evolution-rss:amd64
  Installing evolution-rss as Recommends of ubuntu-mate-desktop
    MarkInstall evolution-rss:amd64 < none -> 0.3.96-1 @un uN > FU=0
  new important dependency: gamemode:amd64
  Installing gamemode as Recommends of ubuntu-mate-desktop
    MarkInstall gamemode:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN Ib > FU=0
    Installing libgamemode0 as Depends of gamemode
      MarkInstall libgamemode0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
    Installing libgamemodeauto0 as Depends of gamemode
      MarkInstall libgamemodeauto0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
  new important dependency: gnome-firmware:amd64
  Installing gnome-firmware as Recommends of ubuntu-mate-desktop
    MarkInstall gnome-firmware:amd64 < none -> 3.34.0-2 @un uN > FU=0
  new important dependency: indicator-datetime:amd64
  Installing indicator-datetime as Recommends of ubuntu-mate-desktop
    MarkInstall indicator-datetime:amd64 < none -> 15.10+20.04.20200217-0ubuntu1 @un uN Ib > FU=0
    Installing libaccounts-glib0 as Depends of indicator-datetime
      MarkInstall libaccounts-glib0:amd64 < none -> 1.23+17.04.20161104-0ubuntu3 @un uN > FU=0
    Installing ubuntu-touch-sounds as Recommends of indicator-datetime
      MarkInstall ubuntu-touch-sounds:amd64 < none -> 15.08 @un uN > FU=0
  new important dependency: indicator-notifications:amd64
  Installing indicator-notifications as Recommends of ubuntu-mate-desktop
    MarkInstall indicator-notifications:amd64 < none -> 0.4.2-0ubuntu1 @un uN > FU=0
  new important dependency: magnus:amd64
  Installing magnus as Recommends of ubuntu-mate-desktop
    MarkInstall magnus:amd64 < none -> 1.0.3-1 @un uN > FU=0
  new important dependency: plymouth-theme-spinner:amd64
  Installing plymouth-theme-spinner as Recommends of ubuntu-mate-desktop
    MarkInstall plymouth-theme-spinner:amd64 < none -> 0.9.4git20200323-0ubuntu6 @un uN Ib > FU=0
    Installing libplymouth5 as Depends of plymouth-theme-spinner
      MarkInstall libplymouth5:amd64 < none -> 0.9.4git20200323-0ubuntu6 @un uN > FU=0
  new important dependency: pulsemixer:amd64
  Installing pulsemixer as Recommends of ubuntu-mate-desktop
    MarkInstall pulsemixer:amd64 < none -> 1.5.0-1 @un uN > FU=0
  new important dependency: qt5-style-platform-gtk2:amd64
  Installing qt5-style-platform-gtk2 as Recommends of ubuntu-mate-desktop
    MarkInstall qt5-style-platform-gtk2:amd64 < none -> 5.0.0+git23.g335dbec-3ubuntu4 @un uN > FU=0
  new important dependency: whoopsie-preferences:amd64
  Installing whoopsie-preferences as Recommends of ubuntu-mate-desktop
    MarkInstall whoopsie-preferences:amd64 < none -> 22 @un uN Ib > FU=0
    Installing libwhoopsie-preferences0 as Depends of whoopsie-preferences
      MarkInstall libwhoopsie-preferences0:amd64 < none -> 22 @un uN > FU=0
  new important dependency: yaru-theme-sound:amd64
  Installing yaru-theme-sound as Recommends of ubuntu-mate-desktop
    MarkInstall yaru-theme-sound:amd64 < none -> 20.04.8 @un uN > FU=0
  MarkInstall libvte-2.91-0:amd64 < 0.52.2-1ubuntu1~18.04.2 -> 0.60.3-0ubuntu1~20.04 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libvte-2.91-0
    MarkInstall libpcre2-8-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall linux-headers-generic:amd64 < 4.15.0.118.105 -> 5.4.0.48.51 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-48-generic as Depends of linux-headers-generic
    MarkInstall linux-headers-5.4.0-48-generic:amd64 < none -> 5.4.0-48.52 @un uN Ib > FU=0
    Installing linux-headers-5.4.0-48 as Depends of linux-headers-5.4.0-48-generic
      MarkInstall linux-headers-5.4.0-48:amd64 < none -> 5.4.0-48.52 @un uN > FU=0
  MarkInstall virtinst:amd64 < 1:1.5.1-0ubuntu1.2 -> 1:2.2.1-3ubuntu2.1 @ii umU Ib > FU=0
  Installing python3-libvirt as Depends of virtinst
    MarkInstall python3-libvirt:amd64 < none -> 6.1.0-1 @un uN > FU=0
  Installing python3-libxml2 as Depends of virtinst
    MarkInstall python3-libxml2:amd64 < none -> 2.9.10+dfsg-5 @un uN > FU=0
  MarkInstall iptables:amd64 < 1.6.1-2ubuntu2 -> 1.8.4-3ubuntu2 @ii umU Ib > FU=0
  Installing libip4tc2 as Depends of iptables
    MarkInstall libip4tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libip6tc2 as Depends of iptables
    MarkInstall libip6tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libnftnl11 as Depends of iptables
    MarkInstall libnftnl11:amd64 < none -> 1.1.5-1 @un uN > FU=0
  MarkInstall gvfs-backends:amd64 < 1.36.1-0ubuntu1.3.3 -> 1.44.1-1ubuntu1 @ii umU Ib > FU=0
  Installing libnfs13 as Depends of gvfs-backends
    MarkInstall libnfs13:amd64 < none -> 4.0.0-1 @un uN > FU=0
  MarkInstall ffmpeg:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavresample4 as Depends of ffmpeg
    MarkInstall libavresample4:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall python-samba:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.20 @ii mK Ib > FU=0
  MarkInstall libevdocument3-4:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libsynctex2 as Depends of libevdocument3-4
    MarkInstall libsynctex2:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  MarkInstall libpam-modules:amd64 < 1.1.8-3.6ubuntu2.18.04.2 -> 1.3.1-5ubuntu4.1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on update-motd:amd64
  MarkInstall orage:amd64 < 4.12.1-4 -> 4.12.1-7 @ii umU Ib > FU=0
  Installing orage-data as Depends of orage
    MarkInstall orage-data:amd64 < none -> 4.12.1-7 @un uN > FU=0
  MarkInstall qemu-system-mips:amd64 < 1:2.11+dfsg-1ubuntu7.32 -> 1:4.2-3ubuntu6.6 @ii umU Ib > FU=0
  Installing libbrlapi0.7 as Depends of qemu-system-mips
    MarkInstall libbrlapi0.7:amd64 < none -> 6.0+dfsg-4ubuntu6 @un uN > FU=0
  Installing libnettle7 as Depends of qemu-system-mips
    MarkInstall libnettle7:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  Installing libpmem1 as Depends of qemu-system-mips
    MarkInstall libpmem1:amd64 < none -> 1.8-1ubuntu1 @un uN > FU=0
  Installing libslirp0 as Depends of qemu-system-mips
    MarkInstall libslirp0:amd64 < none -> 4.1.0-2ubuntu2.1 @un uN > FU=0
  Installing libvirglrenderer1 as Depends of qemu-system-mips
    MarkInstall libvirglrenderer1:amd64 < none -> 0.8.2-1ubuntu1 @un uN > FU=0
  Installing qemu-system-data as Depends of qemu-system-mips
    MarkInstall qemu-system-data:amd64 < none -> 1:4.2-3ubuntu6.6 @un uN > FU=0
  new important dependency: qemu-system-gui:amd64
  Installing qemu-system-gui as Recommends of qemu-system-mips
    MarkInstall qemu-system-gui:amd64 < none -> 1:4.2-3ubuntu6.6 @un uN > FU=0
  MarkInstall sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of sane-utils
    MarkInstall libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:amd64 < none -> 8.0.21-0ubuntu0.20.04.4 @un uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:amd64 < none -> 5.30.0-9build1 @un uN Ib > FU=0
        Installing libgdbm6 as Depends of libperl5.30
          MarkInstall libgdbm6:amd64 < none -> 1.18.1-5 @un uN > FU=0
        Installing perl-modules-5.30 as Depends of libperl5.30
          MarkInstall perl-modules-5.30:amd64 < none -> 5.30.0-9build1 @un uN > FU=0
  MarkInstall libc6-dev:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9.1 @ii umU Ib > FU=0
  Installing libcrypt-dev as Depends of libc6-dev
    MarkInstall libcrypt-dev:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libargon2-0:amd64 < 0~20161029-1.1 -> 0~20171227-0.2 @ii umU Ib > FU=0
  Installing libargon2-1 as Depends of libargon2-0
    MarkInstall libargon2-1:amd64 < none -> 0~20171227-0.2 @un uN > FU=0
  MarkInstall va-driver-all:amd64 < 2.1.0-3 -> 2.7.0-2 @ii umU Ib > FU=0
  Installing intel-media-va-driver as Depends of va-driver-all
    MarkInstall intel-media-va-driver:amd64 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
    Installing libigdgmm11 as Depends of intel-media-va-driver
      MarkInstall libigdgmm11:amd64 < none -> 20.1.1+ds1-1 @un uN > FU=0
  MarkInstall mate-menu:amd64 < 18.04.3-2ubuntu1 -> 20.04.3-0ubuntu1 @ii umU Ib > FU=0
  Installing python3-configobj as Depends of mate-menu
    MarkInstall python3-configobj:amd64 < none -> 5.0.6-4 @un uN > FU=0
  Installing gir1.2-matemenu-2.0 as Depends of mate-menu
    MarkInstall gir1.2-matemenu-2.0:amd64 < none -> 1.24.0-1 @un uN > FU=0
  MarkInstall ntfs-3g:amd64 < 1:2017.3.23-2ubuntu0.18.04.2 -> 1:2017.3.23AR.3-3ubuntu1 @ii umU Ib > FU=0
  Installing libntfs-3g883 as Depends of ntfs-3g
    MarkInstall libntfs-3g883:amd64 < none -> 1:2017.3.23AR.3-3ubuntu1 @un uN > FU=0
  MarkInstall libcmis-0.5-5v5:amd64 < 0.5.1+git20160603-3build2 -> 0.5.2-1ubuntu1 @ii umU Ib > FU=0
  Installing libboost-date-time1.71.0 as Depends of libcmis-0.5-5v5
    MarkInstall libboost-date-time1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall fonts-smc:amd64 < 1:7.0 -> 1:7.1 @ii umU Ib > FU=0
  Installing fonts-smc-gayathri as Depends of fonts-smc
    MarkInstall fonts-smc-gayathri:amd64 < none -> 1.100-1 @un uN > FU=0
  MarkInstall linux-image-generic:amd64 < 4.15.0.118.105 -> 5.4.0.48.51 @ii umU Ib > FU=0
  Installing linux-image-5.4.0-48-generic as Depends of linux-image-generic
    MarkInstall linux-image-5.4.0-48-generic:amd64 < none -> 5.4.0-48.52 @un uN Ib > FU=0
    Installing linux-modules-5.4.0-48-generic as Depends of linux-image-5.4.0-48-generic
      MarkInstall linux-modules-5.4.0-48-generic:amd64 < none -> 5.4.0-48.52 @un uN > FU=0
  Installing linux-modules-extra-5.4.0-48-generic as Depends of linux-image-generic
    MarkInstall linux-modules-extra-5.4.0-48-generic:amd64 < none -> 5.4.0-48.52 @un uN > FU=0
  MarkInstall apt:amd64 < 1.6.12ubuntu0.1 -> 2.0.2ubuntu0.1 @ii umU Ib > FU=0
  Installing libapt-pkg6.0 as Depends of apt
    MarkInstall libapt-pkg6.0:amd64 < none -> 2.0.2ubuntu0.1 @un uN > FU=0
  MarkInstall elinks:amd64 < 0.12~pre6-13 -> 0.13.1-1 @ii umU Ib > FU=0
  Installing libev4 as Depends of elinks
    MarkInstall libev4:amd64 < none -> 1:4.31-1 @un uN > FU=0
  MarkInstall gwenview:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu2 @ii umU Ib > FU=0
  Installing libcfitsio8 as Depends of gwenview
    MarkInstall libcfitsio8:amd64 < none -> 3.470-3 @un uN > FU=0
  Installing libexiv2-27 as Depends of gwenview
    MarkInstall libexiv2-27:amd64 < none -> 0.27.2-8ubuntu2 @un uN > FU=0
  Installing libkf5purpose-bin as Depends of gwenview
    MarkInstall libkf5purpose-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkaccounts1 as Depends of libkf5purpose-bin
      MarkInstall libkaccounts1:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
      Installing libaccounts-qt5-1 as Depends of libkaccounts1
        MarkInstall libaccounts-qt5-1:amd64 < none -> 1.15+17.04.20161104.1-0ubuntu3 @un uN > FU=0
      Installing libsignon-qt5-1 as Depends of libkaccounts1
        MarkInstall libsignon-qt5-1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2 @un uN > FU=0
      Installing kaccounts-providers as Recommends of libkaccounts1
        MarkInstall kaccounts-providers:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
        Installing signon-plugin-oauth2 as Depends of kaccounts-providers
          MarkInstall signon-plugin-oauth2:amd64 < none -> 0.24+16.10.20160818-0ubuntu2 @un uN Ib > FU=0
          Installing libsignon-plugins-common1 as Depends of signon-plugin-oauth2
            MarkInstall libsignon-plugins-common1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2 @un uN > FU=0
    Installing qml-module-org-kde-bluezqt as Depends of libkf5purpose-bin
      MarkInstall qml-module-org-kde-bluezqt:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5bluezqt6 as Depends of qml-module-org-kde-bluezqt
        MarkInstall libkf5bluezqt6:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
        Installing libkf5bluezqt-data as Depends of libkf5bluezqt6
          MarkInstall libkf5bluezqt-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing qml-module-ubuntu-onlineaccounts as Depends of libkf5purpose-bin
      MarkInstall qml-module-ubuntu-onlineaccounts:amd64 < none -> 0.6+17.04.20170405-0ubuntu4 @un uN > FU=0
    Installing libkf5purpose5 as Depends of libkf5purpose-bin
      MarkInstall libkf5purpose5:amd64 < none -> 5.68.0-0ubuntu1 @un uN IPb > FU=0
      Installing qml-module-org-kde-purpose as Recommends of libkf5purpose5
        MarkInstall qml-module-org-kde-purpose:amd64 < none -> 5.68.0-0ubuntu1 @un uN IPb > FU=0
        Installing kdeconnect as Recommends of qml-module-org-kde-purpose
          MarkInstall kdeconnect:amd64 < none -> 1.4-0ubuntu5 @un uN Ib > FU=0
          Installing kde-cli-tools as Depends of kdeconnect
            MarkInstall kde-cli-tools:amd64 < none -> 4:5.18.4.1-0ubuntu1 @un uN Ib > FU=0
            Installing kde-cli-tools-data as Depends of kde-cli-tools
              MarkInstall kde-cli-tools-data:amd64 < none -> 4:5.18.4.1-0ubuntu1 @un uN > FU=0
            Installing libkf5su-bin as Depends of kde-cli-tools
              MarkInstall libkf5su-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5su5 as Depends of libkf5su-bin
                MarkInstall libkf5su5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
                Installing libkf5su-data as Depends of libkf5su5
                  MarkInstall libkf5su-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkf5kcmutils5 as Depends of kde-cli-tools
              MarkInstall libkf5kcmutils5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5kcmutils-data as Depends of libkf5kcmutils5
                MarkInstall libkf5kcmutils-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkworkspace5-5 as Depends of kde-cli-tools
              MarkInstall libkworkspace5-5:amd64 < none -> 4:5.18.5-0ubuntu0.1 @un uN > FU=0
          Installing libqca-qt5-2-plugins as Depends of kdeconnect
            MarkInstall libqca-qt5-2-plugins:amd64 < none -> 2.2.1-2build1 @un uN Ib > FU=0
            Installing libqca-qt5-2 as Depends of libqca-qt5-2-plugins
              MarkInstall libqca-qt5-2:amd64 < none -> 2.2.1-2build1 @un uN > FU=0
          Installing qml-module-org-kde-people as Depends of kdeconnect
            MarkInstall qml-module-org-kde-people:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
            Installing libkf5people5 as Depends of qml-module-org-kde-people
              MarkInstall libkf5people5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5people-data as Depends of libkf5people5
                MarkInstall libkf5people-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
              Installing libkf5peoplebackend5 as Depends of libkf5people5
                MarkInstall libkf5peoplebackend5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkf5peoplewidgets5 as Depends of qml-module-org-kde-people
              MarkInstall libkf5peoplewidgets5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
          Installing libkf5pulseaudioqt2 as Depends of kdeconnect
            MarkInstall libkf5pulseaudioqt2:amd64 < none -> 1.2-2build1 @un uN > FU=0
          Installing kpeople-vcard as Recommends of kdeconnect
            MarkInstall kpeople-vcard:amd64 < none -> 0.1-0ubuntu1 @un uN Ib > FU=0
            Installing libkf5contacts5 as Depends of kpeople-vcard
              MarkInstall libkf5contacts5:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5contacts-data as Depends of libkf5contacts5
                MarkInstall libkf5contacts-data:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall mate-optimus:amd64 < 18.04.0-1 -> 19.10.4-0ubuntu1 @ii umU Ib > FU=0
  Installing glew-utils as Depends of mate-optimus
    MarkInstall glew-utils:amd64 < none -> 2.1.0-4 @un uN Ib > FU=0
    Installing libglew2.1 as Depends of glew-utils
      MarkInstall libglew2.1:amd64 < none -> 2.1.0-4 @un uN > FU=0
  MarkInstall libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
  MarkInstall libreoffice-core:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libboost-locale1.71.0 as Depends of libreoffice-core
    MarkInstall libboost-locale1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing liborcus-0.15-0 as Depends of libreoffice-core
    MarkInstall liborcus-0.15-0:amd64 < none -> 0.15.3-3build2 @un uN Ib > FU=0
    Installing libboost-filesystem1.71.0 as Depends of liborcus-0.15-0
      MarkInstall libboost-filesystem1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
    Installing libboost-iostreams1.71.0 as Depends of liborcus-0.15-0
      MarkInstall libboost-iostreams1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall seahorse:amd64 < 3.20.0-5 -> 3.36-1 @ii umU Ib > FU=0
  Installing libhandy-0.0-0 as Depends of seahorse
    MarkInstall libhandy-0.0-0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  MarkInstall cpp-7:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libisl22 as Depends of cpp-7
    MarkInstall libisl22:amd64 < none -> 0.22.1-1 @un uN > FU=0
  MarkInstall libasound2-data:amd64 < 1.1.3-5ubuntu0.5 -> 1.2.2-2.1ubuntu2 @ii umU IPb > FU=0
  new important dependency: alsa-ucm-conf:amd64
  Installing alsa-ucm-conf as Recommends of libasound2-data
    MarkInstall alsa-ucm-conf:amd64 < none -> 1.2.2-1ubuntu0.4 @un uN > FU=0
  new important dependency: alsa-topology-conf:amd64
  Installing alsa-topology-conf as Recommends of libasound2-data
    MarkInstall alsa-topology-conf:amd64 < none -> 1.2.2-1 @un uN > FU=0
  MarkInstall samba:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.20 -> 2:4.11.6+dfsg-0ubuntu1.5 @ii umU Ib > FU=0
  Installing python3-dnspython as Depends of samba
    MarkInstall python3-dnspython:amd64 < none -> 1.16.0-1build1 @un uN > FU=0
  Installing python3-samba as Depends of samba
    MarkInstall python3-samba:amd64 < none -> 2:4.11.6+dfsg-0ubuntu1.5 @un uN Ib > FU=0
    Installing python3-ldb as Depends of python3-samba
      MarkInstall python3-ldb:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib > FU=0
      Installing libldb2 as Depends of python3-ldb
        MarkInstall libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib > FU=0
         Removing: libldb1
          MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
    Installing python3-tdb as Depends of python3-samba
      MarkInstall python3-tdb:amd64 < none -> 1.4.2-3build1 @un uN > FU=0
    Installing python3-talloc as Depends of python3-samba
      MarkInstall python3-talloc:amd64 < none -> 2.3.0-3ubuntu1 @un uN > FU=0
    Installing python3-gpg as Recommends of python3-samba
      MarkInstall python3-gpg:amd64 < none -> 1.13.1-7ubuntu2 @un uN > FU=0
  new important dependency: python3-markdown:amd64
  Installing python3-markdown as Recommends of samba
    MarkInstall python3-markdown:amd64 < none -> 3.1.1-3 @un uN Ib > FU=0
    Installing python3-packaging as Depends of python3-markdown
      MarkInstall python3-packaging:amd64 < none -> 20.3-1 @un uN > FU=0
  MarkInstall flatpak:amd64 < 1.0.9-0ubuntu0.1 -> 1.6.5-0ubuntu0.1 @ii umU Ib > FU=0
  Installing xdg-dbus-proxy as Depends of flatpak
    MarkInstall xdg-dbus-proxy:amd64 < none -> 0.1.2-1 @un uN > FU=0
  MarkInstall cpp:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing cpp-9 as Depends of cpp
    MarkInstall cpp-9:amd64 < none -> 9.3.0-10ubuntu2 @un uN Ib > FU=0
    Installing gcc-9-base as Depends of cpp-9
      MarkInstall gcc-9-base:amd64 < none -> 9.3.0-10ubuntu2 @un uN > FU=0
  MarkInstall libgpg-error0:amd64 < 1.27-6 -> 1.37-1 @ii umU IPb > FU=0
  new important dependency: libgpg-error-l10n:amd64
  Installing libgpg-error-l10n as Recommends of libgpg-error0
    MarkInstall libgpg-error-l10n:amd64 < none -> 1.37-1 @un uN > FU=0
  MarkInstall bind9-host:amd64 < 1:9.11.3+dfsg-1ubuntu1.13 -> 1:9.16.1-0ubuntu2.3 @ii umU Ib > FU=0
  Installing bind9-libs as Depends of bind9-host
    MarkInstall bind9-libs:amd64 < none -> 1:9.16.1-0ubuntu2.3 @un uN Ib > FU=0
    Installing libjson-c4 as Depends of bind9-libs
      MarkInstall libjson-c4:amd64 < none -> 0.13.1+dfsg-7ubuntu0.3 @un uN > FU=0
  MarkInstall e2fsprogs:amd64 < 1.44.1-1ubuntu1.3 -> 1.45.5-2ubuntu1 @ii umU Ib > FU=0
  Installing logsave as Depends of e2fsprogs
    MarkInstall logsave:amd64 < none -> 1.45.5-2ubuntu1 @un uN > FU=0
  MarkInstall libkf5kdcraw5:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libraw19 as Depends of libkf5kdcraw5
    MarkInstall libraw19:amd64 < none -> 0.19.5-1ubuntu1 @un uN > FU=0
  MarkInstall libpython-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii ugU Ib > FU=0
  Installing libpython2-dev as Depends of libpython-all-dev
    MarkInstall libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
     Removing: libpython-dev
      MarkDelete libpython-dev:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
  MarkInstall dnsutils:amd64 < 1:9.11.3+dfsg-1ubuntu1.13 -> 1:9.16.1-0ubuntu2.3 @ii umU Ib > FU=0
  Installing bind9-dnsutils as Depends of dnsutils
    MarkInstall bind9-dnsutils:amd64 < none -> 1:9.16.1-0ubuntu2.3 @un uN > FU=0
  MarkInstall fonts-roboto-hinted:amd64 < 2:0~20160106-2 -> 2:0~20170802-3 @ii umU Ib > FU=0
  Installing fonts-roboto-unhinted as Depends of fonts-roboto-hinted
    MarkInstall fonts-roboto-unhinted:amd64 < none -> 2:0~20170802-3 @un uN > FU=0
  MarkInstall g++:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing g++-9 as Depends of g++
    MarkInstall g++-9:amd64 < none -> 9.3.0-10ubuntu2 @un uN Ib > FU=0
    Installing gcc-9 as Depends of g++-9
      MarkInstall gcc-9:amd64 < none -> 9.3.0-10ubuntu2 @un uN Ib > FU=0
      Installing libgcc-9-dev as Depends of gcc-9
        MarkInstall libgcc-9-dev:amd64 < none -> 9.3.0-10ubuntu2 @un uN Ib > FU=0
        Installing libasan5 as Depends of libgcc-9-dev
          MarkInstall libasan5:amd64 < none -> 9.3.0-10ubuntu2 @un uN > FU=0
        Installing libubsan1 as Depends of libgcc-9-dev
          MarkInstall libubsan1:amd64 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
    Installing libstdc++-9-dev as Depends of g++-9
      MarkInstall libstdc++-9-dev:amd64 < none -> 9.3.0-10ubuntu2 @un uN > FU=0
  MarkInstall eom:amd64 < 1.20.0-2ubuntu1 -> 1.24.0-1 @ii umU Ib > FU=0
  Installing gir1.2-eom-1.0 as Depends of eom
    MarkInstall gir1.2-eom-1.0:amd64 < none -> 1.24.0-1 @un uN > FU=0
  Installing libexempi8 as Depends of eom
    MarkInstall libexempi8:amd64 < none -> 2.5.1-1build1 @un uN > FU=0
  MarkInstall mate-panel:amd64 < 1.20.1-3ubuntu1 -> 1.24.0-2 @ii umU Ib > FU=0
  Installing libgtk-layer-shell0 as Depends of mate-panel
    MarkInstall libgtk-layer-shell0:amd64 < none -> 0.1.0-3 @un uN > FU=0
  MarkInstall dnsmasq-base:amd64 < 2.79-1 -> 2.80-1.1ubuntu1 @ii umU Ib > FU=0
  Installing libhogweed5 as Depends of dnsmasq-base
    MarkInstall libhogweed5:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall python3-pil:amd64 < 5.1.0-1ubuntu0.3 -> 7.0.0-4ubuntu0.1 @ii umU Ib > FU=0
  Installing libimagequant0 as Depends of python3-pil
    MarkInstall libimagequant0:amd64 < none -> 2.12.2-1.1 @un uN > FU=0
  MarkInstall python3-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python3-entrypoints as Depends of python3-keyring
    MarkInstall python3-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN > FU=0
  MarkInstall libc6:i386 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9.1 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libc6
    MarkInstall libgcc-s1:i386 < none -> 10-20200411-0ubuntu1 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:i386 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
  Installing libcrypt1 as Depends of libc6
    MarkInstall libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  new important dependency: libidn2-0:i386
  Installing libidn2-0 as Recommends of libc6
    MarkInstall libidn2-0:i386 < none -> 2.2.0-2 @un uN Ib > FU=0
    Installing libunistring2 as Depends of libidn2-0
      MarkInstall libunistring2:i386 < none -> 0.9.10-2 @un uN > FU=0
  MarkInstall qemu-system-x86:amd64 < 1:2.11+dfsg-1ubuntu7.32 -> 1:4.2-3ubuntu6.6 @ii umU IPb > FU=0
  new important dependency: ovmf:amd64
  Installing ovmf as Recommends of qemu-system-x86
    MarkInstall ovmf:amd64 < none -> 0~20191122.bd85bf54-2ubuntu3 @un uN > FU=0
  MarkInstall xfce4-settings:amd64 < 4.12.4-0ubuntu0.18.04.1 -> 4.14.3-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: xiccd:amd64
  Installing xiccd as Recommends of xfce4-settings
    MarkInstall xiccd:amd64 < none -> 0.3.0-1 @un uN > FU=0
  MarkInstall libnet-dns-perl:amd64 < 1.10-2 -> 1.22-1 @ii umU IPb > FU=0
  new important dependency: libdigest-bubblebabble-perl:amd64
  Installing libdigest-bubblebabble-perl as Recommends of libnet-dns-perl
    MarkInstall libdigest-bubblebabble-perl:amd64 < none -> 0.02-2 @un uN > FU=0
  new important dependency: libnet-dns-sec-perl:amd64
  Installing libnet-dns-sec-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-dns-sec-perl:amd64 < none -> 1.15-1 @un uN > FU=0
  new important dependency: libnet-libidn-perl:amd64
  Installing libnet-libidn-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-libidn-perl:amd64 < none -> 0.12.ds-3build2 @un uN > FU=0
  MarkInstall dmeventd:amd64 < 2:1.02.145-4.1ubuntu3.18.04.3 -> 2:1.02.167-1ubuntu1 @ii umU Ib > FU=0
  Installing liblvm2cmd2.03 as Depends of dmeventd
    MarkInstall liblvm2cmd2.03:amd64 < none -> 2.03.07-1ubuntu1 @un uN > FU=0
  MarkInstall etherape:amd64 < 0.9.16-1 -> 0.9.18-2 @ii umU Ib > FU=0
  Installing libgoocanvas-2.0-9 as Depends of etherape
    MarkInstall libgoocanvas-2.0-9:amd64 < none -> 2.0.4-1 @un uN Ib > FU=0
    Installing libgoocanvas-2.0-common as Depends of libgoocanvas-2.0-9
      MarkInstall libgoocanvas-2.0-common:amd64 < none -> 2.0.4-1 @un uN > FU=0
  MarkInstall indicator-sound:amd64 < 12.10.2+18.04.20180420.3-0ubuntu1 -> 12.10.2+18.10.20180612-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: accountsservice-ubuntu-schemas:amd64
  Installing accountsservice-ubuntu-schemas as Recommends of indicator-sound
    MarkInstall accountsservice-ubuntu-schemas:amd64 < none -> 0.0.7+17.10.20170922-0ubuntu1 @un uN > FU=0
  MarkInstall python3-louis:amd64 < 3.5.0-1ubuntu0.3 -> 3.12.0-3 @ii umU Ib > FU=0
  Installing liblouis20 as Depends of python3-louis
    MarkInstall liblouis20:amd64 < none -> 3.12.0-3 @un uN > FU=0
  MarkInstall lvm2:amd64 < 2.02.176-4.1ubuntu3.18.04.3 -> 2.03.07-1ubuntu1 @ii umU IPb > FU=0
  new important dependency: thin-provisioning-tools:amd64
  Installing thin-provisioning-tools as Recommends of lvm2
    MarkInstall thin-provisioning-tools:amd64 < none -> 0.8.5-4build1 @un uN > FU=0
  MarkInstall python3-ipython:amd64 < 5.5.0-1 -> 7.13.0-1 @ii umU Ib > FU=0
  Installing python3-backcall as Depends of python3-ipython
    MarkInstall python3-backcall:amd64 < none -> 0.1.0-2 @un uN > FU=0
  Installing python3-jedi as Depends of python3-ipython
    MarkInstall python3-jedi:amd64 < none -> 0.15.2-1 @un uN Ib > FU=0
    Installing python3-parso as Depends of python3-jedi
      MarkInstall python3-parso:amd64 < none -> 0.5.2-1ubuntu1 @un uN > FU=0
  MarkInstall mate-control-center:amd64 < 1.20.2-2ubuntu1 -> 1.24.0-1 @ii umU Ib > FU=0
  Installing libmarco-private2 as Depends of mate-control-center
    MarkInstall libmarco-private2:amd64 < none -> 1.24.0-1ubuntu1 @un uN Ib > FU=0
     Removing: libmarco-private1
      MarkDelete libmarco-private1:amd64 < 1.20.1-2ubuntu1 @ii mK > FU=0
  MarkInstall gstreamer1.0-plugins-bad:amd64 < 1.14.5-0ubuntu1~18.04.1 -> 1.16.2-2.1ubuntu1 @ii umU Ib > FU=0
  Installing libfluidsynth2 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libfluidsynth2:amd64 < none -> 2.1.1-2 @un uN Ib > FU=0
    Installing libinstpatch-1.0-2 as Depends of libfluidsynth2
      MarkInstall libinstpatch-1.0-2:amd64 < none -> 1.1.2-2build1 @un uN > FU=0
    Installing timgm6mb-soundfont as Depends of libfluidsynth2
      MarkInstall timgm6mb-soundfont:amd64 < none -> 1.3-3 @un uN > FU=0
  Installing libilmbase24 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libilmbase24:amd64 < none -> 2.3.0-6build1 @un uN > FU=0
  Installing libopenexr24 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libopenexr24:amd64 < none -> 2.3.0-6ubuntu0.2 @un uN > FU=0
  Installing libsrt1 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libsrt1:amd64 < none -> 1.4.0-1build1 @un uN > FU=0
  Installing libusrsctp1 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libusrsctp1:amd64 < none -> 0.9.3.0+20190901-1 @un uN > FU=0
  MarkInstall python3-matplotlib:amd64 < 2.1.1-2ubuntu3 -> 3.1.2-1ubuntu4 @ii umU Ib > FU=0
  Installing python3-kiwisolver as Depends of python3-matplotlib
    MarkInstall python3-kiwisolver:amd64 < none -> 1.0.1-3build1 @un uN > FU=0
  MarkInstall python3-lazr.restfulclient:amd64 < 0.13.5-1 -> 0.14.2-2build1 @ii umU Ib > FU=0
  Installing python3-oauthlib as Depends of python3-lazr.restfulclient
    MarkInstall python3-oauthlib:amd64 < none -> 3.1.0-1ubuntu2 @un uN Ib > FU=0
    Installing python3-blinker as Depends of python3-oauthlib
      MarkInstall python3-blinker:amd64 < none -> 1.4+dfsg1-0.3ubuntu1 @un uN > FU=0
    Installing python3-jwt as Depends of python3-oauthlib
      MarkInstall python3-jwt:amd64 < none -> 1.7.1-2ubuntu2 @un uN > FU=0
  MarkInstall procps:amd64 < 2:3.3.12-3ubuntu1.2 -> 2:3.3.16-1ubuntu2 @ii umU Ib > FU=0
  Installing libprocps8 as Depends of procps
    MarkInstall libprocps8:amd64 < none -> 2:3.3.16-1ubuntu2 @un uN > FU=0
  MarkInstall xfce4-panel:amd64 < 4.12.2-1ubuntu1 -> 4.14.3-1 @ii umU Ib > FU=0
  Installing libgarcon-gtk3-1-0 as Depends of xfce4-panel
    MarkInstall libgarcon-gtk3-1-0:amd64 < none -> 0.6.4-1 @un uN > FU=0
  MarkInstall alsa-utils:amd64 < 1.1.3-1ubuntu1 -> 1.2.2-1ubuntu1 @ii umU Ib > FU=0
  Installing libatopology2 as Depends of alsa-utils
    MarkInstall libatopology2:amd64 < none -> 1.2.2-2.1ubuntu2 @un uN > FU=0
  MarkInstall orca:amd64 < 3.28.0-3ubuntu1 -> 3.36.2-1ubuntu1~20.04.1 @ii umU IPb > FU=0
  MarkInstall libvoikko1:amd64 < 4.1.1-1.1 -> 4.3-1build1 @ii umU Ib > FU=0
  Installing libhfstospell10 as Depends of libvoikko1
    MarkInstall libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib > FU=0
     Removing: libhfstospell9
      MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
  MarkInstall kio-extras:amd64 < 4:17.12.3-0ubuntu2 -> 4:19.12.3a-0ubuntu2 @ii umU Ib > FU=0
  Installing libkf5activitiesstats1 as Depends of kio-extras
    MarkInstall libkf5activitiesstats1:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall libwmf0.2-7:amd64 < 0.2.8.4-12 -> 0.2.8.4-17ubuntu1 @ii umU IPb > FU=0
  new important dependency: fonts-urw-base35:amd64
  Installing fonts-urw-base35 as Recommends of libwmf0.2-7
    MarkInstall fonts-urw-base35:amd64 < none -> 20170801.1-3 @un uN > FU=0
  MarkInstall xfpanel-switch:amd64 < 1.0.7-0ubuntu2 -> 1.0.10-0ubuntu1 @ii umU Ib > FU=0
  Installing xfce4-panel-profiles as Depends of xfpanel-switch
    MarkInstall xfce4-panel-profiles:amd64 < none -> 1.0.10-0ubuntu1 @un uN > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
  MarkInstall libkf5bookmarks5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: keditbookmarks:amd64
  Installing keditbookmarks as Recommends of libkf5bookmarks5
    MarkInstall keditbookmarks:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5kiogui5 as Depends of keditbookmarks
      MarkInstall libkf5kiogui5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib > FU=0
   Removing: fwupdate-signed
    MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
   Removing: libfwup1
    MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
  MarkInstall dh-strip-nondeterminism:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libdebhelper-perl as Depends of dh-strip-nondeterminism
    MarkInstall libdebhelper-perl:amd64 < none -> 12.10ubuntu1 @un uN > FU=0
  MarkInstall indicator-session:amd64 < 17.3.20+17.10.20171006-0ubuntu1 -> 17.3.20+19.10.20190921-0ubuntu1 @ii umU Ib > FU=0
  Installing unity-settings-daemon-schemas as Depends of indicator-session
    MarkInstall unity-settings-daemon-schemas:amd64 < none -> 15.04.1+20.04.20200325-0ubuntu1 @un uN > FU=0
  Installing gnome-settings-daemon-common as Depends of indicator-session
    MarkInstall gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib > FU=0
     Removing: gnome-settings-daemon-schemas
      MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
  MarkInstall libfile-stripnondeterminism-perl:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libsub-override-perl as Depends of libfile-stripnondeterminism-perl
    MarkInstall libsub-override-perl:amd64 < none -> 0.09-2 @un uN > FU=0
  MarkInstall libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib > FU=0
  MarkInstall libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib > FU=0
  MarkInstall libfontconfig1-dev:amd64 < 2.12.6-0ubuntu2 -> 2.13.1-2ubuntu3 @ii umU Ib > FU=0
  Installing uuid-dev as Depends of libfontconfig1-dev
    MarkInstall uuid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  MarkInstall libreoffice-style-galaxy:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-style-colibre as Depends of libreoffice-style-galaxy
    MarkInstall libreoffice-style-colibre:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libcairo-perl:amd64 < 1.106-2build2 -> 1.107-1 @ii umU Ib > FU=0
  Installing libextutils-depends-perl as Depends of libcairo-perl
    MarkInstall libextutils-depends-perl:amd64 < none -> 0.8000-1 @un uN > FU=0
  Installing libextutils-pkgconfig-perl as Depends of libcairo-perl
    MarkInstall libextutils-pkgconfig-perl:amd64 < none -> 1.16-1 @un uN > FU=0
  MarkInstall aisleriot:amd64 < 1:3.22.5-1 -> 1:3.22.9-1 @ii umU Ib > FU=0
  Installing guile-2.2-libs as Depends of aisleriot
    MarkInstall guile-2.2-libs:amd64 < none -> 2.2.7+1-4 @un uN > FU=0
  MarkInstall binutils-x86-64-linux-gnu:amd64 < 2.30-21ubuntu1~18.04.4 -> 2.34-6ubuntu1 @ii umU Ib > FU=0
  Installing libctf-nobfd0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf-nobfd0:amd64 < none -> 2.34-6ubuntu1 @un uN > FU=0
  Installing libctf0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf0:amd64 < none -> 2.34-6ubuntu1 @un uN > FU=0
  MarkInstall fonts-noto:amd64 < 20171026-2 -> 20200323-1build1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing fonts-noto-core as Depends of fonts-noto
    MarkInstall fonts-noto-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-cjk-extra:amd64
  Installing fonts-noto-cjk-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-cjk-extra:amd64 < none -> 1:20190410+repack1-2 @un uN > FU=0
  new important dependency: fonts-noto-extra:amd64
  Installing fonts-noto-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-core:amd64
  Installing fonts-noto-ui-core as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-extra:amd64
  Installing fonts-noto-ui-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  MarkInstall mate-applet-appmenu:amd64 < 0.6.94+repack1-1 -> 0.7.3+dfsg1-2 @ii umU NPb Ib > FU=0
  Installing appmenu-registrar as Depends of mate-applet-appmenu
    MarkInstall appmenu-registrar:amd64 < none -> 0.7.3-2 @un uN Ib > FU=0
     Removing: vala-panel-appmenu-registrar
      MarkDelete vala-panel-appmenu-registrar:amd64 < 0.6.94+repack1-1 @ii mK NPb Ib > FU=0
  MarkInstall libpango1.0-dev:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi-dev as Depends of libpango1.0-dev
    MarkInstall libfribidi-dev:amd64 < none -> 1.0.8-2 @un uN > FU=0
  Installing libthai-dev as Depends of libpango1.0-dev
    MarkInstall libthai-dev:amd64 < none -> 0.1.28-3 @un uN Ib > FU=0
    Installing libdatrie-dev as Depends of libthai-dev
      MarkInstall libdatrie-dev:amd64 < none -> 0.2.12-3 @un uN > FU=0
  Installing pango1.0-tools as Depends of libpango1.0-dev
    MarkInstall pango1.0-tools:amd64 < none -> 1.44.7-2ubuntu4 @un uN > FU=0
  MarkInstall gimp:amd64 < 2.8.22-1 -> 2.10.18-1 @ii umU Ib > FU=0
  Installing libgegl-0.4-0 as Depends of gimp
    MarkInstall libgegl-0.4-0:amd64 < none -> 0.4.22-3 @un uN Ib > FU=0
    Installing libgegl-common as Depends of libgegl-0.4-0
      MarkInstall libgegl-common:amd64 < none -> 0.4.22-3 @un uN > FU=0
  Installing libheif1 as Depends of gimp
    MarkInstall libheif1:amd64 < none -> 1.6.1-1build1 @un uN > FU=0
  Installing libmypaint-1.5-1 as Depends of gimp
    MarkInstall libmypaint-1.5-1:amd64 < none -> 1.5.1-1 @un uN Ib > FU=0
    Installing libmypaint-common as Depends of libmypaint-1.5-1
      MarkInstall libmypaint-common:amd64 < none -> 1.5.1-1 @un uN > FU=0
  MarkInstall gitg:amd64 < 3.26.0-4 -> 3.32.1-1 @ii umU Ib > FU=0
  Installing libdazzle-1.0-0 as Depends of gitg
    MarkInstall libdazzle-1.0-0:amd64 < none -> 3.36.0-1 @un uN > FU=0
  MarkInstall gnome-calculator:amd64 < 1:3.28.2-1~ubuntu18.04.3 -> 1:3.36.0-1ubuntu1 @ii umU Ib > FU=0
  Installing libgtksourceview-4-0 as Depends of gnome-calculator
    MarkInstall libgtksourceview-4-0:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
    Installing libgtksourceview-4-common as Depends of libgtksourceview-4-0
      MarkInstall libgtksourceview-4-common:amd64 < none -> 4.6.0-1 @un uN > FU=0
    MarkKeep python-caja:amd64 < 1.20.0-1 @ii mR > FU=0
  MarkInstall libllvm10:i386 < 1:10.0.0-4ubuntu1~18.04.2 -> 1:10.0.0-4ubuntu1 @ii umU Ib > FU=0
  Installing libffi7 as Depends of libllvm10
    MarkInstall libffi7:i386 < none -> 3.3-4 @un uN > FU=0
  Installing libtinfo6 as Depends of libllvm10
    MarkInstall libtinfo6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib > FU=0
   Removing: libapt-pkg5.0
    MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mK > FU=0
  MarkInstall cups-filters:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libqpdf26 as Depends of cups-filters
    MarkInstall libqpdf26:amd64 < none -> 9.1.1-1build1 @un uN > FU=0
  MarkInstall imagemagick-6.q16:amd64 < 8:6.9.7.4+dfsg-16ubuntu6.8 -> 8:6.9.10.23+dfsg-2.1ubuntu11.1 @ii umU Ib > FU=0
  Installing libmagickcore-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.1 @un uN > FU=0
  Installing libmagickwand-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickwand-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.1 @un uN > FU=0
  new important dependency: libmagickcore-6.q16-6-extra:amd64
  Installing libmagickcore-6.q16-6-extra as Recommends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6-extra:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.1 @un uN > FU=0
  MarkInstall libqt5gui5:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-xinput0 as Depends of libqt5gui5
    MarkInstall libxcb-xinput0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
  Installing libsensors4 as Depends of libsnmp30
      MarkKeep libsensors4:amd64 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall wireshark-common:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU Ib > FU=0
  Installing libwireshark13 as Depends of wireshark-common
    MarkInstall libwireshark13:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
    Installing libwiretap10 as Depends of libwireshark13
      MarkInstall libwiretap10:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
      Installing libwsutil11 as Depends of libwiretap10
        MarkInstall libwsutil11:amd64 < none -> 3.2.3-1 @un uN > FU=0
  MarkInstall libfile-mimeinfo-perl:amd64 < 0.28-1 -> 0.29-1 @ii umU IPb > FU=0
  new important dependency: libio-stringy-perl:amd64
  Installing libio-stringy-perl as Recommends of libfile-mimeinfo-perl
    MarkInstall libio-stringy-perl:amd64 < none -> 2.111-3 @un uN > FU=0
  MarkInstall ubuntu-drivers-common:amd64 < 1:0.5.2.5 -> 1:0.8.4~0.20.04.3 @ii umU Ib > FU=0
  Installing python3-click as Depends of ubuntu-drivers-common
    MarkInstall python3-click:amd64 < none -> 7.0-3 @un uN Ib > FU=0
    Installing python3-colorama as Depends of python3-click
      MarkInstall python3-colorama:amd64 < none -> 0.4.3-1build1 @un uN > FU=0
  MarkInstall blueman:amd64 < 2.0.5-1ubuntu1 -> 2.1.2-1 @ii umU Ib > FU=0
  Installing gir1.2-nm-1.0 as Depends of blueman
    MarkInstall gir1.2-nm-1.0:amd64 < none -> 1.22.10-1ubuntu2.1 @un uN > FU=0
  MarkInstall libmirprotobuf3:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libprotobuf-lite17 as Depends of libmirprotobuf3
    MarkInstall libprotobuf-lite17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall libxenstore3.0:amd64 < 4.9.2-0ubuntu1 -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @ii umU Ib > FU=0
  Installing libxentoolcore1 as Depends of libxenstore3.0
    MarkInstall libxentoolcore1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
  MarkInstall nmap:amd64 < 7.60-1ubuntu5 -> 7.80+dfsg1-2build1 @ii umU Ib > FU=0
  Installing nmap-common as Depends of nmap
    MarkInstall nmap-common:amd64 < none -> 7.80+dfsg1-2build1 @un uN > FU=0
  Installing liblinear4 as Depends of nmap
    MarkInstall liblinear4:amd64 < none -> 2.3.0+dfsg-3build1 @un uN > FU=0
  Installing lua-lpeg as Depends of nmap
    MarkInstall lua-lpeg:amd64 < none -> 1.0.2-1 @un uN > FU=0
  MarkInstall libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall libimobiledevice6:amd64 < 1.2.1~git20171128.5a854327+dfsg-0.1 -> 1.2.1~git20191129.9f79242-1build1 @ii umU Ib > FU=0
  Installing libusbmuxd6 as Depends of libimobiledevice6
    MarkInstall libusbmuxd6:amd64 < none -> 2.0.1-2 @un uN > FU=0
  MarkInstall libmate-menu2:amd64 < 1.20.0-2 -> 1.24.0-1 @ii umU Ib > FU=0
   Removing: python-mate-menu
    MarkDelete python-mate-menu:amd64 < 1.20.0-2 @ii mK > FU=0
    MarkKeep libpython-dev:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
  MarkInstall libmirclient9:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libcapnp-0.7.0 as Depends of libmirclient9
    MarkInstall libcapnp-0.7.0:amd64 < none -> 0.7.0-6 @un uN > FU=0
  MarkInstall libepub0:amd64 < 0.2.2-4ubuntu1 -> 0.2.2-4ubuntu2 @ii umU Ib > FU=0
  Installing libzip5 as Depends of libepub0
    MarkInstall libzip5:amd64 < none -> 1.5.1-0ubuntu1 @un uN > FU=0
  MarkInstall libfreetype6-dev:amd64 < 2.8.1-2ubuntu2 -> 2.10.1-2 @ii umU Ib > FU=0
  Installing libfreetype-dev as Depends of libfreetype6-dev
    MarkInstall libfreetype-dev:amd64 < none -> 2.10.1-2 @un uN > FU=0
  MarkInstall libvirt-daemon-system:amd64 < 4.0.0-1ubuntu8.17 -> 6.0.0-0ubuntu8.4 @ii umU Ib > FU=0
  Installing libvirt-daemon-system-systemd as Depends of libvirt-daemon-system
    MarkInstall libvirt-daemon-system-systemd:amd64 < none -> 6.0.0-0ubuntu8.4 @un uN Ib > FU=0
    Installing systemd-container as Depends of libvirt-daemon-system-systemd
      MarkInstall systemd-container:amd64 < none -> 245.4-4ubuntu3.2 @un uN IPb > FU=0
      Installing libnss-mymachines as Recommends of systemd-container
        MarkInstall libnss-mymachines:amd64 < none -> 245.4-4ubuntu3.2 @un uN > FU=0
  MarkInstall mailutils:amd64 < 1:3.4-1 -> 1:3.7-2.1 @ii umU Ib > FU=0
  Installing libmailutils6 as Depends of mailutils
    MarkInstall libmailutils6:amd64 < none -> 1:3.7-2.1 @un uN Ib > FU=0
     Removing: libmailutils5
      MarkDelete libmailutils5:amd64 < 1:3.4-1 @ii mK Ib > FU=0
  MarkInstall acpi-support:amd64 < 0.142 -> 0.143 @ii umU NPb IPb > FU=0
    MarkKeep libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mR > FU=0
  MarkInstall fonts-gujr:amd64 < 2:1.2 -> 2:1.3 @ii umU Ib > FU=0
  Installing fonts-yrsa-rasa as Depends of fonts-gujr
    MarkInstall fonts-yrsa-rasa:amd64 < none -> 1.002-2 @un uN > FU=0
  MarkInstall printer-driver-gutenprint:amd64 < 5.2.13-2 -> 5.3.3-4 @ii umU Ib > FU=0
  Installing libgutenprint9 as Depends of printer-driver-gutenprint
    MarkInstall libgutenprint9:amd64 < none -> 5.3.3-4 @un uN Ib > FU=0
    Installing libgutenprint-common as Depends of libgutenprint9
      MarkInstall libgutenprint-common:amd64 < none -> 5.3.3-4 @un uN > FU=0
  MarkInstall lintian:amd64 < 2.5.81ubuntu1 -> 2.62.0 @ii umU Ib > FU=0
  Installing libcapture-tiny-perl as Depends of lintian
    MarkInstall libcapture-tiny-perl:amd64 < none -> 0.48-1 @un uN > FU=0
  Installing libclass-xsaccessor-perl as Depends of lintian
    MarkInstall libclass-xsaccessor-perl:amd64 < none -> 1.19-3build3 @un uN > FU=0
  Installing libcpanel-json-xs-perl as Depends of lintian
    MarkInstall libcpanel-json-xs-perl:amd64 < none -> 4.19-1build1 @un uN > FU=0
  Installing libdevel-size-perl as Depends of lintian
    MarkInstall libdevel-size-perl:amd64 < none -> 0.83-1build1 @un uN > FU=0
  Installing libfile-find-rule-perl as Depends of lintian
    MarkInstall libfile-find-rule-perl:amd64 < none -> 0.34-1 @un uN Ib > FU=0
    Installing libnumber-compare-perl as Depends of libfile-find-rule-perl
      MarkInstall libnumber-compare-perl:amd64 < none -> 0.03-1 @un uN > FU=0
    Installing libtext-glob-perl as Depends of libfile-find-rule-perl
      MarkInstall libtext-glob-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libfont-ttf-perl as Depends of lintian
    MarkInstall libfont-ttf-perl:amd64 < none -> 1.06-1 @un uN > FU=0
  Installing libio-async-perl as Depends of lintian
    MarkInstall libio-async-perl:amd64 < none -> 0.75-1 @un uN Ib > FU=0
    Installing libfuture-perl as Depends of libio-async-perl
      MarkInstall libfuture-perl:amd64 < none -> 0.43-1 @un uN > FU=0
    Installing libstruct-dumb-perl as Depends of libio-async-perl
      MarkInstall libstruct-dumb-perl:amd64 < none -> 0.09-1 @un uN > FU=0
    Installing libasync-mergepoint-perl as Recommends of libio-async-perl
      MarkInstall libasync-mergepoint-perl:amd64 < none -> 0.04-2 @un uN > FU=0
    Installing libsereal-perl as Recommends of libio-async-perl
      MarkInstall libsereal-perl:amd64 < none -> 4.011-1 @un uN Ib > FU=0
      Installing libsereal-decoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-decoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
      Installing libsereal-encoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-encoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
    Installing libtest-fatal-perl as Recommends of libio-async-perl
      MarkInstall libtest-fatal-perl:amd64 < none -> 0.014-1 @un uN > FU=0
    Installing libtest-refcount-perl as Recommends of libio-async-perl
      MarkInstall libtest-refcount-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libio-async-loop-epoll-perl as Depends of lintian
    MarkInstall libio-async-loop-epoll-perl:amd64 < none -> 0.20-1 @un uN Ib > FU=0
    Installing liblinux-epoll-perl as Depends of libio-async-loop-epoll-perl
      MarkInstall liblinux-epoll-perl:amd64 < none -> 0.017-1 @un uN > FU=0
  Installing libjson-maybexs-perl as Depends of lintian
    MarkInstall libjson-maybexs-perl:amd64 < none -> 1.004000-1 @un uN > FU=0
  Installing liblist-compare-perl as Depends of lintian
    MarkInstall liblist-compare-perl:amd64 < none -> 0.53-1 @un uN > FU=0
  Installing libmoo-perl as Depends of lintian
    MarkInstall libmoo-perl:amd64 < none -> 2.003006-1 @un uN Ib > FU=0
    Installing libclass-method-modifiers-perl as Depends of libmoo-perl
      MarkInstall libclass-method-modifiers-perl:amd64 < none -> 2.13-1 @un uN > FU=0
    Installing libimport-into-perl as Depends of libmoo-perl
      MarkInstall libimport-into-perl:amd64 < none -> 1.002005-1 @un uN Ib > FU=0
      Installing libmodule-runtime-perl as Depends of libimport-into-perl
        MarkInstall libmodule-runtime-perl:amd64 < none -> 0.016-1 @un uN Ib > FU=0
        Installing libparams-classify-perl as Depends of libmodule-runtime-perl
          MarkInstall libparams-classify-perl:amd64 < none -> 0.015-1build2 @un uN Ib > FU=0
          Installing libdevel-callchecker-perl as Depends of libparams-classify-perl
            MarkInstall libdevel-callchecker-perl:amd64 < none -> 0.008-1ubuntu1 @un uN Ib > FU=0
            Installing libb-hooks-op-check-perl as Depends of libdevel-callchecker-perl
              MarkInstall libb-hooks-op-check-perl:amd64 < none -> 0.22-1build2 @un uN > FU=0
            Installing libdynaloader-functions-perl as Depends of libdevel-callchecker-perl
              MarkInstall libdynaloader-functions-perl:amd64 < none -> 0.003-1 @un uN > FU=0
    Installing librole-tiny-perl as Depends of libmoo-perl
      MarkInstall librole-tiny-perl:amd64 < none -> 2.001004-1 @un uN > FU=0
    Installing libstrictures-perl as Depends of libmoo-perl
      MarkInstall libstrictures-perl:amd64 < none -> 2.000006-1 @un uN > FU=0
    Installing libsub-quote-perl as Depends of libmoo-perl
      MarkInstall libsub-quote-perl:amd64 < none -> 2.006006-1 @un uN > FU=0
  Installing libmoox-aliases-perl as Depends of lintian
    MarkInstall libmoox-aliases-perl:amd64 < none -> 0.001006-1 @un uN > FU=0
  Installing libnamespace-clean-perl as Depends of lintian
    MarkInstall libnamespace-clean-perl:amd64 < none -> 0.27-1 @un uN Ib > FU=0
    Installing libb-hooks-endofscope-perl as Depends of libnamespace-clean-perl
      MarkInstall libb-hooks-endofscope-perl:amd64 < none -> 0.24-1 @un uN Ib > FU=0
      Installing libmodule-implementation-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libmodule-implementation-perl:amd64 < none -> 0.09-1 @un uN > FU=0
      Installing libsub-exporter-progressive-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libsub-exporter-progressive-perl:amd64 < none -> 0.001013-1 @un uN > FU=0
      Installing libvariable-magic-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libvariable-magic-perl:amd64 < none -> 0.62-1build2 @un uN > FU=0
    Installing libpackage-stash-perl as Depends of libnamespace-clean-perl
      MarkInstall libpackage-stash-perl:amd64 < none -> 0.38-1 @un uN IPb > FU=0
      Installing libpackage-stash-xs-perl as Recommends of libpackage-stash-perl
        MarkInstall libpackage-stash-xs-perl:amd64 < none -> 0.29-1build1 @un uN > FU=0
    Installing libsub-identify-perl as Depends of libnamespace-clean-perl
      MarkInstall libsub-identify-perl:amd64 < none -> 0.14-1build2 @un uN > FU=0
  Installing libpath-tiny-perl as Depends of lintian
    MarkInstall libpath-tiny-perl:amd64 < none -> 0.108-1 @un uN IPb > FU=0
    Installing libunicode-utf8-perl as Recommends of libpath-tiny-perl
      MarkInstall libunicode-utf8-perl:amd64 < none -> 0.62-1build1 @un uN > FU=0
  Installing libtype-tiny-perl as Depends of lintian
    MarkInstall libtype-tiny-perl:amd64 < none -> 1.008001-2 @un uN IPb > FU=0
    Installing libref-util-perl as Recommends of libtype-tiny-perl
      MarkInstall libref-util-perl:amd64 < none -> 0.204-1 @un uN IPb > FU=0
      Installing libreadonly-perl as Recommends of libref-util-perl
        MarkInstall libreadonly-perl:amd64 < none -> 2.050-2 @un uN > FU=0
      Installing libref-util-xs-perl as Recommends of libref-util-perl
        MarkInstall libref-util-xs-perl:amd64 < none -> 0.117-1build2 @un uN > FU=0
    Installing libtype-tiny-xs-perl as Recommends of libtype-tiny-perl
      MarkInstall libtype-tiny-xs-perl:amd64 < none -> 0.016-1 @un uN > FU=0
  Installing libxml-writer-perl as Depends of lintian
    MarkInstall libxml-writer-perl:amd64 < none -> 0.625-1 @un uN > FU=0
  MarkInstall ure:amd64 < 6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-purpenvhelpergcc3-3 as Depends of ure
    MarkInstall libuno-purpenvhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjuh-java:amd64
  Installing libjuh-java as Recommends of ure
    MarkInstall libjuh-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjurt-java:amd64
  Installing libjurt-java as Recommends of ure
    MarkInstall libjurt-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libridl-java:amd64
  Installing libridl-java as Recommends of ure
    MarkInstall libridl-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libunoloader-java:amd64
  Installing libunoloader-java as Recommends of ure
    MarkInstall libunoloader-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall brltty:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libpcre2-32-0 as Depends of brltty
    MarkInstall libpcre2-32-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall libselinux1:i386 < 2.7-2build2 -> 3.0-1build2 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libselinux1
    MarkInstall libpcre2-8-0:i386 < none -> 10.34-7 @un uN > FU=0
  MarkInstall xubuntu-core:amd64 < 2.225 -> 2.233 @ii umU IPb > FU=0
  new important dependency: xfce4-screensaver:amd64
  Installing xfce4-screensaver as Recommends of xubuntu-core
    MarkInstall xfce4-screensaver:amd64 < none -> 0.1.10-0ubuntu1 @un uN > FU=0
  MarkInstall libglib2.0-dev:amd64 < 2.56.4-0ubuntu0.18.04.6 -> 2.64.3-1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing libffi-dev as Depends of libglib2.0-dev
    MarkInstall libffi-dev:amd64 < none -> 3.3-4 @un uN > FU=0
  Installing libmount-dev as Depends of libglib2.0-dev
    MarkInstall libmount-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN Ib > FU=0
    Installing libblkid-dev as Depends of libmount-dev
      MarkInstall libblkid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  Installing libselinux1-dev as Depends of libglib2.0-dev
    MarkInstall libselinux1-dev:amd64 < none -> 3.0-1build2 @un uN Ib > FU=0
    Installing libsepol1-dev as Depends of libselinux1-dev
      MarkInstall libsepol1-dev:amd64 < none -> 3.0-1 @un uN > FU=0
    Installing libpcre2-dev as Depends of libselinux1-dev
      MarkInstall libpcre2-dev:amd64 < none -> 10.34-7 @un uN Ib > FU=0
      Installing libpcre2-16-0 as Depends of libpcre2-dev
        MarkInstall libpcre2-16-0:amd64 < none -> 10.34-7 @un uN > FU=0
      Installing libpcre2-posix2 as Depends of libpcre2-dev
        MarkInstall libpcre2-posix2:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall python-bs4:amd64 < 4.6.0-1 -> 4.8.2-1 @ii umU Ib > FU=0
  Installing python-soupsieve as Depends of python-bs4
    MarkInstall python-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN Ib > FU=0
    Installing python-backports.functools-lru-cache as Depends of python-soupsieve
      MarkInstall python-backports.functools-lru-cache:amd64 < none -> 1.5-3build1 @un uN > FU=0
  MarkInstall virt-manager:amd64 < 1:1.5.1-0ubuntu1.2 -> 1:2.2.1-3ubuntu2.1 @ii umU Ib > FU=0
  Installing gir1.2-gtksource-4 as Depends of virt-manager
    MarkInstall gir1.2-gtksource-4:amd64 < none -> 4.6.0-1 @un uN > FU=0
  MarkInstall systemd:amd64 < 237-3ubuntu10.42 -> 245.4-4ubuntu3.2 @ii umU Ib > FU=0
  Installing systemd-timesyncd as Depends of systemd
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu3.2 @un uN > FU=0
  MarkInstall libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libdouble-conversion3 as Depends of libqt5core5a
    MarkInstall libdouble-conversion3:amd64 < none -> 3.1.5-4ubuntu1 @un uN > FU=0
   Removing: libqtcore4
    MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
  MarkInstall python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > FU=0
  Installing python as Depends of python-dev
    Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
  MarkInstall libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
  MarkInstall debhelper:amd64 < 11.1.6ubuntu2 -> 12.10ubuntu1 @ii umU Ib > FU=0
  Installing dwz as Depends of debhelper
    MarkInstall dwz:amd64 < none -> 0.13-5 @un uN > FU=0
  MarkInstall libkf5windowsystem5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-res0 as Depends of libkf5windowsystem5
    MarkInstall libxcb-res0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libgl1-mesa-dri:i386 < 20.0.8-0ubuntu1~18.04.1 -> 20.0.8-0ubuntu1~20.04.1 @ii umU Ib > FU=0
  Installing libsensors5 as Depends of libgl1-mesa-dri
    MarkInstall libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN > FU=0
  Installing libvulkan1 as Depends of libgl1-mesa-dri
    MarkInstall libvulkan1:i386 < none -> 1.2.131.2-1 @un uN IPb > FU=0
    Installing mesa-vulkan-drivers as Recommends of libvulkan1
      MarkInstall mesa-vulkan-drivers:i386 < none -> 20.0.8-0ubuntu1~20.04.1 @un uN Ib > FU=0
      Installing libwayland-client0 as Depends of mesa-vulkan-drivers
        MarkInstall libwayland-client0:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libxcb-randr0 as Depends of mesa-vulkan-drivers
        MarkInstall libxcb-randr0:i386 < none -> 1.14-2 @un uN > FU=0
  MarkInstall python-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python-entrypoints as Depends of python-keyring
    MarkInstall python-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN Ib > FU=0
    Installing python-configparser as Depends of python-entrypoints
      MarkInstall python-configparser:amd64 < none -> 3.5.0b2-3build1 @un uN > FU=0
   Removing: python-keyrings.alt
    MarkDelete python-keyrings.alt:amd64 < 3.0-1 @ii mK > FU=0
  MarkInstall xfce4-clipman:amd64 < 2:1.4.2-1 -> 2:1.4.4-1 @ii umU Ib > FU=0
  Installing libqrencode4 as Depends of xfce4-clipman
    MarkInstall libqrencode4:amd64 < none -> 4.0.2-2 @un uN > FU=0
  MarkInstall openssh-client:amd64 < 1:7.6p1-4ubuntu0.3 -> 1:8.2p1-4ubuntu0.1 @ii umU Ib > FU=0
  Installing libfido2-1 as Depends of openssh-client
    MarkInstall libfido2-1:amd64 < none -> 1.3.1-1ubuntu2 @un uN Ib > FU=0
    Installing libcbor0.6 as Depends of libfido2-1
      MarkInstall libcbor0.6:amd64 < none -> 0.6.0-0ubuntu1 @un uN > FU=0
  MarkInstall libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
  Installing libqtcore4 as Depends of libqt4-sql
      MarkKeep libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > FU=0
  MarkInstall ubuntu-mate-wallpapers:amd64 < 18.04.11 -> 20.04.2 @ii umU Ib > FU=0
  Installing ubuntu-mate-wallpapers-focal as Depends of ubuntu-mate-wallpapers
    MarkInstall ubuntu-mate-wallpapers-focal:amd64 < none -> 20.04.2 @un uN > FU=0
  MarkInstall liblouisutdml-bin:amd64 < 2.7.0-1 -> 2.8.0-3 @ii umU Ib > FU=0
  Installing liblouisutdml9 as Depends of liblouisutdml-bin
    MarkInstall liblouisutdml9:amd64 < none -> 2.8.0-3 @un uN > FU=0
  MarkInstall palapeli:amd64 < 4:17.12.3-0ubuntu2 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5kdegames7 as Depends of palapeli
    MarkInstall libkf5kdegames7:amd64 < none -> 4:19.12.3-1ubuntu1 @un uN Ib > FU=0
    Installing libkf5kdegames-data as Depends of libkf5kdegames7
      MarkInstall libkf5kdegames-data:amd64 < none -> 4:19.12.3-1ubuntu1 @un uN > FU=0
  MarkInstall libphonon4qt5-4:amd64 < 4:4.10.0-2 -> 4:4.11.1-3build1 @ii umU Ib > FU=0
  Installing libphonon4qt5-data as Depends of libphonon4qt5-4
    MarkInstall libphonon4qt5-data:amd64 < none -> 4:4.11.1-3build1 @un uN > FU=0
    MarkKeep libmailutils5:amd64 < 1:3.4-1 @ii mR > FU=0
  MarkInstall pysolfc:amd64 < 2.0-4 -> 2.6.4-3 @ii umU NPb Ib > FU=0
  Installing python3-pygame as Depends of pysolfc
    MarkInstall python3-pygame:amd64 < none -> 1.9.6+dfsg-2build1 @un uN > FU=0
  Installing python3-random2 as Depends of pysolfc
    MarkInstall python3-random2:amd64 < none -> 1.0.1-2 @un uN > FU=0
  new important dependency: python3-pil.imagetk:amd64
  Installing python3-pil.imagetk as Recommends of pysolfc
    MarkInstall python3-pil.imagetk:amd64 < none -> 7.0.0-4ubuntu0.1 @un uN > FU=0
  MarkInstall libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
  Installing libapt-pkg5.0 as Depends of libept1.5.0
      MarkKeep libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mR > FU=0
  MarkInstall cups-filters-core-drivers:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libpoppler-cpp0v5 as Depends of cups-filters-core-drivers
    MarkInstall libpoppler-cpp0v5:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall libpeas-1.0-python2loader:amd64 < 1.22.0-2 @ii mK Ib > FU=0
  MarkInstall xfce4-quicklauncher-plugin:amd64 < 1.9.4-11build1 @ii mK Ib > FU=0
  MarkInstall libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall fwupd:amd64 < 1.2.10-1ubuntu2~ubuntu18.04.5 -> 1.3.11-1~focal1 @ii umU Ib > FU=0
  Installing libfwupdplugin1 as Depends of fwupd
    MarkInstall libfwupdplugin1:amd64 < none -> 1.3.11-1~focal1 @un uN > FU=0
  Installing libtss2-esys0 as Depends of fwupd
    MarkInstall libtss2-esys0:amd64 < none -> 2.3.2-1 @un uN Ib > FU=0
    Installing tpm-udev as Depends of libtss2-esys0
      MarkInstall tpm-udev:amd64 < none -> 0.4 @un uN > FU=0
  new important dependency: bolt:amd64
  Installing bolt as Recommends of fwupd
    MarkInstall bolt:amd64 < none -> 0.8-4ubuntu1 @un uN > FU=0
  MarkInstall libqt5webenginecore5:amd64 < 5.9.5+dfsg-0ubuntu2 -> 5.12.8+dfsg-0ubuntu1.1 @ii umU Ib > FU=0
  Installing libevent-2.1-7 as Depends of libqt5webenginecore5
    MarkInstall libevent-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  Installing libre2-5 as Depends of libqt5webenginecore5
    MarkInstall libre2-5:amd64 < none -> 20200101+dfsg-1build1 @un uN > FU=0
  MarkInstall pokerth:amd64 < 1.1.1-7ubuntu1 -> 1.1.2-1build6 @ii umU Ib > FU=0
  Installing libboost-random1.71.0 as Depends of pokerth
    MarkInstall libboost-random1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing libboost-regex1.71.0 as Depends of pokerth
    MarkInstall libboost-regex1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall transmission-gtk:amd64 < 2.92-3ubuntu2 -> 2.94-2ubuntu3 @ii umU Ib > FU=0
  Installing libminiupnpc17 as Depends of transmission-gtk
    MarkInstall libminiupnpc17:amd64 < none -> 2.1.20190824-0ubuntu2 @un uN > FU=0
    MarkKeep uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mR > FU=0
  MarkInstall calibre-bin:amd64 < 3.21.0+dfsg-1build1 -> 4.99.4+dfsg+really4.12.0-1build1 @ii umU Ib > FU=0
  Installing libpodofo0.9.6 as Depends of calibre-bin
    MarkInstall libpodofo0.9.6:amd64 < none -> 0.9.6+dfsg-5build1 @un uN > FU=0
  MarkInstall python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
  MarkInstall qemu-system-arm:amd64 < 1:2.11+dfsg-1ubuntu7.32 -> 1:4.2-3ubuntu6.6 @ii umU IPb > FU=0
  new important dependency: qemu-efi-aarch64:amd64
  Installing qemu-efi-aarch64 as Recommends of qemu-system-arm
    MarkInstall qemu-efi-aarch64:amd64 < none -> 0~20191122.bd85bf54-2ubuntu3 @un uN > FU=0
  new important dependency: qemu-efi-arm:amd64
  Installing qemu-efi-arm as Recommends of qemu-system-arm
    MarkInstall qemu-efi-arm:amd64 < none -> 0~20191122.bd85bf54-2ubuntu3 @un uN > FU=0
  MarkInstall xubuntu-community-wallpapers:amd64 < 18.04.0 -> 20.04.0 @ii umU Ib > FU=0
  Installing xubuntu-community-wallpapers-focal as Depends of xubuntu-community-wallpapers
    MarkInstall xubuntu-community-wallpapers-focal:amd64 < none -> 20.04.0 @un uN > FU=0
  MarkInstall python-wheel:amd64 < 0.30.0-0.2 @ii mK IPb > FU=0
  previously satisfied important dependency on python-keyrings.alt:amd64
  Installing python-keyrings.alt as Recommends of python-wheel
      MarkKeep python-keyrings.alt:amd64 < 3.0-1 @ii mR > FU=0
  MarkInstall duplicity:amd64 < 0.7.17-0ubuntu1.1 -> 0.8.11.1612-1 @ii umU Ib > FU=0
  Installing librsync2 as Depends of duplicity
    MarkInstall librsync2:amd64 < none -> 2.0.2-1ubuntu1 @un uN > FU=0
  Installing python3-fasteners as Depends of duplicity
    MarkInstall python3-fasteners:amd64 < none -> 0.14.1-2 @un uN Ib > FU=0
    Installing python3-monotonic as Depends of python3-fasteners
      MarkInstall python3-monotonic:amd64 < none -> 1.5-0ubuntu2 @un uN > FU=0
  Installing python3-future as Depends of duplicity
    MarkInstall python3-future:amd64 < none -> 0.18.2-2 @un uN > FU=0
  Installing python3-lockfile as Depends of duplicity
    MarkInstall python3-lockfile:amd64 < none -> 1:0.12.2-2ubuntu2 @un uN > FU=0
  new important dependency: python3-paramiko:amd64
  Installing python3-paramiko as Recommends of duplicity
    MarkInstall python3-paramiko:amd64 < none -> 2.6.0-2 @un uN Ib > FU=0
    Installing python3-bcrypt as Depends of python3-paramiko
      MarkInstall python3-bcrypt:amd64 < none -> 3.1.7-2ubuntu1 @un uN > FU=0
    Installing python3-nacl as Depends of python3-paramiko
      MarkInstall python3-nacl:amd64 < none -> 1.3.0-5 @un uN > FU=0
  MarkInstall libpci3:amd64 < 1:3.5.2-1ubuntu1.1 -> 1:3.6.4-1 @ii umU Ib > FU=0
  Installing pci.ids as Depends of libpci3
    MarkInstall pci.ids:amd64 < none -> 0.0~2020.03.20-1 @un uN > FU=0
  MarkInstall python-ldb:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK Ib > FU=0
  Installing libldb1 as Depends of python-ldb
      MarkKeep libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > FU=0
  MarkInstall libreoffice-help-en-us:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-help-common as Depends of libreoffice-help-en-us
    MarkInstall libreoffice-help-common:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall vlc-plugin-base:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libixml10 as Depends of vlc-plugin-base
    MarkInstall libixml10:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  Installing liblivemedia77 as Depends of vlc-plugin-base
    MarkInstall liblivemedia77:amd64 < none -> 2020.01.19-1build1 @un uN > FU=0
  Installing libspatialaudio0 as Depends of vlc-plugin-base
    MarkInstall libspatialaudio0:amd64 < none -> 0.3.0+git20180730+dfsg1-2build1 @un uN > FU=0
  Installing libupnp13 as Depends of vlc-plugin-base
    MarkInstall libupnp13:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  MarkInstall calibre:amd64 < 3.21.0+dfsg-1build1 -> 4.99.4+dfsg+really4.12.0-1build1 @ii umU Ib > FU=0
  Installing libjpeg-turbo-progs as Depends of calibre
    MarkInstall libjpeg-turbo-progs:amd64 < none -> 2.0.3-0ubuntu1.20.04.1 @un uN > FU=0
  Installing libjxr-tools as Depends of calibre
    MarkInstall libjxr-tools:amd64 < none -> 1.1-6build1 @un uN Ib > FU=0
    Installing libjxr0 as Depends of libjxr-tools
      MarkInstall libjxr0:amd64 < none -> 1.1-6build1 @un uN > FU=0
  Installing optipng as Depends of calibre
    MarkInstall optipng:amd64 < none -> 0.7.7-1 @un uN > FU=0
  Installing python3-apsw as Depends of calibre
    MarkInstall python3-apsw:amd64 < none -> 3.28.0-r1-1ubuntu4 @un uN > FU=0
  Installing python3-bs4 as Depends of calibre
    MarkInstall python3-bs4:amd64 < none -> 4.8.2-1 @un uN Ib > FU=0
    Installing python3-soupsieve as Depends of python3-bs4
      MarkInstall python3-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN > FU=0
    Installing python3-lxml as Recommends of python3-bs4
      MarkInstall python3-lxml:amd64 < none -> 4.5.0-1 @un uN IPb > FU=0
      Installing python3-html5lib as Recommends of python3-lxml
        MarkInstall python3-html5lib:amd64 < none -> 1.0.1-2 @un uN Ib > FU=0
        Installing python3-webencodings as Depends of python3-html5lib
          MarkInstall python3-webencodings:amd64 < none -> 0.5.1-1ubuntu1 @un uN > FU=0
  Installing python3-chm as Depends of calibre
    MarkInstall python3-chm:amd64 < none -> 0.8.6-2build1 @un uN > FU=0
  Installing python3-css-parser as Depends of calibre
    MarkInstall python3-css-parser:amd64 < none -> 1.0.4-2 @un uN > FU=0
  Installing python3-cssselect as Depends of calibre
    MarkInstall python3-cssselect:amd64 < none -> 1.1.0-2 @un uN > FU=0
  Installing python3-cssutils as Depends of calibre
    MarkInstall python3-cssutils:amd64 < none -> 1.0.2-3 @un uN > FU=0
  Installing python3-feedparser as Depends of calibre
    MarkInstall python3-feedparser:amd64 < none -> 5.2.1-2 @un uN > FU=0
  Installing python3-html2text as Depends of calibre
    MarkInstall python3-html2text:amd64 < none -> 2020.1.16-1 @un uN > FU=0
  Installing python3-html5-parser as Depends of calibre
    MarkInstall python3-html5-parser:amd64 < none -> 0.4.9-3build1 @un uN > FU=0
  Installing python3-mechanize as Depends of calibre
    MarkInstall python3-mechanize:amd64 < none -> 1:0.4.5-2 @un uN > FU=0
  Installing python3-msgpack as Depends of calibre
    MarkInstall python3-msgpack:amd64 < none -> 0.6.2-1 @un uN > FU=0
  Installing python3-pyqt5.qtwebengine as Depends of calibre
    MarkInstall python3-pyqt5.qtwebengine:amd64 < none -> 5.14.0-2build1 @un uN Ib > FU=0
    Installing python3-pyqt5.qtwebchannel as Depends of python3-pyqt5.qtwebengine
      MarkInstall python3-pyqt5.qtwebchannel:amd64 < none -> 5.14.1+dfsg-3build1 @un uN > FU=0
    Installing libqt5webengine5 as Depends of python3-pyqt5.qtwebengine
      MarkInstall libqt5webengine5:amd64 < none -> 5.12.8+dfsg-0ubuntu1.1 @un uN > FU=0
  Installing python3-regex as Depends of calibre
    MarkInstall python3-regex:amd64 < none -> 0.1.20190819-2build1 @un uN > FU=0
  Installing python3-routes as Depends of calibre
    MarkInstall python3-routes:amd64 < none -> 2.4.1-2 @un uN Ib > FU=0
    Installing python3-repoze.lru as Depends of python3-routes
      MarkInstall python3-repoze.lru:amd64 < none -> 0.7-2 @un uN > FU=0
    Installing python3-webob as Recommends of python3-routes
      MarkInstall python3-webob:amd64 < none -> 1:1.8.5-2 @un uN > FU=0
  Installing python3-zeroconf as Depends of calibre
    MarkInstall python3-zeroconf:amd64 < none -> 0.24.4-0ubuntu1 @un uN Ib > FU=0
    Installing python3-ifaddr as Depends of python3-zeroconf
      MarkInstall python3-ifaddr:amd64 < none -> 0.1.6-1 @un uN > FU=0
    Installing python3-nose as Depends of python3-zeroconf
      MarkInstall python3-nose:amd64 < none -> 1.3.7-5 @un uN > FU=0
  MarkInstall synaptic:amd64 < 0.84.3ubuntu1 -> 0.84.6ubuntu5 @ii umU Ib > FU=0
  Installing libept1.6.0 as Depends of synaptic
    MarkInstall libept1.6.0:amd64 < none -> 1.1+nmu3ubuntu3 @un uN > FU=0
    MarkKeep fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mR > FU=0
  MarkInstall kodi-bin:amd64 < 2:17.6+dfsg1-1ubuntu1 -> 2:18.6+dfsg1-2ubuntu1 @ii umU Ib > FU=0
  Installing kodi-x11 as Depends of kodi-bin
    MarkInstall kodi-x11:amd64 < none -> 2:18.6+dfsg1-2ubuntu1 @un uN Ib > FU=0
    Installing libfstrcmp0 as Depends of kodi-x11
      MarkInstall libfstrcmp0:amd64 < none -> 0.7.D001-1.1build1 @un uN > FU=0
  MarkInstall kodi-data:amd64 < 2:17.6+dfsg1-1ubuntu1 -> 2:18.6+dfsg1-2ubuntu1 @ii umU Ib > FU=0
  Installing python-pycryptodome as Depends of kodi-data
    MarkInstall python-pycryptodome:amd64 < none -> 3.6.1-2build4 @un uN > FU=0
    MarkKeep vala-panel-appmenu-registrar:amd64 < 0.6.94+repack1-1 @ii mR NPb > FU=0
  MarkInstall isc-dhcp-client:amd64 < 4.3.5-3ubuntu7.1 -> 4.4.1-2.1ubuntu5 @ii umU Ib > FU=0
  Installing libdns-export1109 as Depends of isc-dhcp-client
    MarkInstall libdns-export1109:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN Ib > FU=0
    Installing libisc-export1105 as Depends of libdns-export1109
      MarkInstall libisc-export1105:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN > FU=0
  MarkInstall libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall cryptsetup:amd64 < 2:2.0.2-1ubuntu1.1 -> 2:2.2.2-3ubuntu2.2 @ii umU IPb > FU=0
  new important dependency: cryptsetup-initramfs:amd64
  Installing cryptsetup-initramfs as Recommends of cryptsetup
    MarkInstall cryptsetup-initramfs:amd64 < none -> 2:2.2.2-3ubuntu2.2 @un uN > FU=0
  new important dependency: cryptsetup-run:amd64
  Installing cryptsetup-run as Recommends of cryptsetup
    MarkInstall cryptsetup-run:amd64 < none -> 2:2.2.2-3ubuntu2.2 @un uN > FU=0
    MarkKeep libsensors4:i386 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall python-pip:amd64 < 9.0.1-2.3~ubuntu1.18.04.3 @ii mK Ib > FU=0
  MarkInstall initramfs-tools-core:amd64 < 0.130ubuntu3.11 -> 0.136ubuntu6.3 @ii umU Ib > FU=0
  Installing lz4 as Depends of initramfs-tools-core
    MarkInstall lz4:amd64 < none -> 1.9.2-2 @un uN > FU=0
  MarkInstall python-markdown:amd64 < 2.6.9-1 -> 3.1.1-3 @ii umU Ib > FU=0
  Installing python-packaging as Depends of python-markdown
    MarkInstall python-packaging:amd64 < none -> 20.3-1 @un uN > FU=0
  MarkInstall tenace:amd64 < 0.15-1 -> 0.16-2 @ii umU Ib > FU=0
  Installing libdds0 as Depends of tenace
    MarkInstall libdds0:amd64 < none -> 2.9.0-7ubuntu1 @un uN > FU=0
  MarkInstall wireshark-qt:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on libqt5multimedia5-plugins:amd64
  MarkInstall python-all-dev:amd64 < 2.7.15~rc1-1 -> 2.7.17-2ubuntu4 @ii ugU Ib > FU=0
  Installing python2-dev as Depends of python-all-dev
    MarkInstall python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
     Removing: python-dev
      MarkDelete python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > FU=0
  MarkInstall libvirt-daemon:amd64 < 4.0.0-1ubuntu8.17 -> 6.0.0-0ubuntu8.4 @ii umU Ib > FU=0
  Installing libvirt-daemon-driver-qemu as Depends of libvirt-daemon
    MarkInstall libvirt-daemon-driver-qemu:amd64 < none -> 6.0.0-0ubuntu8.4 @un uN > FU=0
    MarkKeep libfwup1:amd64 < 12-3bionic2 @ii mR > FU=0
    MarkKeep gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mR > FU=0
    MarkKeep libmarco-private1:amd64 < 1.20.1-2ubuntu1 @ii mR > FU=0
    MarkKeep python-mate-menu:amd64 < 1.20.0-2 @ii mR > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
    MarkKeep python-dev:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
Starting pkgProblemResolver with broken count: 41
Starting 2 pkgProblemResolver with broken count: 41
Investigating (0) dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib >
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mK > (< 1.7~b)
  Considering libapt-pkg5.0:amd64 -1 as a solution to dpkg:amd64 5908
  Added libapt-pkg5.0:amd64 to the remove list
  Fixing dpkg:amd64 via remove of libapt-pkg5.0:amd64
  MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mK > FU=0
Investigating (0) libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib >
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
  Considering libqtcore4:amd64 19 as a solution to libqt5core5a:amd64 1441
  Added libqtcore4:amd64 to the remove list
  Fixing libqt5core5a:amd64 via remove of libqtcore4:amd64
  MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
Investigating (0) libuno-sal3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib >
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
  Considering uno-libs3:amd64 -8 as a solution to libuno-sal3:amd64 105
  Added uno-libs3:amd64 to the remove list
  Fixing libuno-sal3:amd64 via remove of uno-libs3:amd64
  MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
Investigating (0) libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib >
Broken libgcc1:amd64 Conflicts on libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib >
  Considering libgcc1:i386 3 as a solution to libgcc1:amd64 87
  Added libgcc1:i386 to the remove list
  Conflicts//Breaks against version 1:8.4.0-1ubuntu1~18.04 for libgcc1 but that is not InstVer, ignoring
  Fixing libgcc1:amd64 via remove of libgcc1:i386
  MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10-20200411-0ubuntu1 @ii umU Ib > FU=0
Investigating (0) python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken python2-minimal:amd64 Breaks on python-minimal:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering python-minimal:amd64 -3 as a solution to python2-minimal:amd64 54
  Added python-minimal:amd64 to the remove list
  Fixing python2-minimal:amd64 via remove of python-minimal:amd64
  MarkDelete python-minimal:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
Investigating (0) libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken libpython2-stdlib:amd64 Breaks on libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering libpython-stdlib:amd64 -3 as a solution to libpython2-stdlib:amd64 54
  Added libpython-stdlib:amd64 to the remove list
  Fixing libpython2-stdlib:amd64 via remove of libpython-stdlib:amd64
  MarkDelete libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
Investigating (0) libmate-menu2:amd64 < 1.20.0-2 -> 1.24.0-1 @ii umU Ib >
Broken libmate-menu2:amd64 Breaks on python-mate-menu:amd64 < 1.20.0-2 @ii mK > (< 1.22.0)
  Considering python-mate-menu:amd64 -3 as a solution to libmate-menu2:amd64 25
  Added python-mate-menu:amd64 to the remove list
  Fixing libmate-menu2:amd64 via remove of python-mate-menu:amd64
  MarkDelete python-mate-menu:amd64 < 1.20.0-2 @ii mK > FU=0
Investigating (0) libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
  Considering libldb1:amd64 -1 as a solution to libldb2:amd64 17
  Added libldb1:amd64 to the remove list
  Fixing libldb2:amd64 via remove of libldb1:amd64
  MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
Investigating (0) python3-caja:amd64 < none -> 1.24.0-2 @un uN Ib >
Broken python3-caja:amd64 Breaks on python-caja:amd64 < 1.20.0-1 @ii mK Ib > (< 1.23~)
  Considering python-caja:amd64 -3 as a solution to python3-caja:amd64 10
  Added python-caja:amd64 to the remove list
  Fixing python3-caja:amd64 via remove of python-caja:amd64
  MarkDelete python-caja:amd64 < 1.20.0-1 @ii mK Ib > FU=0
Investigating (0) libmarco-private2:amd64 < none -> 1.24.0-1ubuntu1 @un uN Ib >
Broken libmarco-private2:amd64 Breaks on libmarco:amd64 < none @un H >
  Considering libmarco-private1:amd64 -3 as a solution to libmarco-private2:amd64 7
  Added libmarco-private1:amd64 to the remove list
Broken libmarco-private2:amd64 Breaks on libmarco-private1:amd64 < 1.20.1-2ubuntu1 @ii mK >
  Considering libmarco-private1:amd64 -3 as a solution to libmarco-private2:amd64 7
  Added libmarco-private1:amd64 to the remove list
  Fixing libmarco-private2:amd64 via remove of libmarco-private1:amd64
  MarkDelete libmarco-private1:amd64 < 1.20.1-2ubuntu1 @ii mK > FU=0
  Fixing libmarco-private2:amd64 via remove of libmarco-private1:amd64
Investigating (0) gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
  Considering gnome-settings-daemon-schemas:amd64 -3 as a solution to gnome-settings-daemon-common:amd64 5
  Added gnome-settings-daemon-schemas:amd64 to the remove list
  Fixing gnome-settings-daemon-common:amd64 via remove of gnome-settings-daemon-schemas:amd64
  MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
Investigating (0) libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqtdbus4:amd64 5
  Removing libqtdbus4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 -2 as a solution to libsensors-config:amd64 4
  Added libsensors4:amd64 to the remove list
Broken libsensors-config:amd64 Conflicts on libsensors4:i386 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:i386 -3 as a solution to libsensors-config:amd64 4
  Added libsensors4:i386 to the remove list
  Fixing libsensors-config:amd64 via remove of libsensors4:amd64
  MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
  Fixing libsensors-config:amd64 via remove of libsensors4:i386
  MarkDelete libsensors4:i386 < 1:3.4.0-4 @ii mK > FU=0
Investigating (0) libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtgui4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqtgui4:amd64 4
  Removing libqtgui4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) appmenu-registrar:amd64 < none -> 0.7.3-2 @un uN Ib >
Broken appmenu-registrar:amd64 Breaks on vala-panel-appmenu-registrar:amd64 < 0.6.94+repack1-1 @ii mK NPb Ib > (< 0.7.1)
  Considering vala-panel-appmenu-registrar:amd64 -3 as a solution to appmenu-registrar:amd64 3
  Added vala-panel-appmenu-registrar:amd64 to the remove list
  Fixing appmenu-registrar:amd64 via remove of vala-panel-appmenu-registrar:amd64
  MarkDelete vala-panel-appmenu-registrar:amd64 < 0.6.94+repack1-1 @ii mK NPb Ib > FU=0
Investigating (0) libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqt4-declarative:amd64 3
  Removing libqt4-declarative:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib >
Broken qt-at-spi:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8~)
  Considering libqtcore4:amd64 19 as a solution to qt-at-spi:amd64 3
  Removing qt-at-spi:amd64 rather than change libqtcore4:amd64
  MarkDelete qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib > FU=0
Investigating (0) libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib >
Broken libpython2-dev:amd64 Breaks on libpython-dev:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering libpython-dev:amd64 -2 as a solution to libpython2-dev:amd64 2
  Added libpython-dev:amd64 to the remove list
  Fixing libpython2-dev:amd64 via remove of libpython-dev:amd64
  MarkDelete libpython-dev:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
Investigating (0) libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqt4-xml:amd64 2
  Removing libqt4-xml:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtdbus4:amd64 5 as a solution to libqt4-dbus:amd64 2
  Removing libqt4-dbus:amd64 rather than change libqtdbus4:amd64
  MarkDelete libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqt4-network:amd64 1
  Removing libqt4-network:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libmailutils6:amd64 < none -> 1:3.7-2.1 @un uN Ib >
Broken libmailutils6:amd64 Conflicts on libmailutils5:amd64 < 1:3.4-1 @ii mK Ib >
  Considering libmailutils5:amd64 -3 as a solution to libmailutils6:amd64 1
  Added libmailutils5:amd64 to the remove list
  Fixing libmailutils6:amd64 via remove of libmailutils5:amd64
  MarkDelete libmailutils5:amd64 < 1:3.4-1 @ii mK Ib > FU=0
Investigating (0) qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 2 as a solution to qdbus:amd64 1
  Removing qdbus:amd64 rather than change libqt4-xml:amd64
  MarkDelete qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib >
Broken python-keyring:amd64 Breaks on python-keyrings.alt:amd64 < 3.0-1 @ii mK > (< 3.1)
  Considering python-keyrings.alt:amd64 -2 as a solution to python-keyring:amd64 1
  Added python-keyrings.alt:amd64 to the remove list
  Fixing python-keyring:amd64 via remove of python-keyrings.alt:amd64
  MarkDelete python-keyrings.alt:amd64 < 3.0-1 @ii mK > FU=0
Investigating (0) python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib >
Broken python2-dev:amd64 Breaks on python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > (< 2.7.15-2)
  Considering python-dev:amd64 -3 as a solution to python2-dev:amd64 1
  Added python-dev:amd64 to the remove list
  Fixing python2-dev:amd64 via remove of python-dev:amd64
  MarkDelete python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > FU=0
Investigating (0) libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
  Considering libhfstospell9:amd64 -2 as a solution to libhfstospell10:amd64 1
  Added libhfstospell9:amd64 to the remove list
  Fixing libhfstospell10:amd64 via remove of libhfstospell9:amd64
  MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
Investigating (0) libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqt4-sql:amd64 0
  Removing libqt4-sql:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib >
Broken appmenu-qt:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8)
  Considering libqt4-dbus:amd64 2 as a solution to appmenu-qt:amd64 0
  Removing appmenu-qt:amd64 rather than change libqt4-dbus:amd64
  MarkDelete appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib > FU=0
Investigating (0) python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1441 as a solution to python-pyqt5:amd64 0
  Removing python-pyqt5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib >
Broken libdbusmenu-qt2:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.6.2)
  Considering libqt4-dbus:amd64 2 as a solution to libdbusmenu-qt2:amd64 0
  Removing libdbusmenu-qt2:amd64 rather than change libqt4-dbus:amd64
  MarkDelete libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib > FU=0
Investigating (0) fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
  Considering fwupdate-signed:amd64 -3 as a solution to fwupdate:amd64 0
  Added fwupdate-signed:amd64 to the remove list
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
  Considering libfwup1:amd64 -3 as a solution to fwupdate:amd64 0
  Added libfwup1:amd64 to the remove list
  Fixing fwupdate:amd64 via remove of fwupdate-signed:amd64
  MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
  Fixing fwupdate:amd64 via remove of libfwup1:amd64
  MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
Investigating (0) python-ldb:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK Ib >
Broken python-ldb:amd64 Depends on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > (= 2:1.2.3-1ubuntu0.1)
  Considering libldb1:amd64 -1 as a solution to python-ldb:amd64 -1
  Removing python-ldb:amd64 rather than change libldb1:amd64
  MarkDelete python-ldb:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK Ib > FU=0
Investigating (0) libqt4-sql-mysql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql-mysql:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-sql:amd64 0 as a solution to libqt4-sql-mysql:amd64 -1
  Removing libqt4-sql-mysql:amd64 rather than change libqt4-sql:amd64
  MarkDelete libqt4-sql-mysql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-tdb:amd64 < 1.3.15-2 @ii mK Ib >
Broken python-tdb:amd64 Depends on libtdb1:amd64 < 1.3.15-2 -> 1.4.2-3build1 @ii umU > (= 1.3.15-2)
  Considering libtdb1:amd64 64 as a solution to python-tdb:amd64 -1
  Removing python-tdb:amd64 rather than change libtdb1:amd64
  MarkDelete python-tdb:amd64 < 1.3.15-2 @ii mK Ib > FU=0
Investigating (0) libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-script:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 19 as a solution to libqt4-script:amd64 -1
  Removing libqt4-script:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xmlpatterns:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 1 as a solution to libqt4-xmlpatterns:amd64 -1
  Removing libqt4-xmlpatterns:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 476 as a solution to libcupsppdc1:amd64 -2
  Removing libcupsppdc1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib >
Broken libpango1.0-0:amd64 Depends on libpango-1.0-0:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU > (= 1.40.14-1ubuntu0.1)
  Considering libpango-1.0-0:amd64 1002 as a solution to libpango1.0-0:amd64 -2
  Removing libpango1.0-0:amd64 rather than change libpango-1.0-0:amd64
  MarkDelete libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
Investigating (0) libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib >
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii mR > (>= 1:3.0.0)
  Considering libsensors4:amd64 -2 as a solution to libsnmp30:amd64 -2
  Removing libsnmp30:amd64 rather than change libsensors4:amd64
  MarkDelete libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
Investigating (0) libpeas-1.0-python2loader:amd64 < 1.22.0-2 @ii mK Ib >
Broken libpeas-1.0-python2loader:amd64 Depends on libpeas-1.0-0:amd64 < 1.22.0-2 -> 1.26.0-2 @ii umU > (= 1.22.0-2)
  Considering libpeas-1.0-0:amd64 23 as a solution to libpeas-1.0-python2loader:amd64 -2
  Removing libpeas-1.0-python2loader:amd64 rather than change libpeas-1.0-0:amd64
  MarkDelete libpeas-1.0-python2loader:amd64 < 1.22.0-2 @ii mK Ib > FU=0
Investigating (0) python-pyqt5.qtwebkit:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtwebkit:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 0 as a solution to python-pyqt5.qtwebkit:amd64 -2
  Removing python-pyqt5.qtwebkit:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtwebkit:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib >
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
  Considering libpolkit-gobject-1-0:amd64 158 as a solution to libpolkit-backend-1-0:amd64 -2
  Removing libpolkit-backend-1-0:amd64 rather than change libpolkit-gobject-1-0:amd64
  MarkDelete libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
Investigating (0) xfce4-quicklauncher-plugin:amd64 < 1.9.4-11build1 @ii mK Ib >
Broken xfce4-quicklauncher-plugin:amd64 Depends on xfce4-panel:amd64 < 4.12.2-1ubuntu1 -> 4.14.3-1 @ii umU > (< 4.13)
  Considering xfce4-panel:amd64 16 as a solution to xfce4-quicklauncher-plugin:amd64 -2
  Removing xfce4-quicklauncher-plugin:amd64 rather than change xfce4-panel:amd64
  MarkDelete xfce4-quicklauncher-plugin:amd64 < 1.9.4-11build1 @ii mK Ib > FU=0
Investigating (0) python-pip:amd64 < 9.0.1-2.3~ubuntu1.18.04.3 @ii mK Ib >
Broken python-pip:amd64 Depends on python-pip-whl:amd64 < 9.0.1-2.3~ubuntu1.18.04.3 -> 20.0.2-5ubuntu1.1 @ii umU > (= 9.0.1-2.3~ubuntu1.18.04.3)
  Considering python-pip-whl:amd64 1 as a solution to python-pip:amd64 -2
  Removing python-pip:amd64 rather than change python-pip-whl:amd64
  MarkDelete python-pip:amd64 < 9.0.1-2.3~ubuntu1.18.04.3 @ii mK Ib > FU=0
Investigating (0) python-samba:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.20 @ii mK Ib >
Broken python-samba:amd64 Depends on python-ldb:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > (>= 1.1.2~)
  Considering python-ldb:amd64 -1 as a solution to python-samba:amd64 -2
  Removing python-samba:amd64 rather than change python-ldb:amd64
  MarkDelete python-samba:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.20 @ii mK Ib > FU=0
Investigating (0) python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtsvg:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 0 as a solution to python-pyqt5.qtsvg:amd64 -2
  Removing python-pyqt5.qtsvg:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) holdingnuts:amd64 < 0.0.5-4 @ii mK Ib >
Broken holdingnuts:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.5.3)
  Considering libqt4-network:amd64 1 as a solution to holdingnuts:amd64 -2
  Removing holdingnuts:amd64 rather than change libqt4-network:amd64
  MarkDelete holdingnuts:amd64 < 0.0.5-4 @ii mK Ib > FU=0
Investigating (0) libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 476 as a solution to libcupscgi1:amd64 -2
  Removing libcupscgi1:amd64 rather than change libcups2:amd64
  MarkDelete libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib >
Broken sni-qt:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.3-1ubuntu3~)
  Considering libqtcore4:amd64 19 as a solution to sni-qt:amd64 -2
  Removing sni-qt:amd64 rather than change libqtcore4:amd64
  MarkDelete sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libapt-inst2.0:amd64 < 1.6.12ubuntu0.1 @ii mK Ib >
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libapt-inst2.0:amd64 -2
  Removing libapt-inst2.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libapt-inst2.0:amd64 < 1.6.12ubuntu0.1 @ii mK Ib > FU=0
Investigating (0) libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 476 as a solution to libcupsmime1:amd64 -2
  Removing libcupsmime1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib >
Broken libept1.5.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libept1.5.0:amd64 -2
  Removing libept1.5.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
Done
  MarkDelete lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 -> 2.0.6-0ubuntu1 @ii umU > FU=1
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 10003 as a solution to xubuntu-default-settings:amd64 3
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
    Reinst Failed because of protected lightdm-gtk-greeter:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (0) lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib >
Broken lightdm-gtk-greeter-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10003 as a solution to lightdm-gtk-greeter-settings:amd64 1
  MarkKeep lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib > FU=0
    Reinst Failed because of protected lightdm-gtk-greeter:amd64
  MarkKeep lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib > FU=0
  Removing lightdm-gtk-greeter-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 | 1.2.2-3 @ii umH Ib > FU=0
Investigating (0) xubuntu-core:amd64 < 2.225 -> 2.233 @ii umU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10003 as a solution to xubuntu-core:amd64 1
  MarkKeep xubuntu-core:amd64 < 2.225 -> 2.233 @ii umU Ib > FU=0
    Reinst Failed because of protected lightdm-gtk-greeter:amd64
  MarkKeep xubuntu-core:amd64 < 2.225 -> 2.233 @ii umU Ib > FU=0
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Setting alsa-base:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting alsa-utils:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting anacron:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bc:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ca-certificates:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting dmz-cursor-theme:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting doc-base:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-dejavu-core:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-freefont-ttf:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting foomatic-db-compressed-ppds:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting genisoimage:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ghostscript-x:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gtk2-engines-pixbuf:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting inputattach:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libasound2-plugins:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libsasl2-modules:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libu2f-udev:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting lightdm:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting lightdm-gtk-greeter:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting openprinting-ppds:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pnm2ppa:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting rfkill:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting spice-vdagent:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar-volman:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-drivers-common:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting unzip:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wireless-tools:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wpasupplicant:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs-gtk:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-utils:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-appfinder:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-notifyd:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-panel:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-session:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-settings:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfdesktop4:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfwm4:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xkb-data:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xorg:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xterm:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-artwork:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-default-settings:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting zip:amd64 NOT as auto-installed (direct Depends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting acpi-support:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-autoipd:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-daemon:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez-cups:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-bsd:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-client:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-filters:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-indic:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-kacst-one:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-khmeros-core:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lao:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-liberation:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lklug-sinhala:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-cjk:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-hinted:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-opensymbol:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-abyssinica:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-padauk:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-symbola:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-thai-tlwg:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-tibetan-machine:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-ubuntu:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupd:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate-signed:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gucharmap:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting hplip:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting kerneloops:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting laptop-detect:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnotify-bin:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnss-mdns:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libpam-gnome-keyring:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting light-locker:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting memtest86+:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-gnome:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting numlockx:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting packagekit:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pavucontrol:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pcmciautils:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pinentry-gtk2:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting policykit-desktop-privileges:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-brlaser:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-c2esp:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-foo2zjs:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-m2300w:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-min12xxw:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-ptouch:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pxljr:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-sag-gdi:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-splix:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting snapd:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting software-properties-gtk:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-indicator-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-power-manager:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-pulseaudio-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-screenshooter:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-statusnotifier-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-terminal:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-whiskermenu-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xserver-xorg-input-all:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xserver-xorg-input-synaptics:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-docs:amd64 NOT as auto-installed (direct Recommends of xubuntu-core:amd64 which is in APT::Never-MarkAuto-Sections)
  MarkDelete xubuntu-core:amd64 < 2.225 | 2.233 @ii umH Ib > FU=0
Investigating (0) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii umU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10003 as a solution to xubuntu-desktop:amd64 0
  MarkKeep xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii umU Ib > FU=0
    Reinst Failed because of protected lightdm-gtk-greeter:amd64
  MarkKeep xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii umU Ib > FU=0
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Setting alsa-base:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting alsa-utils:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting anacron:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bc:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ca-certificates:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting dmz-cursor-theme:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting doc-base:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-dejavu-core:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-freefont-ttf:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting foomatic-db-compressed-ppds:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting genisoimage:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ghostscript-x:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gtk2-engines-pixbuf:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting inputattach:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting language-selector-gnome:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libasound2-plugins:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libsasl2-modules:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libu2f-udev:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting lightdm:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting lightdm-gtk-greeter:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting openprinting-ppds:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pnm2ppa:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting rfkill:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting spice-vdagent:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar-volman:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting tumbler:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-drivers-common:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting unzip:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting update-manager:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wireless-tools:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wpasupplicant:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs-gtk:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-utils:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-appfinder:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-notifyd:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-panel:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-session:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-settings:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfdesktop4:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfwm4:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xkb-data:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xorg:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xterm:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-artwork:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-core:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-default-settings:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting zenity:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting zip:amd64 NOT as auto-installed (direct Depends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting acpi-support:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting apport-gtk:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting apt-offline:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting atril:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-autoipd:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-daemon:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting blueman:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez-cups:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting brltty:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting brltty-x11:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting catfish:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-bsd:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-client:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-filters:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting desktop-file-utils:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting engrampa:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting espeak:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting firefox:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-indic:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-kacst-one:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-khmeros-core:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lao:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-liberation:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lklug-sinhala:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-cjk:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-hinted:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-opensymbol:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-abyssinica:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-padauk:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-symbola:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-thai-tlwg:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-tibetan-machine:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-ubuntu:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupd:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate-signed:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gigolo:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-accessibility-themes:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-font-viewer:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-mines:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-software:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-sudoku:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-system-tools:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting greybird-gtk-theme:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gstreamer1.0-pulseaudio:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gucharmap:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gvfs-backends:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gvfs-fuse:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting hplip:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting im-config:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting indicator-messages:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting inxi:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting kerneloops:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting laptop-detect:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnotify-bin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnss-mdns:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libpam-gnome-keyring:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-calc:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-gnome:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-style-elementary:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-writer:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libxfce4ui-utils:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting light-locker:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting lightdm-gtk-greeter-settings:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting mate-calc:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting memtest86+:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting menulibre:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting mousepad:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting mugshot:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-gnome:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-pptp:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-pptp-gnome:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting numix-gtk-theme:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting numlockx:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting onboard:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting orage:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting packagekit:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting parole:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pastebinit:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pavucontrol:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pcmciautils:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pidgin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pidgin-otr:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pinentry-gtk2:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting policykit-desktop-privileges:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-brlaser:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-c2esp:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-foo2zjs:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-m2300w:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-min12xxw:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-ptouch:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pxljr:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-sag-gdi:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-splix:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ristretto:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting sgt-launcher:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting simple-scan:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting snapd:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting software-properties-gtk:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting speech-dispatcher:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting system-config-printer:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar-archive-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunar-media-tags-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunderbird:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting transmission-gtk:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting update-notifier:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting whoopsie:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xcursor-themes:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfburn:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-cpugraph-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-dict:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-indicator-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-mailwatch-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-netload-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-notes-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-places-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-power-manager:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-pulseaudio-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-quicklauncher-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-screenshooter:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-statusnotifier-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-systemload-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-taskmanager:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-terminal:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-verve-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-weather-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-whiskermenu-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfce4-xkb-plugin:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xfpanel-switch:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xserver-xorg-input-all:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xserver-xorg-input-synaptics:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-community-wallpapers:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xubuntu-docs:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xul-ext-ubufox:amd64 NOT as auto-installed (direct Recommends of xubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  MarkDelete xubuntu-desktop:amd64 < 2.225 | 2.233 @ii umH Ib > FU=0
Done
  MarkInstall xubuntu-core:amd64 < 2.225 -> 2.233 @ii ugU Ib > FU=1
  Installing lightdm-gtk-greeter as Depends of xubuntu-core
    Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Installing xubuntu-default-settings as Depends of xubuntu-core
    MarkInstall xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii ugU Ib > FU=0
    Installing lightdm-gtk-greeter as Depends of xubuntu-default-settings
      Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 1 as a solution to xubuntu-core:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
  Fixing xubuntu-core:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
Investigating (0) xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 1 as a solution to xubuntu-default-settings:amd64 1
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
  Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (1) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 1 as a solution to xubuntu-core:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
Broken xubuntu-core:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 1 as a solution to xubuntu-core:amd64 10000
  Added xubuntu-default-settings:amd64 to the remove list
  Fixing xubuntu-core:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Fixing xubuntu-core:amd64 via keep of xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR > FU=0
 Try to Re-Instate (1) xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
Investigating (1) xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 1 as a solution to xubuntu-default-settings:amd64 1
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (2) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 1 as a solution to xubuntu-core:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
Broken xubuntu-core:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 1 as a solution to xubuntu-core:amd64 10000
  Added xubuntu-default-settings:amd64 to the remove list
  Fixing xubuntu-core:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Fixing xubuntu-core:amd64 via keep of xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR > FU=0
Investigating (2) xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-default-settings:amd64 10000
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (3) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
Broken xubuntu-core:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-core:amd64 10000
Done
  MarkInstall xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii ugU Ib > FU=1
  Installing lightdm-gtk-greeter as Depends of xubuntu-desktop
    Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Installing xubuntu-default-settings as Depends of xubuntu-desktop
    MarkInstall xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii ugU Ib > FU=0
    Installing lightdm-gtk-greeter as Depends of xubuntu-default-settings
      Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  previously satisfied important dependency on lightdm-gtk-greeter-settings:amd64
  Installing lightdm-gtk-greeter-settings as Recommends of xubuntu-desktop
    MarkInstall lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii ugU Ib > FU=0
    Installing lightdm-gtk-greeter as Depends of lightdm-gtk-greeter-settings
      Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-desktop:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
  Fixing xubuntu-desktop:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
Investigating (0) xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-default-settings:amd64 3
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
  Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (0) lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib >
Broken lightdm-gtk-greeter-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to lightdm-gtk-greeter-settings:amd64 1
  MarkKeep lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib > FU=0
    Reinst Failed because of lightdm-gtk-greeter:amd64
  MarkKeep lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 -> 1.2.2-3 @ii umU Ib > FU=0
  Removing lightdm-gtk-greeter-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete lightdm-gtk-greeter-settings:amd64 < 1.2.2-1 | 1.2.2-3 @ii umH Ib > FU=0
Investigating (0) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (1) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-desktop:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 3 as a solution to xubuntu-desktop:amd64 10000
  Added xubuntu-default-settings:amd64 to the remove list
  Fixing xubuntu-desktop:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Fixing xubuntu-desktop:amd64 via keep of xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR > FU=0
 Try to Re-Instate (1) xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 -> 20.04.4 @ii umU Ib > FU=0
Investigating (1) xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-default-settings:amd64 3
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (1) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (2) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 3 as a solution to xubuntu-desktop:amd64 10000
  Added lightdm-gtk-greeter:amd64 to the remove list
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 3 as a solution to xubuntu-desktop:amd64 10000
  Added xubuntu-default-settings:amd64 to the remove list
  Fixing xubuntu-desktop:amd64 via keep of lightdm-gtk-greeter:amd64
  Ignore MarkKeep of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
  Fixing xubuntu-desktop:amd64 via keep of xubuntu-default-settings:amd64
  MarkKeep xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR > FU=0
Investigating (2) xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib >
Broken xubuntu-default-settings:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > (>= 2.0.1-1)
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-default-settings:amd64 10000
  Removing xubuntu-default-settings:amd64 rather than change lightdm-gtk-greeter:amd64
  MarkDelete xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umH Ib > FU=0
Investigating (2) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (3) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (3) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (4) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (4) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (5) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (5) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (6) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (6) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (7) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (7) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (8) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (8) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (9) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Broken xubuntu-desktop:amd64 Depends on xubuntu-default-settings:amd64 < 18.04.6 | 20.04.4 @ii umR >
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
  Considering xubuntu-default-settings:amd64 10000 as a solution to xubuntu-desktop:amd64 10000
Investigating (9) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 10000 as a solution to xubuntu-core:amd64 10000
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Done
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (0) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (1) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (1) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (2) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (2) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (3) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (3) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (4) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (4) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (5) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (5) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (6) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (6) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (7) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (7) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (8) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (8) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (9) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (9) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Done
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Ignore MarkInstall of lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR > as its mode (Delete) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (0) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
    Reinst Failed because of lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (1) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (1) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (2) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 1
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (2) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 0
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (3) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (3) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (4) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (4) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (5) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (5) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (6) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (6) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (7) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (7) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (8) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (8) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (9) xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-core:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-core:amd64 2
  Ignore MarkKeep of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-core:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-core:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Investigating (9) xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib >
Broken xubuntu-desktop:amd64 Depends on lightdm-gtk-greeter:amd64 < 2.0.5-0ubuntu1 | 2.0.6-0ubuntu1 @ii pugR >
  Considering lightdm-gtk-greeter:amd64 2 as a solution to xubuntu-desktop:amd64 2
  Ignore MarkKeep of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
  Removing xubuntu-desktop:amd64 rather than change lightdm-gtk-greeter:amd64
  Ignore MarkDelete of xubuntu-desktop:amd64 < 2.225 -> 2.233 @ii pumU Ib > as its mode (Install) is protected
Done
Log time: 2020-10-06 20:35:53.903277

if you run:

sudo apt --reinstall install ubuntu-mate-core

Does it reinstall OK?

Manfred Hampl (m-hampl) said : #5

A possible cause for your problem:

You have xubuntu-desktop and ubuntu-mate-desktop installed. Both of these meta-packages have lots of dependencies (that is their purpose), adding to potential conflicts between the dependent packages.

My suggestion: remove one of them, try the release upgrade (which will then hopefully work) and install the new meta-package again after the release upgrade.

bgarnham (bgarnham) said : #6

Thanks again. I really appreciate the help.

I wasn't sure if it was necessary but logged in using Xubuntu and ran the following as per actionparsnip with no issues.

$ sudo apt --reinstall install ubuntu-mate-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 3,740 B of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ca.archive.ubuntu.com/ubuntu bionic/universe amd64 ubuntu-mate-core amd64 1.225 [3,740 B]
Fetched 3,740 B in 1s (2,997 B/s)
(Reading database ... 334175 files and directories currently installed.)
Preparing to unpack .../ubuntu-mate-core_1.225_amd64.deb ...
Unpacking ubuntu-mate-core (1.225) over (1.225) ...
Setting up ubuntu-mate-core (1.225) ...

I logged back in using Mate (my go to) and just to see what happens, I ran the update gui via 'software updater' which gave the same error in /var/log/dist-upgrade/main.log relating to ubuntu-mate-core:

2020-10-08 20:46:33,314 DEBUG Marking 'ubuntu-mate-core' for upgrade
2020-10-08 20:46:33,482 WARNING Can't mark 'ubuntu-mate-core' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)

Still logged in using Mate, as per Manfred Hampl, I ran the following:

$ sudo apt remove xubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  xubuntu-desktop
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 29.7 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 334174 files and directories currently installed.)
Removing xubuntu-desktop (2.225) ...

I then ran the update gui via 'software updater' which, unfortunately, still failed.

Below is the actual error message that pops up, in case it might be useful.
I don't think the suggested problem is an issue in this case.
I have google earth and geogebra installed from third party sources but I don't think that's what this is referring to as the third party sources are disabled with the default update settings. Does that make sense?
__________________
Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

 This was likely caused by:
 * Unofficial software packages not provided by Ubuntu
Please use the tool 'ppa-purge' from the ppa-purge
package to remove software from a Launchpad PPA and
try the upgrade again.

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log'
_____________________

/var/log/dist-upgrade/main.log still shows errors relating to xubuntu-core (as does /var/log/dist-upgrade/apt.log) but, of course, not xubuntu-desktop.

2020-10-08 20:59:58,662 DEBUG Marking 'xubuntu-core' for upgrade
2020-10-08 20:59:58,815 WARNING Can't mark 'xubuntu-core' for upgrade (E:Unable to correct problems, you have held broken packages.)

I've just left xubuntu-desktop uninstalled for the time being.

I'm including the complete /var/log/dist-upgrade/main.log in case it is useful.

2020-10-08 20:58:42,710 INFO Using config files '['./DistUpgrade.cfg.bionic']'
2020-10-08 20:58:42,711 INFO uname information: 'Linux envy 4.15.0-118-generic #119-Ubuntu SMP Tue Sep 8 12:30:01 UTC 2020 x86_64'
2020-10-08 20:58:43,122 INFO apt version: '1.6.12ubuntu0.1'
2020-10-08 20:58:43,122 INFO python version: '3.6.9 (default, Jul 17 2020, 12:50:27)
[GCC 8.4.0]'
2020-10-08 20:58:43,125 INFO release-upgrader version '20.04.25' started
2020-10-08 20:58:43,178 INFO locale: 'en_CA' 'UTF-8'
2020-10-08 20:58:43,417 DEBUG Using 'DistUpgradeViewGtk3' view
2020-10-08 20:58:43,454 DEBUG enable dpkg --force-overwrite
2020-10-08 20:58:43,467 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2020-10-08 20:58:48,016 DEBUG lsb-release: 'bionic'
2020-10-08 20:58:48,017 DEBUG _pythonSymlinkCheck run
2020-10-08 20:58:48,017 DEBUG openCache()
2020-10-08 20:58:48,017 DEBUG quirks: running PreCacheOpen
2020-10-08 20:58:48,017 DEBUG running Quirks.PreCacheOpen
2020-10-08 20:58:48,903 DEBUG Comparing 4.15.0-117 with
2020-10-08 20:58:48,903 DEBUG Comparing 4.15.0-118 with 4.15.0-117
2020-10-08 20:58:49,107 DEBUG /openCache(), new cache size 99760
2020-10-08 20:58:49,108 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'xubuntu-core')
2020-10-08 20:58:49,108 DEBUG checkViewDepends()
2020-10-08 20:58:49,111 DEBUG running doUpdate() (showErrors=False)
2020-10-08 20:58:52,232 DEBUG openCache()
2020-10-08 20:58:53,270 DEBUG Comparing 4.15.0-117 with
2020-10-08 20:58:53,270 DEBUG Comparing 4.15.0-118 with 4.15.0-117
2020-10-08 20:58:53,494 DEBUG /openCache(), new cache size 99760
2020-10-08 20:58:53,495 DEBUG doPostInitialUpdate
2020-10-08 20:58:53,495 DEBUG quirks: running focalPostInitialUpdate
2020-10-08 20:58:53,495 DEBUG running Quirks.focalPostInitialUpdate
2020-10-08 20:58:55,941 DEBUG MetaPkgs: ubuntu-mate-core ubuntu-mate-desktop xubuntu-core
2020-10-08 20:58:59,754 DEBUG Foreign: geogebra-classic google-earth-pro-stable
2020-10-08 20:58:59,754 DEBUG Obsolete:
2020-10-08 20:58:59,754 DEBUG updateSourcesList()
2020-10-08 20:58:59,760 DEBUG rewriteSourcesList() with mirror_check
2020-10-08 20:58:59,760 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2020-10-08 20:58:59,760 DEBUG Checking pkg: ubuntu-minimal
2020-10-08 20:58:59,762 DEBUG Checking pkg: ubuntu-standard
2020-10-08 20:58:59,764 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted'
2020-10-08 20:58:59,764 DEBUG verifySourcesListEntry: deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted
2020-10-08 20:58:59,764 DEBUG url_downloadable: http://ca.archive.ubuntu.com/ubuntu//dists/focal/Release
2020-10-08 20:58:59,764 DEBUG s='http' n='ca.archive.ubuntu.com' p='/ubuntu//dists/focal/Release' q='' f=''
2020-10-08 20:59:00,424 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted' updated to new dist
2020-10-08 20:59:00,424 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted'
2020-10-08 20:59:00,424 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates main restricted' updated to new dist
2020-10-08 20:59:00,424 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic universe'
2020-10-08 20:59:00,424 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal universe' updated to new dist
2020-10-08 20:59:00,424 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe'
2020-10-08 20:59:00,424 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates universe' updated to new dist
2020-10-08 20:59:00,424 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic multiverse'
2020-10-08 20:59:00,424 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal multiverse' updated to new dist
2020-10-08 20:59:00,424 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates multiverse'
2020-10-08 20:59:00,425 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates multiverse' updated to new dist
2020-10-08 20:59:00,425 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse'
2020-10-08 20:59:00,425 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse' updated to new dist
2020-10-08 20:59:00,425 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security main restricted'
2020-10-08 20:59:00,425 DEBUG verifySourcesListEntry: deb http://security.ubuntu.com/ubuntu focal main restricted
2020-10-08 20:59:00,425 DEBUG url_downloadable: http://security.ubuntu.com/ubuntu/dists/focal/Release
2020-10-08 20:59:00,425 DEBUG s='http' n='security.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2020-10-08 20:59:01,039 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security main restricted' updated to new dist
2020-10-08 20:59:01,040 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security universe'
2020-10-08 20:59:01,040 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security universe' updated to new dist
2020-10-08 20:59:01,040 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security multiverse'
2020-10-08 20:59:01,040 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security multiverse' updated to new dist
2020-10-08 20:59:01,041 DEBUG examining: 'deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main'
2020-10-08 20:59:01,044 DEBUG entry '# deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main # disabled on upgrade to focal' was disabled (unknown mirror)
2020-10-08 20:59:01,044 DEBUG examining: 'deb http://www.geogebra.net/linux/ stable main'
2020-10-08 20:59:01,045 DEBUG entry '# deb http://www.geogebra.net/linux/ stable main # disabled on upgrade to focal' was disabled (unknown mirror)
2020-10-08 20:59:23,477 DEBUG running doUpdate() (showErrors=True)
2020-10-08 20:59:54,356 DEBUG openCache()
2020-10-08 20:59:54,997 DEBUG Comparing 4.15.0-117 with
2020-10-08 20:59:54,997 DEBUG Comparing 4.15.0-118 with 4.15.0-117
2020-10-08 20:59:55,132 DEBUG /openCache(), new cache size 66423
2020-10-08 20:59:55,132 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'xubuntu-core')
2020-10-08 20:59:55,133 DEBUG quirks: running PreDistUpgradeCache
2020-10-08 20:59:55,133 DEBUG running Quirks.PreDistUpgradeCache
2020-10-08 20:59:55,133 INFO installing python-is-python2 because python-minimal was installed
2020-10-08 20:59:55,133 DEBUG Installing 'python-is-python2' (python-minimal was installed on the system)
2020-10-08 20:59:55,274 INFO removing python-minimal because python-is-python2 is being installed
2020-10-08 20:59:55,274 DEBUG Removing 'python-minimal' (python-is-python2 is being installed on the system)
2020-10-08 20:59:55,274 INFO failed to remove python-minimal
2020-10-08 20:59:56,585 DEBUG Running KeepInstalledSection rules
2020-10-08 20:59:57,173 DEBUG Kernel uname: '4.15.0-118-generic'
2020-10-08 20:59:57,183 DEBUG nvidiaUpdate()
2020-10-08 20:59:58,095 ERROR NvidiaDetection returned a error: invalid literal for int() with base 10: 'server'
2020-10-08 20:59:58,099 DEBUG Removing 'notification-daemon' (xubuntu-core PostUpgradeRemove rule)
2020-10-08 20:59:58,100 DEBUG Removing 'ibus' (ubuntu-mate-core PostUpgradeRemove rule)
2020-10-08 20:59:58,100 DEBUG Removing 'lightdm-gtk-greeter' (ubuntu-mate-core PostUpgradeRemove rule)
2020-10-08 20:59:58,285 DEBUG Removing 'lightdm-gtk-greeter-settings' (ubuntu-mate-core PostUpgradeRemove rule)
2020-10-08 20:59:58,285 DEBUG Removing 'ibus' (ubuntu-mate-desktop PostUpgradeRemove rule)
2020-10-08 20:59:58,285 DEBUG Removing 'lightdm-gtk-greeter' (ubuntu-mate-desktop PostUpgradeRemove rule)
2020-10-08 20:59:58,285 DEBUG Removing 'lightdm-gtk-greeter-settings' (ubuntu-mate-desktop PostUpgradeRemove rule)
2020-10-08 20:59:58,286 DEBUG quirks: running PostDistUpgradeCache
2020-10-08 20:59:58,286 DEBUG running Quirks.PostDistUpgradeCache
2020-10-08 20:59:58,538 DEBUG Comparing 4.15.0-117 with
2020-10-08 20:59:58,538 DEBUG Comparing 4.15.0-118 with 4.15.0-117
2020-10-08 20:59:58,539 DEBUG Comparing 5.4.0-48 with 4.15.0-118
2020-10-08 20:59:58,662 DEBUG Marking 'xubuntu-core' for upgrade
2020-10-08 20:59:58,815 WARNING Can't mark 'xubuntu-core' for upgrade (E:Unable to correct problems, you have held broken packages.)
2020-10-08 20:59:58,815 DEBUG Marking 'ubuntu-mate-core' for upgrade
2020-10-08 20:59:58,954 WARNING Can't mark 'ubuntu-mate-core' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2020-10-08 20:59:58,955 DEBUG Marking 'ubuntu-mate-desktop' for upgrade
2020-10-08 20:59:59,098 WARNING Can't mark 'ubuntu-mate-desktop' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2020-10-08 21:02:25,020 ERROR Dist-upgrade failed: 'Broken packages after upgrade: xubuntu-core'
2020-10-08 21:02:25,023 DEBUG abort called
2020-10-08 21:02:25,027 DEBUG openCache()
2020-10-08 21:02:27,339 DEBUG Comparing 4.15.0-117 with
2020-10-08 21:02:27,340 DEBUG Comparing 4.15.0-118 with 4.15.0-117
2020-10-08 21:02:27,553 DEBUG /openCache(), new cache size 99760

Best Manfred Hampl (m-hampl) said : #7

In addition to removing xubuntu-desktop you shoudl also remove ubuntu-core and try again.

bgarnham (bgarnham) said : #8

Manfred Hampl, as you suggested, I uninstalled xubuntu-core (I'm sure that's what you meant) then ran the upgrade to Focal Fossa again and everything worked smoothly. I also reinstalled xubuntu-desktop with no problems and successfully tested it. I was well out of my depth with the upgrade issues I was experiencing so your advice was invaluable. Thank you so much for your help.

bgarnham (bgarnham) said : #9

Thanks Manfred Hampl, that solved my question.