Upgrade of Kubuntu

Asked by Paul on 2020-08-09

Checking for a new Ubuntu release
There is no development version of an LTS available.
To upgrade to the latest non-LTS development release
set Prompt=normal in /etc/update-manager/release-upgrades.

Above is the error message I get when running the suggested command on the upgrade page of wiki

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-08-09
Last reply:
2020-08-09
Manfred Hampl (m-hampl) said : #1

From which version to which version do you want to upgrade?

What is the output of the diagnostic commands

uname -a
lsb_release -crid
cat /etc/update-manager/release-upgrades.

Paul (paulbrockett) said : #2

Hi
Outputs below, thanks

Linux paul-Aspire-5750 5.4.0-42-generic #46~18.04.1-Ubuntu SMP Fri Jul 10 07:21:24 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

 Default behavior for the release upgrader.

#[DEFAULT]
# Default prompting behavior, valid options:
#
# never - Never check for, or allow upgrading to, a new release.
# normal - Check to see if a new release is available. If more than one new
# release is found, the release upgrader will attempt to upgrade to
# the supported release that immediately succeeds the
# currently-running release.
# lts - Check to see if a new LTS release is available. The upgrader
# will attempt to upgrade to the first LTS release available after
# the currently-running one. Note that if this option is used and
# the currently-running release is not itself an LTS release the
# upgrader will assume prompt was meant to be normal.

Try:

echo "Prompt=LTS" | sudo tee -a /etc/update-manager/release-upgrades > /dev/null

(its one big command).. Does that help? If you run:

sudo do-release-upgrade

Does it upgrade OK. Be sure to run a full backup before starting.

Paul (paulbrockett) said : #4

It now says:

ERROR: failed to read '/etc/update-manager/release-upgrades':
While reading from '/etc/update-manager/release-upgrades' [line 17]: option 'prompt' in section 'DEFAULT' already exists

OK, run:

cat -n /etc/update-manager/release-upgrades | grep -i prompt

What is the output please?

Paul (paulbrockett) said : #6

Hi thanks

It seemed to be stuck for a while, but this is the message:

    4 # Default prompting behavior, valid options:
    15 # upgrader will assume prompt was meant to be normal.
    16 Prompt=lts
    17 Prompt=LTS

Manfred Hampl (m-hampl) said : #7

If that is now the output, then the output of the "cat" command must have been incomplete.

Try

sudo kate /etc/update-manager/release-upgrades

and remove the last line (with LTS in caps)
Save the file, close the editor and try running the upgrade again.

What happens?

Manfred Hampl (m-hampl) said : #8

And:

How do you initiate the upgrade?

Paul (paulbrockett) said : #9

I have tried the install as per the upgrade wike page.

From the responses it may be that the ubuntu team have not released the upgrade yet.

Yeah my bad. Sorry. The line needed is in the file.

https://www.omgubuntu.co.uk/2020/08/ubuntu-20-04-1-lts-release

The first point release is available so you can upgrade online

Manfred Hampl (m-hampl) said : #12

"I have tried the install as per the upgrade wike page."

There are different possibilities, which one did you try?
Which wiki page?
Which command exactly?

Can you help with this problem?

Provide an answer of your own, or ask Paul for more information if necessary.

To post a message you must log in.