gdm gets stuck after dist-upgrade

Asked by Steven Oxley on 2009-04-29

Binary package hint: gdm

I just upgraded to 9.04 from 8.10. Everything appeared to go fine, but when I boot up, before it gets to the login screen, I get a blue background (looks like a xubuntu theme background which is what I was running prior to the upgrade) and a "busy" cursor that make it appear as though something is causing processing over and over again.

When I dig into the log files, indeed, that is what I find. For example:

#/var/log/syslog

...

Apr 29 09:50:02 sick-laptop gdm[5425]: WARNING: Couldn't authenticate user
Apr 29 09:50:33 sick-laptop last message repeated 25 times

#/var/log/auth.log

...

Apr 29 09:50:16 sick-laptop gdm[5425]: pam_nologin(gdm:auth): cannot determine username
Apr 29 09:50:47 sick-laptop last message repeated 27 times
Apr 29 09:51:49 sick-laptop last message repeated 51 times

#/var/log/gdm/:0.log

...

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 29 09:57:04 2009
(==) Using config file: "/etc/X11/xorg.conf"
f000:4b9a: 01 ILLEGAL EXTENDED X86 OPCODE!

So it appears as though gdm is trying to auto-login (even though auto-login should be disabled according to the configuration files).

I am using gdm 2.20.10 (package 2.20.10-0ubuntu2)

I have tried several things to try to fix this but so far have not been able to get to my desktop. Go to this thread to see the things I've tried: http://ubuntuforums.org/showthread.php?p=7173815#post7173815.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Oxley
Solved:
2009-05-06
Last query:
2009-05-06
Last reply:
2009-05-01

This question was originally filed as bug #369060.

Sebastien Bacher (seb128) said : #1

the issue is rather an user configuration issue or an xorg bug that a GNOME issue

Steven Oxley (steven-aj-oxley) said : #2

If it is a user configuration issue then it is an upgrade bug since the situation was caused by the upgrade. I don't see how it could be an xorg but since the only errors I'm getting are authentication errors.

Steven Oxley (steven-aj-oxley) said : #3

OK, I believe I've narrowed it down to definitely being a gdm problem. After installing kubuntu-desktop and using kdm as the desktop manager I can log in and use the KDE desktop just fine. I can also log into gnome, but I think I've messed it up somehow along the way because I don't get any panels or menus or anything - just my gnome desktop background and a cursor.

Shahar Or (mightyiam) said : #4

Are you sure you didn't do anything strange, Steven?

Did you try to reinstall gdm?

Steven Oxley (steven-aj-oxley) said : #5

I actually am quite sure I must have done something strange, but not until after I had the problems described in the original post. I did try reinstalling gdm (I did sudo apt-get remove --purge gdm and then apt-get install gdm) but after it had installed again, I got the exact same problems.

Shahar Or (mightyiam) said : #6

Did you try to press <Esc> in GRUB and going into the maintenance mode and selecting xfix (or is it fix x?)?

Steven Oxley (steven-aj-oxley) said : #7

Yes, I did try that - in fact, it's one of the first things I tried. I don't believe it is a problem with X - I tried dpkg-reconfigure xserver-xorg several times and used different backup configuration files - none of these things helped.

Shahar Or (mightyiam) said : #8

Dear Steven,

If you think that you may have done something strange then please consider reinstalling the system.

If you chose to manually partition in the next installation and you use the same setup as you had before, then your /home will not be modified.

Many blessings.

Steven Oxley (steven-aj-oxley) said : #9

I didn't do anything strange at all to get to the original problem (which I still have). I started with a working 8.10 and used Update Manager to upgrade to 9.04. Then, when the computer rebooted, I could not get to the login screen. There is clearly something wrong here that I would be glad to figure out and hopefully someone else would benefit from as well. I have come up with a temporary solution at the moment (installing kdm), so I do not have an urgent need to have this resolved, but it should definitely remain an open question until a solution is found.

OK, I believe my problem has been resolved. I have deduced that the distribution upgrade did not complete successfully even though I did not get any errors stating that anything went wrong. I went to Update Manager to update my machine today and found that something had apparently gone wrong and that it wanted to do a "partial upgrade." I allowed it to do so and now I am able to use gdm again and log into the gnome environment without any apparent problems. Thank you for your help.