No GRUB on boot, auto windows boot, UEFI GPT, also not booting into rEFInd

Asked by Mahadevan Iyer on 2020-07-30

I have installed Ubuntu Budgie ( focal fossa ), on a windows multiboot setup.

Used UEFI & GPT partition. No legacy.

After installation it booted automatically into windows 10. No GRUB.

Before boot I used Esc key + F7 key to choose bootloader.

Only from there I can enter the Ubuntu GRUB bootloader.

I also installed rEFInd, it is also working but still auto boot to windows only.

I tried sudo efibootmgr -o and change the boot order.

It worked couple of times well.

But now even after changing order successfully, everytime only WIndows auto boot up.

Please Help.

I want rEFInd as boot loader everytime I boot up.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-30
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Mahadevan Iyer for more information if necessary.

To post a message you must log in.