20.04 Desktop unresponsive to mouse and keyboard

Asked by Larry Marshall on 2020-07-27

At login, mouse moves and can select poweroff/reboot. However, once logged on, mouse left and right buttons non-response, as is the keyboard.

Both mouse and keyboard are wired.

I can get to terminal with ctrl-alt-f3. I tried 'sudo apt-get install xserver-xorg-input-all' but no change.

Monitor on both controller non-responsive.

What can I do short of re-installing?

       description: VGA compatible controller
       product: GP107 [GeForce GTX 1050 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:155 memory:63000000-63ffffff memory:50000000-5fffffff memory:60000000-61ffffff ioport:4000(size=128) memory:c0000-dffff
       description: Display controller
       product: UHD Graphics 630 (Desktop)
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:153 memory:62000000-62ffffff memory:40000000-4fffffff ioport:5000(size=64)

Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

Linux dev11 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Larry Marshall
Last query:
Last reply:

Does the system have a make and model?
Is it a dual boot?
Do you have the latest BIOS?

Larry Marshall (lcm-3) said : #2

I built it.

Gigabyte Z390 Aorus Pro motherboard
Corsaid RM750X power supply
Crucial 32GB 2400 MHz memory
Samsung PM981 512GB NVMe
Intel Core i7-8700K 3.7 GHz CPU
Crucial MX500 1TB x2

Not a dual boot

Is the USB enabled? Does it have legacy mode? Does that help? Have you tried a different USB port?

Larry Marshall (lcm-3) said : #4

Legacy USB Support - Enabled
XHCI Hand-off - Disabled
USB Mass Storage Driver Support - Enabled
Port 60/64 Emulation - Disabled

Yes, I've tried different ports. But the mouse tracks at the login screen and after logging in. It only responds to clicks while on the login screen. For example, I am able to shutdown or reboot the system before logging in using the mouse.

Larry Marshall (lcm-3) said : #5

I booted from the Ubuntu 20.04 installation USB and chose 'Try Ubuntu'.

The mouse and keyboard are working normally. I can open a terminal using keyboard shortcut, open gedit and type, etc.

Larry Marshall (lcm-3) said : #6