Cannot connect iPhone

Asked by Mika Jones on 2020-07-26

Before today I was able to connect my iPhone 5s to Ubuntu 18.04 but now it is not detected. Running lsusb doesn't show the device, and idevicepair pair shows "No device found, is it plugged in?". When plugging it in it vibrates and makes the charging sound, so I assume it is receiving power, but there is no charging indicator at the top of the screen. When trying with an iPhone 6s, it does not even make the sound. I have tried with the other USB port without success. Windows 10 (my computer is dual-booted) is able to detect the device and the charging indicator shows at the top. When turning on the computer with the device plugged in the charging indicator shows until Ubuntu is selected from Grub when it disappears again. Other devices (keyboards and mice) are detected with no problem. dmesg shows

[ 2639.564588] usb 1-3: new high-speed USB device number 12 using xhci_hcd
[ 2639.718553] usb 1-3: New USB device found, idVendor=05ac, idProduct=12a8, bcdDevice= 6.01
[ 2639.718559] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2639.718563] usb 1-3: Product: iPhone
[ 2639.718566] usb 1-3: Manufacturer: Apple Inc.
[ 2639.718568] usb 1-3: SerialNumber: af8xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[ 2639.762698] audit: type=1107 audit(1595093570.440:3473): pid=871 uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED" operation="dbus_signal" bus="system" path="/org/freedesktop/UPower" interface="org.freedesktop.UPower" member="DeviceAdded" name=":1.42" mask="receive" pid=3824 label="snap.chromium.chromium" peer_pid=1265 peer_label="unconfined"
                exe="/usr/bin/dbus-daemon" sauid=103 hostname=? addr=? terminal=?'

How can I go about fixing this? I know this is a duplicate of a billion other questions but none of them have solutions.
Killing chrome gets rid of the last dmesg entry, but doesn't fix anything.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-26
Last reply:
2020-08-13
Mika Jones (twistyturtle) said : #1

Additionally, after leaving the device plugged in for half an hour a small amount of charge was lost, so Ubuntu won't even let me charge the device.

Have you tried a different USB port or cable?
What are you connecting the phone to the system to do? Transfer data?

Mika Jones (twistyturtle) said : #3

I’ve tried multiple cables and both ports. All combinations work with Windows but not Ubuntu. Trying to transfer data/test software. Uninstalling usbmuxd (an open-source alternative to Apple’s multiplexing daemon) allows the device to charge but it is still not listed in the lsusb output. I’ve fixed the problem temporarily by reinstalling Ubuntu, but since I can’t remember any significant changes to the system that could have caused the problem in the first placeI wouldn’t be surprised if this happened again.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.