Did : apt purge evolution* and the next boot has no GUI

Asked by Bill Gradwohl on 2020-07-23

I'm sending this from a working machine. The report is for a box that now has no GUI.

I tried to get rid of evolution by :
apt purge evolution*
which was successful. Worked the rest of the day without issues.

The next morning, the GUI won't load - there's no GUI login screen.

Using terminal, journalctl show nothing of significance. Trying to startx fails. I took a photo of that output and is attached.

Could the GUI dependencies be missing something?

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: evolution (not installed)
ProcVersionSignature: Ubuntu 5.0.0-36.39~18.04.1-generic 5.0.21
Uname: Linux 5.0.0-36-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Jul 23 10:43:55 2020
InstallationDate: Installed on 2019-11-17 (248 days ago)
InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bill Gradwohl
Solved:
2020-07-24
Last query:
2020-07-24
Last reply:
2020-07-24
Kai Kasurinen (kai-kasurinen) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at https://askubuntu.com or https://ubuntuforums.org. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Kai Kasurinen (kai-kasurinen) said : #2

sudo apt install ubuntu-desktop

Bill Gradwohl (0cs935-bill) said : #3

Kai:

Thank you. That brought up the GUI and I can successfully run apps.