Epson Workforce 633 in Ubuntu 20.04

Asked by Frank Gilmurray on 2020-07-21

I'd like to move to 20.04 but I can't get my networked Epson WorkForce 633 working. It works perfect in 18.04. When I trouble shot the problem in 20.04 (via Help/F1), it said there were 2files missing both in /usr/lib/cups/filter/, namely 'commandtoepson' and 'rastertogutenprint.5.3'. I copied these from my 18.04 system and sym linked rastertogutenprint.5.2 (from 18.04) to rastertogutenprint.5.3. Fortunately both of these files were dynamically linked to the same library on 18.04 and 20.04. Now the printer shows no problems and the 'Print Self-Test Page' even worked but nothing else; not the 'Print Test Page' nor any other file. The print requests just sit in the print queue stopped.

Am I missing something? Is there some package I need to install? I installed 20.04 via the CLI upgrade from 18.04 rather than a fresh install. I'm stumped. Any help would be much appreciated.

Thanks, Frank

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Best Manfred Hampl (m-hampl) said : #1

Instead of copying files from Ubuntu 18.04 to Ubuntu 20.04 you should have installed the correct packages.

/usr/lib/cups/filter/rastertogutenprint.5.3 and /usr/lib/cups/filter/commandtoepson are provided by the package printer-driver-gutenprint

I suggest that you undo your changes and execute the command
sudo apt install printer-driver-gutenprint

Frank Gilmurray (fgilmurray) said : #2

Thank you. That solved my problem and my pronter is working again.