Files do no recognize a Lets Encrypt SSH certificate

Asked by Andre Metelo on 2020-06-28

I tried to find any references for this question, but I could not find anything close to the issue.

I have a WebDAV server using a Letsencrypt certificate. When I access it through any browser (Chrome, Firefox), the certificate is valid an all goes well. It also works from the default Mac OS file browser. Windows is a no go, as it never worked from the get-go due to a "feature" on its WebDAV client, and a non-issue for us.

However, when I try to use the default Files app from Ubuntu 16.04, 18.04, and 20.04 to connect to that server through the +Other Locations option (Dave://, it says the certificate authority is not known.

Is this done on purpose (I mean not including the Letencrypt CA by default) Or just a mishappening somewhere?


ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: file 1:5.38-4
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Jun 28 14:53:00 2020
InstallationDate: Installed on 2020-04-25 (64 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: file
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Andre Metelo
Last query:
Last reply:
Kai Kasurinen (kai-kasurinen) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community or asking at or For help on reporting bugs, see

Kai Kasurinen (kai-kasurinen) said : #2

Does your server send Let’s Encrypt Authority X3 intermediate certificate also?

Andre Metelo (metelo) said : #3

thanks Kai.

Sorry for posting on the wrong place.

IT seems that certbot is not configuring the site properly. As soon as I put the full chain line form the link it started working.

Again, thanks and sorry for posting in the wrong place.