Ubuntu freezes after resume from suspend in 10-15 sec

Asked by AlekseyK

Asked her as well: https://askubuntu.com/questions/1247968/ubuntu-freezes-after-resume-from-suspend-hibernate-in-10-15-sec

Bought new laptop - [Dell Latitude-5501][1] with Ubuntu 18.04.4. Works fine, however the only problem exists: after I close laptop cover or after some time of inactivity Ubuntu suspends or hibernate (do not know). After I resume it, it starts to work but in 10-15 sec Ubuntu freezes and I forced to power-off.

Tried many things mentioned here:

- blacklist nouveau
- install older kernel - 4.14.41
- update to newer - 4.18 or latest 5.3 kernel
- switch to proprietary nvidia driver (was installed by default)
- install `lightdm` instead of `gdm3`
- dell software had run some recent firmware upgrade
- etc

Nothing work - it still freezes and it is impossible to work. The only suggestion I did not tried yet: install kubuntu and then original nvidia driver from manufacturer site. Do not know however if it affects warranty? ;) Any ideas how to solve, how to diagnose? Thanks!

System, hardware and security logs during suspend/resume attached (original 4.15 kernel):

- [System.log](https://pastebin.com/0Ttnu7T9)
- [Security.log](https://pastebin.com/Wme1y1wM)
- [Hardware.log](https://pastebin.com/ujUS5Ce4)

Logs for 4.18 kernel are slightly different:

- [System_4.18.log](https://pastebin.com/WVNXiFdA)
- [Hardware_4.18.log](https://pastebin.com/RphtPj0w)
- [Software_4.18.log](https://pastebin.com/CwypQ4VF)
- [Security_4.18.log](https://pastebin.com/VV2ck2un)

  [1]: https://www.dell.com/ru/business/p/latitude-15-5501-laptop/pd

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Do you have the latest BIOS?

Revision history for this message
AlekseyK (tantrido) said :
#2

Of course, as I mentioned above Dell installed latest automatically.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

What is the output of:

sudo dmidecode -t 1

Thanks

Revision history for this message
AlekseyK (tantrido) said :
#4

$ sudo dmidecode -t 1

# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.2.1 present.
# SMBIOS implementations newer than version 3.1.1 are not
# fully supported by this version of dmidecode.

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: Dell Inc.
 Product Name: Latitude 5501
 Version: Not Specified
 Serial Number: B22N3X2
 UUID: 4C4C4544-0032-3210-804E-C2C04F335832
 Wake-up Type: Power Switch
 SKU Number: 0919
 Family: Latitude

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5
Revision history for this message
AlekseyK (tantrido) said :
#6

But how to installe it? It is exe - Windows which I have not. I run some Dell BIOS update from Linux, however do not remember how I did it.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7
Revision history for this message
AlekseyK (tantrido) said :
#8

Ubuntu Software Management have some Dell BIOS update today including POWER management system - updating... Will report results here.

Revision history for this message
AlekseyK (tantrido) said :
#9

Thanks for the link, however I see Ubuntu Software Management installs exactly mentioned BIOS version - 1.9.1, so I won't flash exe manually. This Dell-Ubuntu software update automation excites of course!

Revision history for this message
AlekseyK (tantrido) said :
#10

Hurray!!! Seems BIOS upgrade works!!! Resumed without a problem! Thanks much!

Revision history for this message
AlekseyK (tantrido) said :
#11

Thanks actionparsnip, that solved my question.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#12

Strange isn't it. BIOS updates are important

Revision history for this message
AlekseyK (tantrido) said :
#13

No :( helped only partially. When laptop went on suspend by 20 min timeout it freezes after resume again. So not solved!

Revision history for this message
AlekseyK (tantrido) said :
#14

Now freezes after cover open as well, so not solved at all!

Revision history for this message
Bernard Stafford (bernard010) said :
#15

https://help.ubuntu.com/stable/ubuntu-help/power-suspendfail.html.en

You may try pressing the (Fn) key or (Enter) key.

Revision history for this message
AlekseyK (tantrido) said :
#16

Problem is that it resumes ok and then freezes in 10-15 sec. Your link describes situation when it does not resume at all.

Revision history for this message
AlekseyK (tantrido) said :
#18

Solved by fresh Ubuntu 20.04 install: https://askubuntu.com/a/1248893/130585

The only problem remained: artifacts on the screen after resume. How to solve?

Can you help with this problem?

Provide an answer of your own, or ask AlekseyK for more information if necessary.

To post a message you must log in.