16.04 install initramfs fails with exit status 1

Asked by Exe Cute on 2020-06-05

I'm trying to install 16.04 in an attempt to resolve an issue with my Radeon 7870 XT (16.04 is the latest LTS that it works on, at all) and the installation exited with the above error code.

My hw: 2x4GB DDR3 1600Hz RAM Sticks, Core i3-4150 CPU @ 3.50GHz × 4, llvmpipe (LLVM 6.0, 256 bits) (no idea what that is), 256 GB Sata3 SSD, Motherboard Gigabyte H81M-D2W (not D2V)

/var/log/syslog here: https://gitlab.com/exe-cute/logsnstuff/-/blob/master/2020_06_05_var_log_syslog

Btw I had an issue with "initramfs extracting failed" with 20.04 in case that helps.

I also have not booted the installation yet to preserve the syslog, will try now.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-06-18
Last reply:
2020-06-19

Is this on the first boot of the install, please or is it the USB / CD media booting up?

Exe Cute (exe-cute) said : #2

It's not in boot, it's an error message on the live system right at the end of the installation. Should I report any other logs/info before I reboot?

Does the install complete OK?

Exe Cute (exe-cute) said : #4

Aside from the vague error message at the end the installation went smoothly, I haven't restarted yet for the possibility of a log being needed that would otherwise be erased.

if the install is OK then I'd go fo it. You could make a copy of the contents of /var/log just in case....

Exe Cute (exe-cute) said : #6

Yeah, that's what I did above, but thanks.

Exe Cute (exe-cute) said : #7

If you test your RAM health using Memtest86 from GRUB is it OK?

Exe Cute (exe-cute) said : #9

I suspected that as well, but two passes with 0 errors so far.

Manfred Hampl (m-hampl) said : #10

My suggestions:

1. try repairing the installation with the instructions in https://www.omgubuntu.co.uk/2011/09/live-usb-sticking-grub-2-video
You probably should add the command
sudo update-initramfs
between "sudo chroot /mnt" and "grub-install /dev/sda"

or
2. Do a new install

Exe Cute (exe-cute) said : #11

All right, I did reinstall onto 18.04.4 and still get the same problem. Could the problem lie in wrong partitioning? I have 50-ish MB boot, then 8GB swap and 188 GB for /. Also I use the same partition layout that worked for 20.04, replacing EFI for boot.

Manfred Hampl (m-hampl) said : #12

50 MB for boot is far too small, you should allocate at least 250 MB, preferably even more.

Depending on the options in force an initrd.img file can be bigger than 50 MB.

From your log:
Jun 5 13:35:31 ubuntu ubiquity: update-initramfs: Generating /boot/initrd.img-4.15.0-45-generic
Jun 5 13:35:40 ubuntu ubiquity:
Jun 5 13:35:40 ubuntu ubiquity: gzip: stdout: No space left on device
Jun 5 13:35:40 ubuntu ubiquity: E: mkinitramfs failure cpio 141 gzip 1

Can you help with this problem?

Provide an answer of your own, or ask Exe Cute for more information if necessary.

To post a message you must log in.