wallpaper is (black). Only bottom bar is visible. Clicking on Application Manager or Task Manger icons yield error messages that a file is missing

Asked by Joel Denney on 2020-05-21

(note: initial post)
Installed new PLASMA theme. Didn't seem to fully work.
Used the DISCOVER ap to try to find the theme again & uninstall. Since I didn't remember its name I clicked on the INSTALLED choice but found nothing wrt installed Theme or Look & Feel.
Went through all the choices for Theme, etc looking for one that showed as installed. Nothing.
Figured I might as well go ahead & just install a new theme. Big mistake.
Screen is now entirely black, except for the bottom bar (forget name) w/ small icons for basic functions. BUT
The icons for Task Manager & Application Launcher return similar error messages:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:27:1: module "org.kde.plasma.private.taskmanager" is not installed

or

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kickoff/contents/ui/Kickoff.qml:31:1: module "org.kde.plasma.private.kicker" is not installed

I can access Dolphin (file manager) via "Most Recent Device" icon, see external drives, then open an html document, which gets Firefox which gets me here.
Can't access Terminal w/ Ctr-Alt-T (or "t"). Only access I've found is during boot up, but I'm not allowed access to many files/folders (or asked for password).
Trying various combinations of Ctr-Alt+ letter, I somehow received the following error message:

Plasma Search - System Settings Module
Configure Search Bar
The shared library was not found
Possible reasons:
--An error occurred during your last KDE upgrade, leaving an orphaned control module.
--You have old 3rd party modules lying around.
Check these points carefully & try to remove the module mentioned in the error message. If this fails, consider contacting... distributor...

I'm tempted to reinstall 18.04 or move to 20.04 but figure I've caused myself enough trouble for this month. (I'll tell you the trouble I caused myself last month, which may have something to do with this month's trouble if really necessary. Month before that was a system crash).

note: I'm a Jan 2020 refugee from Win7, still trying to find my way around.
Thanks for any help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Joel Denney
Solved:
2020-05-25
Last query:
2020-05-25
Last reply:
2020-05-24

How did you install the theme and where did you get it from please?

Joel Denney (rjoeld) said : #2

Used "Discover" ap from "Application Launcher" which then shows a menu & sub-menus of types of aps. One of the 3 main options is something like Plasma Add-ons". (Can't open the Discover Ap now, so can't be exact). Thanks for you response

Joel Denney (rjoeld) said : #3

typos
"Plasma Add-ons"
...your response

Joel Denney (rjoeld) said : #5

I haven't figured out a workaround to get a terminal to open, which all those solutions require.
I get File Manager (Dolphin) open by opening a file via the Most Recent Device icon in the ?quick launch? bar (w/ clock, audio, etc)
So, I can open & see files at that point, including root directory
But...
after choosing a file, I can't access the right-click option menu - I get a blank (white) box. The menu bar does the same thing (left, center, or right click). The file opens with whatever the default program is.
(Once open, the mouse buttons bring the usual, visible, options - so mouse is OK)
When I try to open a root directory file, I have the option to either "open" the file or "execute" it
Might *executing* a particular .exe file (or some other extension) be productive?

Joel Denney (rjoeld) said : #6

-- I.e. Where is the .exe file for Terminal/Console/whatever-it's-called?

-- I'm new to this world. I hope I was clear that the themes came via the KDE channel

konsole

Press CTRL + ALT + T and it'll appear. It lives in the /usr/bin directory

Joel Denney (rjoeld) said : #8

Thank you. Although CTRL + ALT + T hasn't been working, knowing where the konsole file is lets me run it "directly", which gets a konsole window!! Now I can explore the various options previously mentioned. The responses are much appreciated.

I'm declaring the problem solved, because it'll probably take me a while to test the options. If I'm still stuck, I'll reinstall 18.04