no wifi adapter found - ubuntu 20.04 LTS - Dell E7440

Asked by Sankalp on 2020-05-19

Hi,

I have made several attempts to configure wifi on my ubuntu however I have not been able to succeed so far. I have a Dell E7440 laptop and I have my ubuntu 20.04 lts configured on oracle vm.

I have tried several proposed solutions to reinstall, update softwares but none of those have worked.

Any help to resolve this will be appreciated.

Thanks
Sankalp

Solutions tried so far
https://www.youtube.com/watch?v=dokG4bCF4GQ
https://www.youtube.com/watch?v=8o0XYfRn5sc
https://www.youtube.com/watch?v=XxB6asfgKOc

lshw -C network

 *-network
       description: Ethernet interface
       product: 82540EM Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       logical name: enp0s3
       version: 02
       serial: 08:00:27:02:03:5f
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=192.168.178.206 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:19 memory:f8200000-f821ffff ioport:d020(size=8)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-05-19
Last reply:
2020-05-19

Is ubuntu installed in a VM using Virtualbox? If so then the hardware is abstracted and will show as an Ethernet device in the VM

Is this the case please?

Sankalp (sankalpkulkarni) said : #2

Hello,

You are right, it is a Virtualbox.

Then it won't be seen as a wireless adapter. The hardware is all virtual. Are you wanting to do some wifi cracking stuff by any chance?

The fact that it isn't wireless is irrelevant otherwise. You will connect to the web. It's all abstracted for you

Sankalp (sankalpkulkarni) said : #5

I cannot connect to internet without a LAN cable connected.

What OS is the host running and does that connect OK

Sankalp (sankalpkulkarni) said : #7

Host OS is Windows 10 and wifi works fine on that

Can you help with this problem?

Provide an answer of your own, or ask Sankalp for more information if necessary.

To post a message you must log in.