Drives unviewable in Samba despite being mounted

Asked by Christian Mantuano on 2020-05-17

Ubuntu 20.04 LTS (Desktop)

I'm unable to view my mounted drives in the 'Other Locations' directory in the file explorer. lsblk shows that the drives are mounted at the correct locations specified in the FSTAB. I can navigate to the drives and access them directly, despite not showing up in the 'other locations' directory. I cannot access this drive on other machines when navigating to the network share. What is wrong?

excerpt from lsblk:

sda
└─sda1 ext4 Storage 759e847e-1eba-4676-b73c-a9ae111aa6c3 8.2T 4% /mnt/storage

Part of smb.conf

[NAS]
 comment = NAS
 browseable = yes
 path = /mnt/Storage/
 read only = no
 guest ok = yes
 force user = root
 force group = root
 force directory mode = 0777
 force create mode = 0777

excerpt from /etc/fstab

UUID=759e847e-1eba-4676-b73c-a9ae111aa6c3 /mnt/storage ext4 defaults 0 0

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Christian Mantuano
Solved:
2020-05-18
Last query:
2020-05-18
Last reply:
2020-05-18

If you open nautilus in the /mnt/Storage folder you can add it to your bookmarks and it'll show in the left hand panel.

Alternatively, make a symlink to your home folder so it appears next to your Downloads and Documents folders for simple access. The symlink will also make terminal access easier too

Christian Mantuano (litesung) said : #3

That's not the problem - I said I can access the files by navigating to them directly. The problem is that the drives cannot be shared when they are in this location and can only be shared/viewable when in the /media/ directory rather than the /mnt/ directory.

Why would you want to share something which is already shared on another system?

Or can the systems accessing what would be the shares on the NAS not hit the NAS directly?

Christian Mantuano (litesung) said : #6

This issue was resolved by adding the x-gvfs-show flag to the respective drives in /etc/fstab. Once this was done, the drives located in the /mnt/ directory were now visible in file explorer and were able to be accessed.

Christian Mantuano (litesung) said : #7

Marking as 'Problem Resolved'

Please see the comment above for the resolution if you are experiencing the same issue.