cannot open shared object file

Asked by Tommy Pollák

After upgrade from Ubuntu 19.10 to 20.4 my Ruby on Rails applications do not work any longer.
Starting stops with error message:
/home/*usernane*/railsprojects/OTK-register/vendor/bundle/ruby/2.7.0/gems/activesupport- `require': cannot open shared object file: No such file or directory - /home/*username*/railsprojects/OTK-register/vendor/bundle/ruby/2.7.0/gems/ffi-1.12.2/lib/ (LoadError)

I have tried to uninstall ffi and do 'sudo apt-get install libffi libffi-dev' but this does not work, there is no libffi. Then 'gem install ffi' this works and installs ffi-1.12.2. But this does not help at all.

/home/*username*/railsprojects/OTK-register/vendor/bundle/ruby/2.7.0/gems/ffi-1.12.2/lib/ contains but I can not find anywhere, nor

How can I create and where should it be? Alterantively how can I remove the dependency on

As you can see I am using Ruby 2.7.0 and Rail

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Seems the package upgraded the library for you

If you run:

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/

Does it work OK?

Revision history for this message
Manfred Hampl (m-hampl) said :

ruby2.7 (2.7.0-5ubuntu1) from the Ubuntu repositories has a dependency on and no more

From which source is your ruby installation?

Revision history for this message
Tommy Pollák (tommy.pollak) said :

Thanks actionparsnip, that solved my question.

Revision history for this message
Tommy Pollák (tommy.pollak) said :

To Manfred: It is old. Worked on 19.10.