Postfix can't send an email

Asked by lgplay on 2020-03-29

I have a Problem with Postfix, when I try to email somebody it emails me back with the following error,
and I also can't receive emails from other email services like Gmail. I installed it with iRedMail and this tutorrial https://www.linuxbabe.com/mail-server/ubuntu-16-04-iredmail-server-installation

Transcript of session follows.

 Out: 220 mail.mydomain.de ESMTP Postfix
 In: EHLO [192.168.2.120]
 Out: 250-mail.mydomain.de
 Out: 250-PIPELINING
 Out: 250-SIZE 15728640
 Out: 250-ETRN
 Out: 250-STARTTLS
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250-DSN
 Out: 250 SMTPUTF8
 In: STARTTLS
 Out: 454 4.7.0 TLS not available due to local problem
 In: QUIT
 Out: 221 2.0.0 Bye

For other details, see the local mail logfile

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
lgplay
Solved:
2020-03-30
Last query:
2020-03-30
Last reply:
2020-03-30

Can you telnet to port 25 on the recipient email server or the next internal email server if you are using another internal server to relay through?

What is the output of:

lsb_release -a; uname -a; apt-cache policy postfix

Thanks

lgplay (lgplay) said : #2

Thanks for helping me here is the Output I got:

When I use telnet on windows and "telnet" my pc I get this:
220-mail.domain.de ESMTP Postfix
220 mail.domain.de ESMTP Postfix

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
Linux 0381f6b5-60a5-45da-8e05-10e40e02a2a9 2.6.32-openvz-042stab140.4-amd64 #1 SMP Fri Oct 11 11:36:40 MSK 2019 x86_64 x86_64 x86_64 GNU/Linux
postfix:
  Installed: 3.1.0-3ubuntu0.3
  Candidate: 3.1.0-3ubuntu0.3
  Version table:
 *** 3.1.0-3ubuntu0.3 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.1.0-3 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Manfred Hampl (m-hampl) said : #3

I assume the important message is "TLS not available due to local problem"
Are you sure that you have TLS configured correctly?
Are there any messages referring to TLS in the local mail logfile?

lgplay (lgplay) said : #4

Hi, thank you for your message,

So I looked into the log file and it displays this https://hastebin.com/xomumekogo.sql
I think the problem is something with my certificate I got from certbot, I already checked if
the chain.pem is at this file and yes it is there, can someone tell me how to fix this?

lgplay (lgplay) said : #5

Hi, So I solved the problem and discovered I am an Idiot, sorry for losing your time.
The problem was my domain is not .com its .de

Thanks for helping me