Unable to boot ubuntu 19.10 or newer on dell xps 9570

Asked by Alistair Burrowes on 2020-03-28

Hi,

Since updating my dell xps 9570 (latest BIOS 1.15.0 and a few previous versions) from 19.04 to 19.10 I have been unable to boot ubuntu. It fails with the following error quickly flashing:

  error: file `/boot/` not found

Then followed by:

  error: cannot allocate kernel buffer.
  error: you need to load the kernel first.

  press any key to continue...

This occurs when doing an update from 19.04 to 19.10 and also when just booting off a usb drive with 19.10.

When booting off the usb drive. The first error flashes quickly before displaying the usb installer options. Selecting any install / boot option results in the second error about kernel buffer.

I have tried all combinations of bios settings I can think of, such as toggling secure boot and other options. The only thing that made a difference is booting via USB with LEGACY EXTERNAL DEVICE BOOT. This allows the installer to complete, but I cannot then boot off the hard drive.

I have tried the same USB drive with 19.10 on a Dell XPS 7590 with BIOS 1.2.3 and the USB stick boots fine. I have also tried many different USB drives on my 9570.

I have tried a few daily builds of 20.04 with the same result. Most recently I tried the current version 2020-03-24 09:40.

Note: 19.04 and earlier continues to work no problem.

I have asked on askbuntu.com and not found a solution https://askubuntu.com/questions/1183129/19-10-usb-installer-boot-fail

Update: Tested with 20.04 beta and same result.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-28
Last reply:
2020-03-28

Have you tried Ubuntu 20.04? It is released soon and is LTS unlike Ubuntu 19.10. The newer packages may help

Alistair Burrowes (afburrowes) said : #2

@actionparsnip No as mentioned I have tried a few daily builds of 20.04 and they made no difference.

Can you help with this problem?

Provide an answer of your own, or ask Alistair Burrowes for more information if necessary.

To post a message you must log in.