No sound on Lenovo X1 Carbon after recent update (19.10)

Asked by S Barmeier on 2020-03-27

I usually keep my system up-to-date and am running 19.10 on a Lenovo X1 Carbon. Sound support has been patchy with volume control for the inbuilt speakers not working (only 0% or 100%). However, after a recent update (about a week ago) the sound completely stopped working, showing only "Dummy Output" as output device (and no sound of course).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-03-28
Last query:
2020-03-28
Last reply:
2020-03-28
Best Manfred Hampl (m-hampl) said : #1

Several people have reported sound problems after an upgrade of the kernel packages, and you probably experience the same problem.
A bug report Bug #1868165 has already been created.
As a workaround: Sound should work, if you select an older kernel (in the grub menu).
A new version of the kernel packages is already in development and will hopefully be published soon.

Ubuntu 20.04 is out soon. Upgrading to that may help

S Barmeier (severinbarmeier) said : #3

Thanks Manfred Hampl, that solved my question.