Can't upgrade and can't install LAMP (Ubuntu 8.10)

Asked by Eric

First I am using Ubuntu 8.10. My primary objective is to install LAMP in order to make some tests.

Unfortunately, I don't have detailed log of my errors but here is what I am trying to do.

After an installation with the alternate CD on an old laptop, I connected it on the internet.

I refreshed the list of available applications to downloads and it worked. Then it told me that there is something like 238 updates that needs to be applied. I started to download these updates and it worked. When it tried to update my system it gives me an error message during the process. Now I have around 219 updates that needs to be done. So probably it made 20 updates, bugged and did not make the other update. After this, I had a problem booting the new kernel ?.?.12, so I need to boot with ?.?.7 (sorry, don't remember the starting numbers).

So I connected the computer on the internet and use tasksel and tried to install LAMP. It does not work. I tried using the command line "sudo tasksel install lamp-server" it dos not works. I tried using apt-get with "sudo apt-get install lamp-server^" it works a bit by checking dependencies and at some point the installation fail. I tried installing a basic server, in case it was a requirement to lamp, and it does not work using any of the methods above.

So how can I install updates, or at least install the ones that could work?
Is there another way to install LAMP?

Now my last solution is to instert the alternate CD and try updating with the CD. That is what I am going to try now. I just hope I can install LAMP from this CD.

Thank you
As you can see, I am new to Ubuntu, but not new to linux.It's just that it has been a while since I have used linux.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Rached ALAYA
Last query:
Last reply:
Revision history for this message
Rached ALAYA (rached.alaya) said :

here is what you have to do :
1- open a terminal and tape : sudo apt-get install -f
this command should force the install of brpoken or uncompleted packages
PS : this step is not related to the next step (n°2)
2-try to use this command : sudo aptitude install apache2 php5 mysql-server php5-mysql libapache2-mod-php5 phpmyadmin
Thanks, RachedTN

Revision history for this message
Eric (larienna) said :

I tried running tasksel with the CD to install lamp. It game me error:

"taskset: aptitude failed(100)"

I will be trying the line of codes above soon.

Thanks again.

Revision history for this message
Best Rached ALAYA (rached.alaya) said :

the desktop CD doesn't include LAMP server
Only the Server CD does include LAMP server
there is also another solution which is to download the XAMPP package and extract it and use it, here is the how to do :
1- download XAMPP :
2- extract the package : sudo tar xvfz xampp-linux-1.5.3a.tar.gz -C /opt
3- start XAMPP : sudo /opt/lampp/lampp start
Here is a nice tutorial about XAMPP :
I hope this solve your problem :)

Revision history for this message
Eric (larienna) said :

I tried "sudo apt-get install -f" and I got

dpkg: parse error, in file '/var/lib/spkg/status' near line 22799 package 'adbbs':
error in Version string '268435456': nothing after colon in version number
E: Sub-process /usr/bin/dpkg/ returned an error code (2)

Then I tried installing XAMPP

and it seems to work.

Now I need to install yaz and try my software.

Revision history for this message
Eric (larienna) said :

Thanks Rached ALEYA, that solved my question.

Revision history for this message
Rached ALAYA (rached.alaya) said :

I suggest that you execute this command : sudo apt-gt autoclean
then try again to install LAMP