Couldn't register with accessibility bus:

Asked by ealthuis on 2020-03-23

Suddenly this message came up while using "sudo gedit filename":

** (gedit:2692): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I would appreciate some suggestion as to what may be wrong. It seems to me a hardware problem. I have no way of checking.

The computer is a desktop with a just installed and updated version of Ubuntu 18.04 LTS

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-03-24
Last query:
2020-03-24
Last reply:
2020-03-24
ealthuis (ealthuis) said : #1

I need to know if this is hardware or software related.

What is the output of:

apt-cache policy gedit; lsb_release -a; uname -a

Thanks

ealthuis (ealthuis) said : #3

ea@discovery:~$ apt-cache policy gedit
gedit:
  Installed: 3.22.1-3ubuntu1
  Candidate: 3.28.1-1ubuntu1.2
  Version table:
     3.28.1-1ubuntu1.2 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     3.28.1-1ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
 *** 3.22.1-3ubuntu1 100
        100 /var/lib/dpkg/status
ea@discovery:~$ uname -a
Linux discovery 4.15.0-91-generic #92-Ubuntu SMP Fri Feb 28 11:09:48 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
ea@discovery:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04
Codename: bionic
ea@discovery:~$

Best Manfred Hampl (m-hampl) said : #4

"with a just installed and updated version of Ubuntu 18.04 LTS"

"gedit:
   Installed: 3.22.1-3ubuntu1
   Candidate: 3.28.1-1ubuntu1.2"

These two pieces of Information are contradictory.

Your system is not correctly updated to the most current status of bionic.

Also "Description: Ubuntu Bionic Beaver (development branch)" is obsolete. Bionic is not the development branch any more.

I suggest that you update all packages to the newest status and try again.
Another option is a new Installation of Ubuntu Bionic from the newest installation medium. It seems to me that you started with a pre-release installer (probably a daily version from the time when development of Bionic was still running).

ealthuis (ealthuis) said : #5

Thanks Manfred Hampl, that solved my question.