Recovering windows 10 backup on Ubuntu

Asked by Harry Dogerman on 2020-03-23

I am transitioning to Ubuntu from Windows 10. Before installing the new OS, I made a full backup of my windows 10, expecting to extract individual files from the backup on my Ubuntu. Now I'm stuck with a bunch of .xml and .vhdx files How do I proceed?

I have already tried https://stackoverflow.com/questions/36819474/how-can-i-attach-a-vhdx-or-vhd-file-in-linux/37790474 and failed with the following error message:

guestmount: no operating system was found on this disk

Here is the full error message:

tsidia@tsidia-System-Product-Name:/media/tsidia/SP PHD U3/WindowsImageBackup/DESKTOP-HG1003T/Backup 2020-03-22 140135$ guestmount -a c3c7f9c3-0000-0000-0000-501f00000000.vhdx -i -r /home/tsidia/Desktop/Backup
libguestfs: trace: set_verbose true
libguestfs: trace: set_verbose = 0
libguestfs: create: flags = 0, handle = 0x5578c9a3a3b0, program = guestmount
libguestfs: trace: set_recovery_proc false
libguestfs: trace: set_recovery_proc = 0
libguestfs: trace: add_drive "c3c7f9c3-0000-0000-0000-501f00000000.vhdx" "readonly:true"
libguestfs: creating COW overlay to protect original drive content
libguestfs: trace: get_tmpdir
libguestfs: trace: get_tmpdir = "/tmp"
libguestfs: trace: disk_create "/tmp/libguestfsjxBRSb/overlay1.qcow2" "qcow2" -1 "backingfile:/media/tsidia/SP PHD U3/WindowsImageBackup/DESKTOP-HG1003T/Backup 2020-03-22 140135/c3c7f9c3-0000-0000-0000-501f00000000.vhdx"
libguestfs: command: run: qemu-img
libguestfs: command: run: \ create
libguestfs: command: run: \ -f qcow2
libguestfs: command: run: \ -o backing_file=/media/tsidia/SP PHD U3/WindowsImageBackup/DESKTOP-HG1003T/Backup 2020-03-22 140135/c3c7f9c3-0000-0000-0000-501f00000000.vhdx
libguestfs: command: run: \ /tmp/libguestfsjxBRSb/overlay1.qcow2
qemu-img: /tmp/libguestfsjxBRSb/overlay1.qcow2: VHDX image file '/media/tsidia/SP PHD U3/WindowsImageBackup/DESKTOP-HG1003T/Backup 2020-03-22 140135/c3c7f9c3-0000-0000-0000-501f00000000.vhdx' opened read-only, but contains a log that needs to be replayed
To replay the log, run:
qemu-img check -r all '/media/tsidia/SP PHD U3/WindowsImageBackup/DESKTOP-HG1003T/Backup 2020-03-22 140135/c3c7f9c3-0000-0000-0000-501f00000000.vhdx'
Could not open backing image to determine size.
libguestfs: error: qemu-img: /tmp/libguestfsjxBRSb/overlay1.qcow2: qemu-img exited with error status 1, see debug messages above
libguestfs: trace: disk_create = -1 (error)
libguestfs: trace: add_drive = -1 (error)
libguestfs: trace: close
libguestfs: closing guestfs handle 0x5578c9a3a3b0 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /tmp/libguestfsjxBRSb

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Harry Dogerman
Solved:
2020-03-23
Last query:
2020-03-23
Last reply:
Harry Dogerman (tsidia) said : #1

I was in the wrong directory

alokod kaloi (sibierji) said : #2

I purchased another PC with Windows introduced on it. I'm going to wipe all segments and introduce Ubuntu. One day I'll most likely sell that PC, so it'll be pleasant to recuperate it to the maker state. I need to reinforcement recuperation parcel, spare it to some record and keep that in cloud. One day I'll reestablish it and reinstall Windows from the recuperation segment. What instruments would it be advisable for me to use to make it easy? I attempted a few Windows devices with my present PC when I originally got it, however following 3 years I can't recoup the parcel. I made the reinforcement on Windows, so now I would prefer not to commit a similar error twice.
https://kodi.software/
https://luckypatcher.cam/
https://nox.tips/