unable to install canon lbp2900b printer in ubuntu 19.10

Asked by B.V.VARMA on 2020-03-23

Dear Si/Madam,

I am unable to install canon lbp 2900b printer in ubuntu 19.10. Kindly help me with steps. I am using 64 bit.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-26
Last reply:
2020-04-11
B.V.VARMA (varmabv29) said : #2

I downloaded tar.gz file but unable to install. I extracted files in that but there is no ./configure file in the extracted folder. Kindly help me to install it completely. I will be thankful if my problem is solved. Thank you...

Manfred Hampl (m-hampl) said : #3

When you have downloaded and extracted the tar.gz file, change directory into the subdirectory linux-capt-drv-v271-uken/64-bit_Driver/Debian/ and issue the command

sudo dpkg -i *.deb

What output do you receive?

B.V.VARMA (varmabv29) said : #4

This is the output I received

(Reading database ... 191206 files and directories currently installed.)
Preparing to unpack cndrvcups-capt_2.71-1_amd64.deb ...
Unpacking cndrvcups-capt (2.71-1) over (2.71-1) ...
Preparing to unpack cndrvcups-common_3.21-1_amd64.deb ...
Unpacking cndrvcups-common (3.21-1) over (3.21-1) ...
dpkg: dependency problems prevent configuration of cndrvcups-capt:
 cndrvcups-capt depends on libglade2-0 (>= 1:2.5.1); however:
  Package libglade2-0 is not installed.
 cndrvcups-capt depends on libgtk2.0-0 (>= 2.8.0); however:
  Package libgtk2.0-0 is not installed.

dpkg: error processing package cndrvcups-capt (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cndrvcups-common:
 cndrvcups-common depends on libglade2-0 (>= 1:2.5.1); however:
  Package libglade2-0 is not installed.
 cndrvcups-common depends on libgtk2.0-0 (>= 2.8.0); however:
  Package libgtk2.0-0 is not installed.

dpkg: error processing package cndrvcups-common (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (242-7ubuntu3.7) ...
Errors were encountered while processing:
 cndrvcups-capt
 cndrvcups-common

B.V.VARMA (varmabv29) said : #5

after updating from the terminal I got output given below...

(Reading database ... 191304 files and directories currently installed.)
Preparing to unpack cndrvcups-capt_2.71-1_amd64.deb ...
Unpacking cndrvcups-capt (2.71-1) over (2.71-1) ...
Preparing to unpack cndrvcups-common_3.21-1_amd64.deb ...
Unpacking cndrvcups-common (3.21-1) over (3.21-1) ...
Setting up cndrvcups-common (3.21-1) ...
Setting up cndrvcups-capt (2.71-1) ...
Processing triggers for systemd (242-7ubuntu3.7) ...

Manfred Hampl (m-hampl) said : #6

This looks good.
Can you now activate and use the printer?

B.V.VARMA (varmabv29) said : #7

I added printer from add printer under settings. Everything looks good but not printing even testpage. I am getting print job completed message on top but no printout...

Clear the print queue. Can you print from gedit?

B.V.VARMA (varmabv29) said : #9

Not able to print from gedit or office writer.... don't know where is the problem.... Kindly help...

Manfred Hampl (m-hampl) said : #10

Do you see the printer queue if you open
http://localhost:631
with your web browser?

Launchpad Janitor (janitor) said : #11

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.