imprimante brother ql-700 label printer

Asked by Bullet on 2020-03-20

imprimante brother ql-700 label printer

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-20
Last reply:
2020-03-20

How does it connect to the system please?
What is the output of:

lsb_release -a; uname -a; lsusb

Thanks

Bullet (angeleyes972) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Focal Fossa (development branch)
Release: 20.04
Codename: focal

Linux bullet-HP-Pavilion-Power-Desktop-580-0xx 5.4.0-18-generic #22-Ubuntu SMP Sat Mar 7 18:13:06 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0846:9021 NetGear, Inc. WNA3100M(v1) Wireless-N 300 [Realtek RTL8192CU]
Bus 001 Device 005: ID 8087:0aa7 Intel Corp.
Bus 001 Device 004: ID 0bda:0153 Realtek Semiconductor Corp. 3-in-1 (SD/SDHC/SDXC) Card Reader
Bus 001 Device 003: ID 04ca:008e Lite-On Technology Corp. HP USB Multimedia Keyboard
Bus 001 Device 009: ID 04f9:2042 Brother Industries, Ltd QL-700
Bus 001 Device 002: ID 0461:4e66 Primax Electronics, Ltd HP USB Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Did you install the debs from the Brother website? They may drivers for a lot of their kit for Linux

cd ~/Downloads
wget https://download.brother.com/welcome/dlfp002192/ql700pdrv-3.1.5-0.i386.deb
sudo dpkg -i ./ql700pdrv-3.1.5-0.i386.deb
sudo apt-get -f install

Should do it

Bullet (angeleyes972) said : #6

I downloaded my file I run it, the software tells me that the file is ready and after tells me impossible to install the file: it is not supported, the only indication that I have it is in the system settings, when I go there I have 3 printer that appears Brother-ql-700, ql-700-2, qul700, impossible to print even having tried with the 3 yet my printer is connect well

even by the way download it from this site :

   https://support.brother.com/g/b/downloadhowto.aspx?c=gb&lang=en&prod=lpql700euk&os=130&dlid=dlfp002192_000&flang=178&type3=10309

Bullet (angeleyes972) said : #7

sudo dpkg -i --force-all ql700pdrv-3.1.5-0.i386.deb
dpkg: concernant ql700pdrv-3.1.5-0.i386.deb contenant ql700pdrv:i386 :
 ql700pdrv:i386 entre en conflit avec ql700cupswrapper
  « ql700cupswrapper:i386 » (version « 1.0.1-1 ») est présent ainsi que « installé ».

dpkg: avertissement: conflit ignoré, il est peut-être possible de continuer malgré tout.
(Lecture de la base de données... 199525 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de ql700pdrv-3.1.5-0.i386.deb ...
Restarting cups (via systemctl): cups.service.
Dépaquetage de ql700pdrv:i386 (3.1.5) sur (3.1.5) ...
Restarting cups (via systemctl): cups.service.
Paramétrage de ql700pdrv:i386 (3.1.5) ...
Restarting cups (via systemctl): cups.service.
lpadmin -p QL700 -E -v usb://Brother/QL-700?serial=000B7Z702725 -P /usr/share/cups/model/Brother/brother_ql700_printer_en.ppd
lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.

Bullet (angeleyes972) said : #8

bullet@bullet-HP-Pavilion-Power-Desktop-580-0xx:~/Téléchargements$ sudo apt remove ql700cupswrapper
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cabextract dleyna-renderer fonts-wine geoip-database glib-networking:i386
  gnome-online-miners gstreamer1.0-plugins-base:i386 imagemagick-6-common
  libaa1:i386 libamd2 libapt-pkg5.90 libavc1394-0:i386 libbabl-0.1-0
  libbind9-161 libblas3 libcaca0:i386 libcairo-gobject2:i386 libcairo2:i386
  libcamd2 libcap2:i386 libccolamd2 libcdparanoia0:i386 libcholmod3 libcroco3
  libdbus-1-3:i386 libdns-export1107 libdns1107 libdns1109 libdv4:i386
  libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libfribidi0:i386
  libfwupdplugin1 libgcab-1.0-0 libgdbm6:i386 libgegl-0.4-0 libgegl-common
  libgeoip1 libgfbgraph-0.2-0 libgfortran5 libglib2.0-0:i386 libgmp10:i386
  libgnutls30:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhogweed5:i386 libicu65 libicu65:i386 libicu66:i386
  libilmbase24 libirs161 libisc-export1104 libisc1104 libisc1105 libisccc161
  libisccfg163 libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblapack3 liblqr-1-0
  liblwres161 libmagickcore-6.q16-6 libmagickwand-6.q16-6 libmetis5
  libmozjs-60-0 libmspack0 libnettle7:i386 libnuma1:i386 libogg0:i386
  libopenexr24 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpcap0.8:i386 libpci3:i386 libpixman-1-0:i386 libpng16-16:i386
  libproxy1v5:i386 libpsl5:i386 libpython2-stdlib libpython2.7-minimal
  libpython2.7-stdlib libraw1394-11:i386 libsdl2-2.0-0 libslang2:i386
  libsmbios-c2 libsqlite3-0:i386 libssl1.1:i386 libtasn1-6:i386
  libtheora0:i386 libtss2-esys0 libumfpack5 libusb-1.0-0:i386
  libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxml2:i386 libxrender1:i386 libzapojit-0.0-0 python2
  python2-minimal python2.7 python2.7-minimal tpm-udev
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  ql700cupswrapper:i386
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 199525 fichiers et répertoires déjà installés.
)
Suppression de ql700cupswrapper:i386 (1.0.1-1) ...
lpadmin : The printer or class does not exist.
Restarting cups (via systemctl): cups.service.

Bullet (angeleyes972) said : #9

no changes after uninstalling the package that appeared to be causing the conflict

It sounds like you can extract the deb and get the PPD out then run the command given. Doesn't need the deb installing (Bit sneaky)

Bullet (angeleyes972) said : #11

I just extracted the deb but I don't know what you call the PPD

Bullet (angeleyes972) said : #12

no change

The pod is a file in the deb file. If you run the same command as the post install script ran (the lpadmin command but point to the ppd file you extracted) then it may work

Can you help with this problem?

Provide an answer of your own, or ask Bullet for more information if necessary.

To post a message you must log in.