Wifi link speed randomizing and usually slow

Asked by Rodrigo Guariento on 2020-02-08

I'm usually turn on my Ubuntu 18.04 LTS and my wifi connection stay at 5Mb/s. My access point is aside my laptop, ~2 meters. Other PC and SO connect to it at 100Mb/s, including our smartphones. Sometimes I turn on my Ubuntu 18.04 LTS and my wifi is 40, or 72, but most part of time is 5MB/s.

In Wi-Fi Settings, I can see:
Signal Strength: Good
Link speed: 5Mb/s
Security: WPA2

And using shell command:

$ sudo iwconfig
wlp2s0 IEEE 802.11 ESSID:"Marte"
          Mode:Managed Frequency:2.437 GHz Access Point: xx:xx:xx:xx:xx:xx
          Bit Rate=5.5 Mb/s Tx-Power=200 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=63/70 Signal level=-47 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

$ sudo lshw -class network
  *-network
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 01
       serial: xx:xx:xx:xx:xx:xx
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=192.168.0.14 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:f6c00000-f6c03fff

I tried a bunch of things and nothing, including reinstalling BCM4313 driver, added "options iw0 11n_disable=1" at end of file "/etc/modprobe.d/iwlwifi.conf", disabled "sudo iwconfig wlp2s0 power off", fixed CRDA with "$ sudo iw reg get" and "$ sudo nano /etc/default/crda" with REGDOMAIN=xx with my country code https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2, and nothing has been solved.

Suggestions? My Laptop is Samsung model RF511. Thank you.

* I have changed some MAC addresses by xx:xx:xx:xx:xx:xx on purpose.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-02-12
Last query:
2020-02-12
Last reply:
2020-02-09
Manfred Hampl (m-hampl) said : #1

Which driver and from which source did you install?

Remark: According to your output you are using the wl0 driver, but the modprobe setting "options iw0 11n_disable=1" is for a driver named iw0. This does not fit together.

possible further reading: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

I'm using the same driver since Ubuntu has been installed. I've opened Synaptic Package Manager and over "bcmwl-kernel-source" (6.30.223.271+bdco "Broadcom 802.11 Linux STA wireless driver source) I've clicked over option "Mark for Reinstallation".

In Software & Updates, the "Broadcom Limited: BCM4313 802.11bgn Wireless Network Adapter" have "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)" selected (installed).

After read this link, I discovered:
$ lspci -vvnn | grep -A 9 Network
02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
 Subsystem: Wistron NeWeb Corp. BCM4313 802.11bgn Wireless Network Adapter [185f:051a]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at f6c00000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: wl
 Kernel modules: bcma, wl

It means that I'm using wrong driver, am I right? According the https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx , the correct driver for Chip ID BCM 4313 is brcmsmac driver (Open-source). If it is right, I need to find and install brcmfmac driver and after follow the steps under "Switching between drivers". I will try. Thank you!

Best Manfred Hampl (m-hampl) said : #3

For several broadcom devices you have the choice between different drivers. I would not say that you are using "the wrong one". I just want to suggest that you try a different one to check whether it works better.

Thanks Manfred Hampl, that solved my question.