video projector no more detected in X mode

Asked by Michel Plasse on 2020-02-07

Hello,

I have ubuntu 18.04. The video projector, which was displaying correctly my labtop screen is no more detecting it, in X mode (it detects it and displays it correctly in console mode).

I have tried to change the resolution to one supported by the video, with no result. Previously, when plugging the projector, my system automatically changed the resolution to conform to the projector one. I have tried many commands found browsing the Web, with no effect. Maybe an important config file has been corrupted or removed, but which one, and how to solve the issue, I have no idea.

My labtop is toshiba satellite pro u400-130. I have tried 2 projectors: EPSON H849B and Dell 1410X.

Here is the output of the step 2 command found in https://help.ubuntu.com/community/GraphicsTroubleshootingProcedure:

Module Size Used by
ccm 20480 6
rfcomm 61440 4
bnep 20480 2
uvcvideo 81920 0
videobuf2_vmalloc 16384 1 uvcvideo
videobuf2_memops 16384 1 videobuf2_vmalloc
videobuf2_v4l2 20480 1 uvcvideo
videobuf2_core 36864 2 uvcvideo,videobuf2_v4l2
videodev 155648 3 uvcvideo,videobuf2_core,videobuf2_v4l2
media 32768 2 uvcvideo,videodev
btusb 40960 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 16384 1 btusb
bluetooth 466944 31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
ecdh_generic 28672 1 bluetooth
wmi_bmof 16384 0
snd_hda_codec_conexant 24576 1
snd_hda_codec_generic 69632 1 snd_hda_codec_conexant
snd_hda_intel 36864 5
coretemp 16384 0
snd_hda_codec 106496 3 snd_hda_intel,snd_hda_codec_conexant,snd_hda_codec_generic
arc4 16384 2
snd_hda_core 65536 4 snd_hda_intel,snd_hda_codec_conexant,snd_hda_codec,snd_hda_codec_generic
snd_hwdep 16384 1 snd_hda_codec
iwldvm 204800 0
i915 1282048 21
kvm 520192 0
mac80211 675840 1 iwldvm
snd_pcm 86016 4 snd_hda_intel,snd_hda_codec,snd_hda_core
drm_kms_helper 151552 1 i915
irqbypass 16384 1 kvm
snd_seq_midi 16384 0
input_leds 16384 0
joydev 20480 0
iwlwifi 249856 1 iwldvm
snd_seq_midi_event 16384 1 snd_seq_midi
drm 339968 9 i915,drm_kms_helper
serio_raw 16384 0
snd_rawmidi 28672 1 snd_seq_midi
cfg80211 532480 3 iwlwifi,mac80211,iwldvm
i2c_algo_bit 16384 1 i915
fb_sys_fops 16384 1 drm_kms_helper
snd_seq 57344 2 snd_seq_midi_event,snd_seq_midi
lpc_ich 24576 0
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 28672 2 snd_seq,snd_pcm
snd 69632 19 snd_hda_intel,snd_hwdep,snd_hda_codec_conexant,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_generic,snd_seq_device,snd_pcm
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
soundcore 16384 1 snd
toshiba_acpi 40960 0
toshiba_haps 16384 0
sparse_keymap 16384 1 toshiba_acpi
shpchp 32768 0
sysimgblt 16384 1 drm_kms_helper
industrialio 57344 1 toshiba_acpi
toshiba_bluetooth 16384 0
wmi 20480 2 wmi_bmof,toshiba_acpi
mac_hid 16384 0
video 40960 2 toshiba_acpi,i915
binfmt_misc 20480 1
sch_fq_codel 20480 6
parport_pc 32768 0
ppdev 20480 0
lp 20480 0
parport 45056 3 lp,parport_pc,ppdev
ip_tables 20480 0
x_tables 28672 1 ip_tables
autofs4 40960 2
firewire_ohci 36864 0
ahci 36864 2
psmouse 131072 0
firewire_core 57344 1 firewire_ohci
sdhci_pci 28672 0
sdhci 45056 1 sdhci_pci
crc_itu_t 16384 1 firewire_core
sky2 53248 0
libahci 32768 1 ahci

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Michel Plasse
Solved:
2020-02-07
Last query:
2020-02-07
Last reply:
Michel Plasse (michel.plasse) said : #2

Finally, after 2 days of investigations, I found a partial solution in https://forum.ubuntu-fr.org/viewtopic.php?id=444936.
My xorg.conf had disappeared after an unexpected shutdown. I have done what was explained: copy the /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf, reboot and run a final command.

sudo cp /etc/X11/xorg.conf.failsafe /etc/X11/xorg.conf.failsafe.copy
sudo mv /etc/X11/xorg.conf.failsafe /etc/X11/xorg.conf
reboot

And after reboot:
sudo dpkg-reconfigure xserver-xorg

Excellent share. Hopefully this will help others